Phones forum


Samsung Galaxy S3 Mini won't send MMS messages!

by NadsG1985 / October 2, 2013 2:52 AM PDT

My Samsung Galaxy S3 Mini (GT-18190N) won't send MMS messages, whenever I try I get 'message not sent, service not activated on network, server response error'. My network resent the CP message and when I check it in the menu it says installed. I tried installing again and switching the phone on and off but it still doesn't work. Is there anything else I can do such as remove specific apps or would resetting the device help? (which I would rather avoid) any help would be greatly appreciated, thank you!

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Samsung Galaxy S3 Mini won't send MMS messages!
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Samsung Galaxy S3 Mini won't send MMS messages!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
I took a quick google on that
by R. Proffitt Forum moderator / October 2, 2013 3:08 AM PDT

And it reads as if your cellular carrier needs to enable this for your plan or they need to tell you how to set it up.

Collapse -
Samsung Galaxy S3
by usmanahmedi / October 4, 2013 4:07 PM PDT

i think you must check your message setting surely there must some problem there set your service provider number right then you get better results.

Note: This post was edited by a forum moderator to remove promotional link on 10/09/2013 at 11:29 AM PT

Collapse -
MMS messages
by AkkiJ / October 8, 2013 5:23 PM PDT

Now a days nobody use MMS service. If you want to use MMS service, you have to tell your telecom service provider & MMS service also requires net.

So my suggestion to you is that use apps instead of MMS.

Note: This post was edited by a forum moderator to remove promotional link on 10/09/2013 at 10:58 AM PT

Collapse -
Not quite....
by birdmantd Forum moderator / October 9, 2013 4:46 AM PDT
In reply to: MMS messages

Virtually all cellular carriers automatically enable MMS and text messaging by default on the account. The carriers consider such features (including data plans) as a cash cow instead of phone call airtime in this day and age.

I suspect that the OP either doesn't have data enabled on the account or the SMS settings are not setup correctly on the device.

Collapse -
turn off wifi and try again
by catholicmom38 / October 9, 2013 12:33 PM PDT

Turn off wifi and try again.

Check that you can connect to the internet with data.

Collapse -
* Solution Found !
by scelaschi / December 25, 2013 1:04 AM PST

for Android phones I found this to work:

From your phone dial pad type the following:


This will activate your network and apply the correct settings

Hope this helps!

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions


Having Wi-Fi troubles?

From the garage to the basement, we blanketed every square inch of the CNET Smart Home with fast, reliable Wi-Fi.