Samsung forum

Question

Samsung BD5700 no longer can connect to Netflix

by grofree / November 22, 2013 11:41 AM PST

I have had my Samsung BD5700 blu ray player for about a year and have been streaming Netflix somewhat successfully. 2 days ago it stopped wokring. Cannot connect to the internet. The internet connection is fine and netflix plays on other devices. I have searched the forum and tried, the reset, the up up down down etc on the remote, resetting my time zone, updated software, unplugging the device... nothing still doesn't work. There are lots of posts on this forum that are in the 2011/12 time frame. Anyone having his issue recently and does anyone have any other suggestions? so frustrating!

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Samsung BD5700 no longer can connect to Netflix
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Samsung BD5700 no longer can connect to Netflix
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
Were you able to figure it out?
by EWestTX26 / December 21, 2013 2:14 PM PST

My Samsung BD-D5700 Netflix went out around the same time too (latter November) with the 'cannot connect to Internet' message, and I have tried everything to troubleshoot, including wiring my player to the modem and reinstalling netflix after a full reset. Calling Netflix they just said it's a known issue and they're working with Samsung on an app update. No word yet. It's been a month. Anyone else else hear anything or able to figure it out?

Collapse -
Lost netfix connection on Samsung blu ray BD-d5700
by grofree / December 21, 2013 9:42 PM PST

No I have not been able to stream Netflix since nov 20. I logged a ticket with Samsung then did a follow up chat with a Samsung customer service rep. He had many troubleshooting suggestions all of which I had tried. In the end he said I would have to wait for a fix and there was no way to know how long that would be. I am trying to be patient but at some point I will replace the player and write Samsung off as a company I will make future purchases from.

Collapse -
Re: Lost netfix connection on Samsung blu ray BD-d5700
by Samsung_HD_Tech Samsung staff / December 29, 2013 11:40 PM PST
Collapse -
No Netflix since 11/20
by grofree / December 30, 2013 2:42 AM PST

My firmware is 1032.1

Collapse -
Re: No Netflix since 11/20
by Samsung_HD_Tech Samsung staff / December 31, 2013 4:13 AM PST
In reply to: No Netflix since 11/20

Hi grofree,

Thanks for the information. This means you are up to date on your firmware. Do you have trouble accessing any other apps?

Regards,
HD Tech

Collapse -
No Netflix since 11/20
by grofree / December 31, 2013 7:10 AM PST

It is only Netflix that doesn't work. I have an Internet connection for other apps. Netflix works on other devices in my house. Was there a software update on or around 11/20?

Collapse -
My problem was my router
by EWestTX26 / January 1, 2014 1:32 PM PST
In reply to: No Netflix since 11/20

Hey,

I gave up on my Samsung BD-D5700 player that stopped playing Netflix last November and got a Google Chromecast player to stream Netflix to our main television. But setting up the Chromecast player also said there was a problem with my network. I was so baffled because all of my other devices work! (We have a ROKU in the other room that plays Netflix, our Wii streams netflix without a problem, and our iPads and such connect to the internet and stream nicely). It was just Netflix on the Samsung Bluray that kept giving me the "Cannot connect to the Internet" message--even though YouTube and the other online apps on the player were working fine.

I was about to jump through the ceiling with Google Chromecast now saying it couldn't connect to the internet when so many other devices in my house connect without a problem. But when I wondered if my router specifications were incompatible with the Chromecast (being a new device), I realized that I had never updated the firmware in my actual router. I've had the router for about five years (a D-Link DIR-615).

I plugged my computer into my router, completely reset it to factory settings then did a full update of the firmware. With the updated router, Chromecast installed nicely, and then I pulled up Netflix on the Samsung DVD player and (after setting it up again since I redid the router) it's working as it used to, so now I can use the Chromecast elsewhere in the house.

I hope this is a permanent fix and I will keep you posted. I realize this may not be other people's problem, but this is what took care of it for me.

Collapse -
same problem
by yppy11 / January 18, 2014 12:44 AM PST

I have just purchased the LAN adapter and set up our blu ray and have the exact problem with netflix. Youtube is working but I do have the exact same router so I will try what you have done and update the firmware once I figure out how to do that thanks for the post.

Collapse -
Netflix works after firmware update
by grofree / January 18, 2014 6:56 AM PST
In reply to: same problem

This was a frustrating experience as well.although I was set for automatic updates it had never updated. I ended up having to download it manually. There were instructions on the website. Let me know if you cannot find them and I can try to help.

Collapse -
firmware update
by yppy11 / January 19, 2014 12:26 AM PST

I have tried to update firmware but am coming up with a message that says the upload for file in not correct? I have emailed D-Link support so we will see what happens. yes very frustrating

Collapse -
Firmware updates
by grofree / January 19, 2014 5:03 AM PST
In reply to: firmware update
Collapse -
firmware update
by yppy11 / January 19, 2014 7:02 AM PST
In reply to: Firmware updates

finally got it to upload, just tried a different browser, IE instead of chrome and it went through no problem.

All Answers

Collapse -
Answer
Cannot connect to the internet.
by R. Proffitt Forum moderator / November 22, 2013 11:47 AM PST

Unless you can fix that, don't waste time. I can't tell if you tried the usual wired connection, changed to the often mentioned Google DNS.

Also, the servers do go out of service so I can't guess if you called in and asked or not. I don't have a pulse on that so folk must call.
Bob

Collapse -
Cannot connect to netflix sm
by grofree / November 22, 2013 10:39 PM PST

The bluray is not in a place I can easily get a wired connection to. The up up down down produces a box but deactivate is not an option. Netfix plays on my other tv and iPad. I don't know what the google dsn option is.
Thank 4 the reply.

Collapse -
Here's a link about the Google DNS
by R. Proffitt Forum moderator / November 22, 2013 11:33 PM PST

Remember I take for granted at times that folk will research what they didn't know but understand that this is a techy area. Here's a note about this.

http://answers.us.samsung.com/answers/7463/product/BD-E5400/samsung-bd-e5400-questions-answers/questions.htm

"Thank you for contacting Samsung.

We recommend you make sure your player has the latest firmware. A new update was just released on 11/29/2012.

http://www.samsung.com/us/support/owners/product/BD-E5400

Additionally, go to Settings > Network > Network Status and once the network test runs, go to IP Settings > DNS Mode > change to Manual and then go to DNS server and enter 8.8.8.8 (which is Google's DNS) and press enter, then highlight OK and press enter.

Thank you for being a Samsung customer!

The Samsung Online Support Team "

By the way the second DNS entry should be 8.8.4.4

--> But the fact you can't run the cable is bad news. For such setups we must be inside 20 feet to the router or else there can be WiFi distance issues. These are not as good as laptops on distance. If that's a problem you get wired or return the product as I have yet to find these to be that good at long distance.
Bob

Collapse -
Samsung forum: Samsung BD5700 no longer can connect to Netfl
by grofree / November 23, 2013 11:10 AM PST

Thanks for the info on the Google DSN. Unfortunately that did not work. The bluray is in the basement almost directly under the router and the signal there is very good. I have been playing netflix there for almost a year until it stopped the other day with the cannot conect to the internet message. Like I said earlier the internet connection is fine (i can play YouTube no problem)and this is the same problem that was reported by many in the 2011/12 time frame.

Collapse -
And remember that Samsung server up or down issue?
by R. Proffitt Forum moderator / November 23, 2013 11:36 PM PST

There were a few posts over the past few days that folk were saying they went down.

Keep in mind that I always assume members are calling into Samsung to ask. I don't keep track of that detail.
Bob

Collapse -
Samsung forum: Samsung D5700 no longer can connect to Netfli
by grofree / November 24, 2013 7:11 PM PST

Read something else about the esn number being wrong for the model. Mine has a D670 in it which indicated it is wrong but no instructions on how to change it

Collapse -
And did you call in?
by R. Proffitt Forum moderator / November 24, 2013 10:52 PM PST
Collapse -
Samsung D5700 no longer can connect to Netflix
by grofree / November 25, 2013 2:29 AM PST
In reply to: And did you call in?

Thanks for the info. After reading all the frustration with the Samsung customer service I have not called in. This may be my issue but I have been down with Netflix since 11/20 way more than the 12 hours cited in this post. When they say the smart hub is down, I assume I would not be able to connect to anything ie YouTube...What do you think about the netflix esn number?

Collapse -
And imagine my take on this.
by R. Proffitt Forum moderator / November 25, 2013 4:24 AM PST

I can't make those calls for owners. And it wastes everyone's time so I'm probably going to upset you here as it's like me stopping to help change a tire on your car and you climb back into the car and wait for me to finish.

Please help along here.

1. It's well discussed that if there is a Samsung issue, many apps fail.
2. ESN? Netflix and Samsung have a system to check that out. I don't.
Bob

Collapse -
Re: Samsung D5700 no longer can connect to Netflix
by Samsung_HD_Tech Samsung staff / November 25, 2013 5:01 AM PST
Collapse -
Samsung D5700 no longer can connect to Netflix
by grofree / November 25, 2013 5:26 AM PST

HD Tech,
Neither of these will work for me I have tried them both.
The problem is "cannot connect to the internet".
On my PC I have already tried signing out of my devices. In fact when I launch Netflix on my ipad I had to relog in so I know it worked. But the instructions say "after netflix launches".... netflix never launches on the samsung device. it says CANNOT CONNECT TO THE INTERNET.
I have the same issue with deactivating on the bluray. I have already reset the player.
The instruction on step 2 "The netflix splash screen appears" the netflix screen does not appear i get the message CANNOT CONNECT TO THE INTERNET.
Please offer some other suggestion. It is only Netflix I am having the issue with on the samsung bluray.

Collapse -
Re: Samsung D5700 no longer can connect to Netflix
by wjl411 / November 25, 2013 10:50 AM PST

HD Tech,

I too have a D5700 and right about the same time, 11/20/13, I've been getting the "Not connected to the Internet. Please check your connection and try again." error message at the splash screen. This is happening only with Netflix. I can connect just fine with Pandora, Hulu, Youtube, every other app in Smart Hub. I'm able to watch Netflix on my laptop, so I know it's not a Netflix issue.

I've taken every troubleshooting step presented in forums addressing this issue and nothing is working. Could there be a setting change that was pushed out inadvertently which is causing this issue with the D5700 device? Please rectify, I'm miss watching Netflix on my TV, which is where it should be watched, not on a laptop screen.

Model # BD-D5700-ZA
software version: BSP-D5700ZA-1032.1

Bill

Collapse -
Re: Samsung D5700 no longer can connect to Netflix
by grofree / November 25, 2013 7:13 PM PST

I have the same version of software. 1032.1.
Just want to point out that there was a software update available and which I downloaded after I started experiencing this problem(after I reset the player) but the update did not resolve the issue.

Collapse -
D5700 no longer connection to netflix
by grofree / December 5, 2013 3:01 AM PST

Are you still having the issue. mine has not been resolved

Collapse -
Answer
Tip. Watch out for forum bottom.
by R. Proffitt Forum moderator / December 5, 2013 3:35 AM PST

If you reply to a deep post you may end up with a post no one can reply to.

Collapse -
Answer
Netflix issue resolved with router firmware update
by grofree / January 11, 2014 9:37 AM PST

Thank you so much EWestTX26 for posting your solution. I have Cisco EA2700 and after 3 hours on an on line chatwith Cisco support, I determined that I did not have the most current firmware and how to manually download and install it. Netflix is back up and running. I still don't understand why on nov 19 Netflix worked and on nov 20 it stopped. The firmware update is from 2012. The only possibility I can think of is that in that same approximate time period comcast sent me an email "good news we have upgraded your Internet speed

Collapse -
Answer
FIXED! For me...
by saintandrewsfall / February 25, 2014 1:45 PM PST

I updated my router's firmware and also noticed the router's time/date was off by more than a year, so I changed it to the current time and date. I think the later might have been the problem since my tablet won't play netflix unless the date is correct. Hope that helps!

Collapse -
THANKS FOR THE CONFIRMATION.
by R. Proffitt Forum moderator / February 26, 2014 12:30 AM PST
In reply to: FIXED! For me...
Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Smartphone tip

Hoarding photos on your phone?

Those picture are hogging memory and could be slowing down your phone.