Well, there are different resolutions that people have posted on the internet. I tried everyting from adding exceptions to firewall policy, disabling firewall, completely uninstalling firewall, changing compatibility mode, setting privilages as administrator, etc. None worked. The solution is kind of odd, yet it worked for me: changing regional settings format to English !

Hope it helps someone who is looking for a solution Happy