Windows 7 forum

Question

robocopy with DCOPY:T does not work

by lele528020 / May 21, 2013 12:26 PM PDT

I am using Win7, the switch DCOPY:T can be used (I mean there is no parameter error) in the command robocopy C:\TEST F:\test \E \MIR \COPYALL \DCOPY:T BUT! folder stamps are not preserved except for folders that does not have more folder under it, i.e., all folders that have other subfolders under them are not getting time stamps preserved. What is going on here? I googled for 2h and still cannot find thread asking the same question. Thank you very much!

I ran cmd elevated.

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: robocopy with DCOPY:T does not work
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: robocopy with DCOPY:T does not work
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
back or forward slashes?
by R. Proffitt Forum moderator / May 21, 2013 10:59 PM PDT

For years I've used the forward slash for command line parameters and backslash for the folder names.

Could it be that?

ABOUT the time stamps. On NTFS there are three time stamps so if you copy to say FAT32 you might lose one. Not only that, the DIR may not show all three stamps.
Bob

All Answers

Collapse -
Answer
solved, but still confused
by lele528020 / May 21, 2013 1:18 PM PDT

I later on tried /copy:t first, which only copies the directory tree with the original time stamp. and then /copyall, this time all data are copy with original time stamp into those folders that have correct time stamp. So it is OK now. But still, I am confused why /copyall at the first place does not work, why bother to do this two-step copy.

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Big stars on small screens

Smosh tells CNET what it took to make it big online

Internet sensations Ian Hecox and Anthony Padilla discuss how YouTube has changed and why among all their goals, "real TV" isn't an ambition.