Office & Productivity Software forum

General discussion

Repeat as header row at the top of each page - Not working

by multiplex7777 / June 19, 2008 1:20 PM PDT


I'm using Word 2007 tables. I'm trying to get the header row to repeat at the top of each page.

So I've SELECTED the top row, gone into Table Properties --> Row tab. The "Repeat as header row at the top of each page" checkbox is SELECTED but is greyed out.

But the header row is not repeating across pages.

Any reason why this is not working?

Thanks for the help.

Discussion is locked
You are posting a reply to: Repeat as header row at the top of each page - Not working
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Repeat as header row at the top of each page - Not working
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Does this happen ...
by Kees Bakker / June 19, 2008 5:27 PM PDT

in a new document with only this table?

Or is, on the contrary, an existing document, converted 5 years ago from WordPerfect and heavily edited afterwards?

Or something in between?

I suspect there's "something" with the document. Sometimes a piecemeal copy/paste to a new document helps.


Collapse -
Repeat as header row at the top of each page
by multiplex7777 / June 19, 2008 7:57 PM PDT
In reply to: Does this happen ...

I found the reason why. The table was joined to an earlier table (which had gridlines hidden). Once I disconnected the table, the header row appeared on all pages.


Collapse -
Table disconnect?
by diman82 / August 12, 2008 11:44 PM PDT

How do you disconnect the main table from the previous one (with the gridlines described)?

Collapse -
RE: Table disconnect?
by multiplex7777 / August 13, 2008 11:09 AM PDT
In reply to: Table disconnect?

I selected the relevant rows, Ctrl-X then Ctrl-V into a separate area on the page.

Collapse -
another way to disconnect the table
by woradit / February 1, 2013 12:20 PM PST
In reply to: Table disconnect?
Collapse -
here's how to fix it, at least in Word 2007
by bheiser / October 1, 2008 9:39 AM PDT

I've repeatedly experienced this in Word 2003 and now in Word 2007, but I think I've found a repeatable solution.

The problem seems to be caused by selecting the "repeat as header row" option while selecting the whole table, or maybe even just some non-header rows. Here's how to fix it.
- Select the whole table.
- De-select the "repeat as header row" option
- Select just the header row
- Select the "repeat as header row" option
This is working for me now in Word 2007, YMMV Happy

Collapse -
by multiplex7777 / October 1, 2008 12:38 PM PDT

Thanks for your reply. I discovered the problem was because the table was accidentally joined to another table above, so Word was confused which table header to use. Once I separated the two tables, everything was ok.

Collapse -
Re: thanks
by bheiser / October 2, 2008 4:19 AM PDT
In reply to: Thanks

OK, thanks, I'll watch for that one too Happy

Collapse -
That solved the problem!
by MrBillB / January 28, 2009 1:59 AM PST

I've been fighting with that problem for a while now and your solution fixed the issue.

Collapse -
And if all else fails...
by MathLion / October 21, 2009 5:24 AM PDT

I tried all of the suggestions above with no luck. (I'm using Office 2007.) The document I'm working on came from a template that someone else created, so I'm not sure what's different about this table. I tried copying the entire table into a fresh document, with no other tables, and it still behaved the same way. No repeating headings. (sigh) I tried one last thing, and it worked!
1. Copied entire table to my clipboard.
2. Pasted as text into Excel spreadsheet.
3. Created new table in Word document.
4. Copied entire Excel spreadsheet (active col/rows) to clipboard.
5. Pasted as plain text into new Word document.
6. Defined top row as heading row and specified "repeat header row."
I had to redo the formatting on the table, but I got my headings to repeat on each page. Woo-hoo!!!

Collapse -
by ricksil2000 / May 7, 2012 7:32 AM PDT

Thanks Mathlion, that worked!

Collapse -
Thank you for this solution!
by jennbedell / March 16, 2010 4:05 AM PDT

Thank you, thank you, thank you! I spent a few minutes on this problem before doing a Google search. This fixed it! Quick and simple. It saved me an hour of frustration trying to figure it out myself.

Collapse -
Your solution worked...
by TruthMiner / July 22, 2010 12:02 PM PDT

...perfectly. Thank you for posting it. Obviously an undocumented Word "feature". Wink

Collapse -
it worked !
by alligator768 / August 16, 2010 3:10 AM PDT

your steps to uncheck the option at the table level then re-check for just the header row worked, thanks for posting!

Collapse -
A little more information
by member_raj / November 29, 2010 1:09 PM PST

With the above steps, also make sure that Select All - Table properties,in the Table Tab, Text Wrapping is set as "None" instead of "Around".This solution worked for Word-2003.

Collapse -
this worked for me also for word - 2010
by kedikasharath / February 20, 2012 3:19 PM PST
Collapse -
Word 2007 Here's how to fix it
by Neil2327 / December 11, 2010 3:50 AM PST

Brilliant! I spent half an hour trying to figure out what was going on and applied your solution and had it working within mihutes. Many thanks for sharing your learning.

Collapse -
by sleek_chic / January 18, 2011 10:14 PM PST

Thanks a lot. Your solution worked for me

Collapse -
(NT) Brilliant! Works great in Crapola Word 2007
by Hone_Heke / October 19, 2011 11:58 AM PDT
Collapse -
This worked for me...thanks!!!!
by VickyVale / November 15, 2011 10:47 PM PST
Collapse -
Good call. MS should show a message.
by bhCSI / February 16, 2012 10:27 PM PST

When selecting the "repeat as header row" option with the entire table selected, Word should display a message such as "Please select header row(s) only" rather than just do nothing. The other option was to find your solution. Thanks Happy

Collapse -
Another potential solution
by AlanD2005 / April 27, 2010 1:13 AM PDT

I had a similiar problem with the headers not repeating after cutting and pasting an excel 2003 grid into Word 2003. After following these steps the header appeared across the page as expected.
1) Deselect, if necessary, the Headers Across the rows checkbox in the Table Properities.
2) Select some or all of the rows in the table, right click and select "Distribute Rows Evenly", although I ended up doing this a few times to get the rows the way I wanted them.
3) Select the header row, and reselect the Headers Across Rows Checkbox.

Collapse -
Word 2007 Table - Heading Row Does not Repeat!
by laobrien / May 17, 2010 11:08 PM PDT

If you run into problem with Heading Row not repeating, you need to rule out that this could be due to the Table's text wrapping property - it should be set to NONE: Right click any cell in the table > Table Properties > Table tab > Text Wrapping Property > select NONE.

Collapse -
Word 2007 Table - Repeat Header Row (Text Wrapping Fix)
by doormattb / November 11, 2010 4:34 AM PST

Yea -- I just had this problem and it was 100% the text wrapping issue. laobrien is exactly right. Changing text wrapping to NONE in the table tab of table properties fixes it instantly.

Not the most intuitive thing in the world... Thanks Microsoft

Collapse -
Word 2007 Table - Repeat Header Row (Text Wrapping Fix)
by lynnsimpson8103 / December 26, 2010 10:25 PM PST

Same here. Setting Text Wrapping to none solves my header row problem as well - no need for me to copy & paste. Thanks for posting this!

Collapse -
Check to make sure you're table isn't "nested" in another
by kaffa2 / March 7, 2011 2:17 AM PST

I found the solution in my case...even though it didn't look like it, my table was "inside" of a blank table with blank columns to the right and left. I found this by turning on gridlines:

Layout-->Table-->View Gridlines

Once I cut and pasted the "real" table to another area of the doc, I was able to get headers to repeat!

Collapse -
by cheyguy84 / April 14, 2011 8:31 AM PDT

Outstanding solution. This was the exact problem I was experiencing but didn't know it. It was frustrating because it would work on one document and not the other. Spent way too many hours trying to figure it out. Thank you all for your input!!!!!

Collapse -
Same issue another solution
by sharpear / September 12, 2011 10:58 PM PDT

Not sure if this will help out anyone as this seems like a very old thread. I selected the full document cells and went to format cells, Protection Tab, and I just unlocked the cells. It then allowed me to set the repeat row per page. Also my Permissions is set to unrestricted access.

Issue originally started with Office 2010 (she said she typed out all the data herself), and I worked it from 2010, 2007, 2003. All versions had the issue with this document. After making the change to the locked cells, it allows me to use this option on any Excel document. I didn't save the document, and I am able to edit it in all versions now from the original. I think the issue was she sorted the information to accending and it had some type of lock on the cells. Don't know how I am able to edit Repeat row per page option, when I didn't save it.

I could not find the option mentioned above that pointed out any tables to me, and I didn't have a Table word wrapping issue.

Collapse -
heading row not repeating in table in word 2007

Simply create your header row in your table, highlight the entire row all the way to that little mark "outside" of the table, then do header row repeat.. ...

Collapse -
header row not repeating

highlight the entire row, all the way outside of the row.. that little icon on the outside of the table.

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

CNET Holiday Gift Guide

Looking for great gifts under $100?

Trendy tech gifts don't require a hefty price tag. Choose from these CNET-recommended useful and high-quality gadgets.