Windows Legacy OS forum

General discussion

Re Enable VGA Driver

by tonyrob53 / July 10, 2006 10:18 PM PDT

Hello,

I have a Dell Inspiron 8100 laptop running XP Home. The VGA driver has been disabled and all I get after bootup is a black screen. None of the safe modes work. I gan get into recovery. How do I re-enable the VGA driver that was disabled?

Thanks,

Jerry

Post a reply
Discussion is locked
You are posting a reply to: Re Enable VGA Driver
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Re Enable VGA Driver
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
If you
by Themisive / July 10, 2006 11:30 PM PDT
In reply to: Re Enable VGA Driver

Can't get into safe mode then try this tip. Go to Control Panel/System then choose the Hardware page, click on the Device Manager button, then look down the list for the monitor. Click on the + beside it and then right click on the monitor and choose "unistall" from the list. Click OK and OK then OK again to log out of the Control Panel, then reboot.

This should force Windows to re-install the drivers for the monitor.

Collapse -
Sorry Should Have Added
by tonyrob53 / July 11, 2006 1:21 AM PDT
In reply to: If you

I should have added that I can't access XP at all. Not in normal mode or in safe mode. I can get into recovery console.

Thanks,

Jerry

Collapse -
How do you know it's been disabled?
by glb613 / July 11, 2006 3:11 AM PDT
In reply to: Re Enable VGA Driver

Maybe it has failed.

Collapse -
It is disabled
by tonyrob53 / July 11, 2006 3:54 AM PDT

I know because I disabled it. The system was not recognizing my new video card. It would only launch into 4 bit vga mode. So I thought I would disable the vga driver and force it to recognize my video card. Did not happen. Now I have an ati 7500 that use to work great with an external monitor. But now it also will not work.

I ran recovery from the disk and verified that vgasave was set to SERVICE_SYSTEM_START but that did not help.

Thanks,

Jerry

Collapse -
VGA driver
by billzhills / July 11, 2006 5:17 AM PDT
In reply to: Re Enable VGA Driver

F8 to access the boot menu...

last known good configuraton

Start VGA mode

Last resort Windows repair

Bill

Collapse -
Did not help
by tonyrob53 / July 11, 2006 10:00 PM PDT
In reply to: VGA driver

I tried to use the last known good configuration. And got no change.

I tried starting in all safe modes including VGA Mode and I still can't access safe mode.

I tried a windows repair install and it did not fix the problem.

Thanks,

Jerry

Collapse -
Reply to: Re Enable VGA
by caktus / July 11, 2006 6:23 AM PDT
In reply to: Re Enable VGA Driver

Can you access/select Last Known Good Configuration?

Perhaps it [is] starting in Safe Mode but because VGA is not working Safe Mode just isn't visiable. If this is the case perhaps you can do a system restore from command prompt.

If you [can] get to a command prompt perhaps typing in or coping and pasting
''enable vgasave service_system_start'' without the quotes and then Enter may reenable VGA.

Hope this stuff helps.

Collapse -
Still Nothing
by tonyrob53 / July 11, 2006 10:49 PM PDT

Hello,

It might be working in safe mode in the background. I can't tell. I did try to run it in safe mode with command prompt and it appears to lockup. I tried typing "shutdown.exe -r" to get the system to restart but it didn't do anything.

I can get into the recovery console and I did try
enable vgasave service_system_start. I also copied vga.dll, vga.drv and vga.sys from my install disk but that also did not fix it.

Thanks,

Jerry

Collapse -
Reply to: Still Nothing
by caktus / July 12, 2006 6:24 AM PDT
In reply to: Still Nothing

''%systemroot%\system32\restore\rstrui.exe'' w/o the quotes at the cmd prompt may get you to System Restore.

Or

Perhaps moving the graghic card to a different slot may cause the driver to be reinstalled.

Collapse -
No Command Prompt
by tonyrob53 / July 12, 2006 8:43 AM PDT

Hello,

Sorry I can't get a command prompt. So I can't access the System Restore. Also this is a laptop so I can't move the video card around. I have tried using several different cards though.

Thanks,

Jerry

Collapse -
This sounds like it be a fix.
by caktus / July 12, 2006 10:49 AM PDT
In reply to: No Command Prompt
Collapse -
Sorry can't display anything
by tonyrob53 / July 12, 2006 11:46 PM PDT

Sorry but I have tried to use an external monitor and still nothing. So I can't go to display settings.

Thanks,

Jerry

Collapse -
couple more possible options.
by caktus / July 13, 2006 5:48 AM PDT

See if this will permit you to access Safe Mode.

Start out accessing the Boot options list by restarting and tapping the F8 key durring startup. Select Restart or HDD, which ever is available on your system. (If you are presented with OS choice hit enter.) Then very quickly start tapping the F8 key. Try accessing Safe Mode.

Also, you might consider removing the HDD (remember to set the jumper to "Slave" or "Cable Select (CS) and installing it in another computer as a slave to backup any important files then reinstall in the problem computer and reforemat/reinstall the OS.

Collapse -
If you can use the Recovery Console you can ...
by Edward ODaniel / July 11, 2006 8:18 AM PDT
In reply to: Re Enable VGA Driver

make a change to the boot.ini file to force Windows to boot with the VGA driver.

It is as simple as editing the Boot.ini and adding a line that includes the /BASEVIDEO switch.

Your boot.ini may be different but essentially this is what you do. The changes you should make are bolded for ease of identification. Changing the timeout to 30 is not actually necessary but it helps you avoid missing the selection to boot to the VGA mode should something else demand your attention during that short 3 seconds:

Existing boot.ini file:

[boot loader]
timeout=3
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

Altered boot.ini file:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP VGA Mode" /fastdetect /basevideo

Note, that last line is identical to the one that was already there except that /basevideo switch is added.

Here is a handy link to other switches that can be very handy when things go wrong. This should have got you into Windows UNLESS you have deleted things you haven't mentioned rather than just disabling a driver.

Collapse -
Still Nothing
by tonyrob53 / July 11, 2006 10:28 PM PDT

Hello,

I am limited in what I can do with boot.ini. I am using the recovery console and can not change the timeout. But I can add a windows installation and set the switch /basevideo.

This did not help. I even tried to access it in safe modes and got nothing more than I did before.

I have tried a repair install to make sure that if I had deleated a file, the xp repair should have reinstalled it. But this also did not help.

Thanks,

Jerry

Collapse -
An update
by tonyrob53 / July 12, 2006 11:49 PM PDT
In reply to: Re Enable VGA Driver

Hello,

I was able to setup BartPE on the system so I can copy files around. I looked at the bootlog and it shows that vga.sys did not load. I have no idea how to make it load. I also looked again at the listsvc list and noted that viaagp and viaide were disabled. Would this help? I have a total of 17 items that are disabled. I can list them if they would help.

Thanks,

Jerry

Collapse -
Jerry, went to shut down and restart WINXP
by DarCLew2 / July 13, 2006 10:06 AM PDT
In reply to: Re Enable VGA Driver

used F8 and kept tapping it and went to the black screen with start windows normaally, last known good configuration, safe mode, safe mode with networking and ENABLE VGA. Mine is set up with a large screen size but it went to 600 x 800 resolution with large icons. I would also double check your video card, if it is not put in properly, that could also be your problem. Also, yur computer may have in it various screen setups under Display, Settings, Color Management and you may have different settings in the computer. There are VGA files in system32 under Windows
Darrell Lewis

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Smartphone tip

Hoarding photos on your phone?

Those picture are hogging memory and could be slowing down your phone.