Computer Help forum


problem with my router

by leonnoah1 / October 4, 2013 2:35 AM PDT

Hi all,

I have some weird problem with my internet connection.
I have a modem adsl which is connected to wireless router (Edimax).
I have a PC which is connected directly to the router and I have a laptop and some smartphone which uses the wifi.
My problem is that the wifi working only when the pc which connected directly to the router is on.

Is anyone have a clue/hint/suggestion why the wireless internet works only when the PC is on?

Thanks, Leon

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: problem with my router
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: problem with my router
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Just A Thought...
by Grif Thomas Forum moderator / October 4, 2013 3:51 AM PDT
In reply to: problem with my router

Some have had similar problems when the router is set to "repeater mode" in their settings, especially when range extenders or secondary routers are used.. Check your settings and disable it. Are all settings at default on the router?

In addition, make sure you have the latest firmware for your router.

Unfortunately, you've told us nothing about the computers which are connected.. Operating systems, make and models, etc.. To test things, have you disabled the firewall on the router to make sure access is correct? If any XP computers are being used, make sure that have Service Pack 3, plus all updates installed...

Hope this helps.


Collapse -
by leonnoah1 / October 4, 2013 6:19 AM PDT
In reply to: Just A Thought...

Hi Grif,

Thanks for your help.

I'm have Win7 on the PC and my router made by Edimax ( BR-6524N Wireless Router)
Unfortunately I didn't find where should I disable the "repeating mode".
Is there any change that this is related to fact that the "DHCP Server" is enabled?

Thanks again, Leon

Collapse -
How are the connections made?
by James Denison / October 5, 2013 1:11 AM PDT
In reply to: Thanks

PC connected by USB or LAN? It isn't plugged into the WAN port is it?
Modem connected to router by USB or LAN?
Is the computer and router both on a power strip you turn off with the computer?

Collapse -
"DHCP Server" Enabled Works Best For Most Home LANs
by Grif Thomas Forum moderator / October 5, 2013 4:18 AM PDT
In reply to: Thanks I'd recommend leaving it enabled.. Each router is slightly different and the one I'm on currently has a Private LAN setting which is enabled in addition to the DHCP Server.

One other item which is good to check.. Open the Device Manager on the Windows 7 "wired" computer, then click on the + sign next to the "Network Adapters" listing.. RIGHT click on the name of your ethernet adapter/controller, then choose the "Advanced" tab.. Check for "Wake on LAN" or "Shutdown wakeup" listing and make sure it's turned OFF. Then select the "Power Management" tab and UNCHECK any boxes that allow the computer to turn off devices to save power. After making the changes, click on "Apply", then OK.

Hope this helps.


Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

Smart Home Help

Light bulbs you shouldn't buy

There are plenty of dimmable LED light bulbs, but make sure you don't buy the ones that flicker when you dial them down.