Windows Vista forum

General discussion

Playing music through the sound card

by alfmic / October 23, 2007 4:47 PM PDT

I dont know if I am in the right forum but I need some urgent help.
My problem is......I have a new pc with vista home basic,I am trying so hard to find a solution so I can play music through my sound card but never succeded. Is there any help plse.When I go to chat rooms I can hear music from other chatters.

Post a reply
Discussion is locked
You are posting a reply to: Playing music through the sound card
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Playing music through the sound card
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Not Clear.. Do You Have Sound?
by Grif Thomas Forum moderator / October 24, 2007 5:29 AM PDT

Are you able to hear sound from your computer?

Which media player are you using on your computer?

Can you play music, CDs, etc. from your disc drive now?

Are you referring to an inability to apply music to a chat room only? (If so, please check with the chat room website. I'll bet they have instructions.)

Hope this helps and let us know more.


Collapse -
playing music through the sound card
by alfmic / October 24, 2007 6:31 AM PDT

Hi Grif,
I have sound in my computer and even in chatrooms
My media player is WM Player.exe/Prefetc:1
I can play music from cd's too.
The problem is I dont know how to play music through the sound card like I use to do when I had the xp.
No,not in chat rooms only.

Collapse -
If You Are 'Hearing' Sound, Then It's Playing Through...
by Grif Thomas Forum moderator / October 24, 2007 8:47 AM PDT

...the sound card.. It's the only way that sound will be heard.. Please explain EXACTLY what you're trying to do.. Media players produce muscial sound by "Playing music through the sound card" so does your chat room, so do the CD players..

Are you trying to plug in some other device to the sound card and hear it through your computer speakers? Or something else? Once again, what EXACTLY are you trying to do?


Collapse -
playing music through the sound
by alfmic / October 24, 2007 6:22 PM PDT

what I want is this....when I had xp and I play in chatroom I did'nt have to hold on mic or click hands free,just adjusting from xp controls and I play directly, just drag the mic lock on the talk button and thats all.With vista I dont know how to do it.

Collapse -
Different Computers, Different Options
by Grif Thomas Forum moderator / October 25, 2007 2:55 AM PDT

Your new machine may, or may not have those same options in its settings.. A different sound card on this computer, different software, as well as a different operating system, don't guarantee that they will be the same. Unfortunately, I can't reproduce your computer here so you may need to explore your settings carefully. Maybe someone else on this forum may have a suggestion.


Collapse -
playing music through sound card
by alfmic / October 25, 2007 3:55 AM PDT

Hi Grif,
Many thanks anyway,maybe someone else take notice of my problem and try to help.

Collapse -
PLaying Music Soundcard Vista
by Ken Deyell / October 25, 2007 7:48 AM PDT
Collapse -
playing music through sound card.
by alfmic / October 25, 2007 10:54 PM PDT

Hi Ken,
First of all I want to thank you for the interest with my problem.
I have done what you have told me but it seems that I have some different options from the site you gave me.
My sound card is Realtek High definition Audio and is integrated in the mother board.When I right click on the spkr icon what I have is this...1 playback devices 2..Recording devices 3...Sound.
When I clicked on Record devices what I got is this...Microphone ,Realtek High Audio Working and Line In Realtek High Definition Audio Working.I have'nt got ...Show Disabled Devices and Show Disconnected Devices.So I am lost.
Another thing I want to know please,when you fixed your problem,are you playing direct from the sound card or from the mic?

Collapse -
playing music through sound card
by Ken Deyell / October 26, 2007 8:07 AM PDT

Alfmic...sorry those instructions didn't get you up and running.Yes,I am playing through my "soundcard" with no mic in the chat rooms,and you will be too before we finish here.I'll try and make these instructions as brief as possible.Follow this path: go to ..control panel\hardware and sound\sound click on "recording tab" then "right click" on empty space in that box.Check .show "disabled items" and "disconnected items".Here is where you will see "stereo mix" check it and then click "apply" and "ok".This should get you setup.

Collapse -
playing music through the sound card
by alfmic / October 27, 2007 5:09 PM PDT

hi ken,I did exactly what you have told me but I need to adjust something else. Can you tell me how can I eliminate the sound from the spkrs while I am playing thru the sound card?When I muted the spkrs they did'nt hear my music.So I think that I am not playing thru the sound card.Your help is very appreciated.

Collapse -
playing music through the sound card
by Ken Deyell / October 27, 2007 11:02 PM PDT

The muting will do that as it is in unison.I don't understand why you want to "mute" your speakers.Your best bet is to "unplug" your speakers from the "plugin jack on soundcard" at the back of your "tower".Then "plugin" a "headset" into the same "jack" your speakers were.You get an improved sound quality for your own listening pleasure over a "headset".Hope this helps you.

Collapse -
playing music thru the sound card
by alfmic / October 28, 2007 12:58 AM PDT

Hi Ken ,if this is the only solution I go for it.I thought there is an adjustment from somewhere in the software or in my pc ,instead I have to un plug everytime I want to shift from the spkrs to earphones.

Collapse -
Playing only through your soundcard
by PamWNC / November 11, 2007 1:30 PM PST

On your lower right in the task bar right click your speaker icon.
Click recording devices.
To play only through your speakers and to turn the mic off right click the stereo mix icon and click Set as Default Device.
To talk on mic right click the microphone icon and click Set as Default Device.

Collapse -
Playing Music through the sound card
by Gravy Baby / February 27, 2008 7:31 AM PST


I have followed your path to do this, when I click in the empty area and click on show disabled devices and disconnected devices, nothing shows up? Any suggestions? I just purchased this HP Pavilion dv9000 with Vist Home basic and I would like to be able to play the music in the rooms ( not through the mic) as well...

Collapse -
Same problem
by RACiE P / June 9, 2008 1:09 PM PDT

Gravy Baby,
I'm afraid I have the same problem as you. Stereo Mix or whatever it's called has not been disabled on our computers, but it has not even been put on them. I have been searching Google and Youtube for a while and nothing has worked. I'll let people know if I find anything.

Collapse -
to enable sterio mix
by andy0910 / July 7, 2008 3:19 AM PDT

you cant see it because you have to RIGHT click the mouse in the recording section on an unused white section in the of the box and the menu should say show disabled devices need to check this box and the sterio mix should then be showing in the list

Hope this helps a bit

Collapse -
re: to enable stereo mix
by RACiE P / July 17, 2008 1:18 PM PDT
In reply to: to enable sterio mix

duh! what do you think i and other people have done? our computers/laptops/whatever just don't have the capabilities.

Collapse -
Ah that old chestnut
by shawaddy / November 22, 2008 1:30 PM PST

Ok so im a bit late with this one but for anyone else who needs it heres how. Please bear in mind your sound card may not be capable of applying the sound direct. But you want to play to an audience without needing to hear the music yourself.....?
Open your sound device and click recording then right click the box and ensure there is a tick in show disabled devices. Now you have those options that you had back in XP. Off the top of my head its stereo mix you want but i could be wrong (depends on the card) right click the device and enable it then right click again and set as default. Hey presto it will now play through your sound card direct and wont be affected by what volume your speakers are set to. To return to normal det your microphone device back to default. Just play around with which devices are there cmedia chips i think use stereo mix and creative's version is called what you hear. Dont flame me if you dont have these devices as i said early in my post not all cards have this capability.

Collapse -
hey for the windows xp part
by liquidcowboy / August 4, 2010 1:53 AM PDT

can u show me how to use music thru the sound card on windows xp
if u have team viewer maybe u can do it for me for the first time an i will be watching an will remember what to do after that

Collapse -
advice on direct song play from sound card
by roshniali / November 29, 2008 11:26 AM PST

i do have sterio mix window vista home adition how do i play directly from sound card i mean music?

Collapse -
playing music thru the soundcard in room
by lola_2008 / January 24, 2009 1:41 AM PST

i did as instructed--next step please

Collapse -
paying music in chatrooms
by andy0910 / October 23, 2010 9:49 PM PDT

Hi alfmic firstly on vista and windows 7 the sterio mix neded to play through the soundcard is diabled and hiden in the previous os you have to enable it by going to sound options recording tab then right clicking in a white area of the box then an option should appear and if you check the enable hidden devices box hey presto sterio mix appears and is enabled in the recording ta. Hope this helps . If you have probs just let me know i play a lot of music on paltalk

Collapse -
music through soundcard
by ladit00 / February 10, 2011 7:58 AM PST

andy I am also on pal and I am using windows7 but still cant get the music to play through my soundcard everything is set up right if you dont mind I could use some help either through here or pal

Collapse -
playing music in chatroom
by andy0910 / February 10, 2011 1:17 PM PST

Hi ladit, I can try and help you if you like on pal my nic is anoisyoyster so message me your nic as i have my privacy settings on block so its better if you add me and send me an offline message with your user nic or or reply post on here than i can add you to my pal list..hope this helps

Collapse -
by ladit00 / February 11, 2011 3:30 AM PST

bamagirl4ever is my nic I sent you a offline but your privacy setting wouldnt let the pm just send me a offline when a good time for you would be and ty again.

Collapse -
Re:playing music in chatroom
by wytchy_steph / March 22, 2012 11:45 AM PDT

I am on paltalk also and having issues with getting things to work as well.. have the stereo mix as default and all but am not getting the right options after that.. Something else is missing somewhere along the line. andy, I have added you to my PalTalk and hope to catch you online at some time, please add me also Wytchy_Steph

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions


CNET bought a house!

Take a look inside the house where we will be testing connected locks, thermostats and other smart home products so we can tell a complete story.