Windows Vista forum

General discussion

persistent Open File - Security Warning dialog box

by oregonuser / September 2, 2007 9:33 AM PDT

...having a problem with an annoyingly persistent dialog box. Perhaps somebody out there can help close it for good.

Whenever I log in to my computer (ASUS M2NPV-VM motherboard and windows home vista basic) either as a std user or an admin) I get a dialog box: "Open File - Security Warning" that wants me to confirm that I trust the smax4pnp.exe file and want it to execute. smax4pnp.exe is associated with the drivers for the on-board audio of my motherboard. Apparently it has an unknown publisher. Anyway, I have been unchecking the "always ask before opening this file" and clicking the "run" button, but am getting tired of this.

Is there a way to make this dialog box go away for good?

I've updated the driver via the ASUS website (ver 6.10.1.6140 for everyone keeping score at home), but to no avail.
...have also tried "unblocking" this file by clicking unblock within the windows explorer file -> properties dialog box. This change does not persist.

How do I get vista to remember to trust this file? Is there a tucked away list of trusted programs within the control panel or management console? How about my Norton Internet Security 2007 security suite?

Post a reply
Discussion is locked
You are posting a reply to: persistent Open File - Security Warning dialog box
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: persistent Open File - Security Warning dialog box
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Same problem, but Windows 7
by winnP / February 20, 2009 6:35 AM PST

I'm having this exact same problem, with two differences (1) I'm using Windows 7, and (2) the software is the Synaptics touchpad driver. I also tried:

(1) Running the driver install .exe as administrator.
(2) Unchecking the "ask every time" box.
(3) Unblocking via the explorer->Properties dialog.
(4) Disabling UAC (using slider then through the registry).

None of these things work. And if the best someone can suggest is not using the software, then that's kinda ridiculous.

Collapse -
Similar problem fixed
by caustic4 / March 16, 2009 10:20 PM PDT

I was having the same problem with a file from ASUS called AsRunHelp.exe getting that annoying message every time i booted Vista.

After some searching i think i figured it out. The problem is when you open the properties dialog and unblock the file it isn't persistent. Its part of some ntfs stream information apparently, idk. I copied the file to a fat32 partition, that removed that whole block/unblock business, and i copied it back replacing the original file. That worked for me, i hope it helps you.

Collapse -
Maybe another copy to 'unblock' under DriverStore
by libove / June 23, 2009 11:51 PM PDT

I ran in to this a long time ago, and never knew quite how I had solved it. I ran in to it again today on reinstalling a Vista laptop (x86, as it happens; I doubt it matters).

I've not found this reference on any of the dozens of threads discussing this issue across the Internet: in my case, I believe the solution was the Vista Driver cache copy of the SynTPEnh.exe (and also SynTPHelper.exe) files, which in my particular case happened to be exactly at:

C:\Windows\System32\DriverStore\FileRepository\synpd.inf_cf8b1771\

Your mileage may vary on the exact name of the DriverStore\FileRepository\... subdirectory, but if you're still having this problem after opening the properties dialog of the SynTPEnh.exe file under the expected location (C:\Program Files\Synaptics\SynTP\) and unblocking it, then try doing the same unblock operation on any other copies of the same file(s) which you may find under the DriverStore\FileRepository.

Jay Libove
Barcelona, Spain

Collapse -
Talk about obscure!
by dsorak / January 22, 2010 9:23 AM PST

Try the article here:

http://itsvista.com/2007/01/itsvista-tip-22-stop-security-warning-from-apps-on-vista/

There is a special case for files the "Program Files" (and "Program Files (x86)" if you have 64-bit) directories, apparently. Move the file to your desktop and then open the properties dialog. In there you will see a new option button "Unblock" - click it. Then, move the file back to your original "Program Files" location.

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech for the school year

Smart tech for smart students

Forget the pencils and notebooks. Gear up your students with these portable and powerful note-taking machines.