Headphones & Mp3 Players

General discussion

PC Not recognizing MTP Device... HELP PLEASE!!!

by pedrossi24 / March 17, 2007 7:44 AM PDT

I bought a Zen V Plus 4gb yesterday, got home and installed everything from the CD, but when I connected my Zen and the program tried to register it, it said it found no unregistered components. I ignored it and tried to open the Media Manager to add songs. It said there's no player connected. I opened Windows Media Player and clicked 'Sync' and there's no player there, either. Every time I connect the player, a Windows Wizard comes up asking me if I want to connect to the internet to install the driver for it. I tried clicking 'yes' once, but it said it couldn't find any drivers. I checked the Device Manager and it says there's a Creative Zen V connected but there's a yellow warning icon next to it. I've tried reinstalling the software from the CD 4 times, and restarted my PC numerous times as well. My player does seem to be charging, as I left it connected to the PC for about 2 hours and now when I disconnect it the battery display is about 1/3 of the way full.

I tried the troubleshooting on Creative's website, but no luck. I also tried a fix that seemed to be working for a lot of people with this problem, which was modifying the registry permissions for USB. I did that, but still no luck.
I'm running Windows XP Service Pack 2, 768mb ram, 2.8Ghz Pentium 4 on an HP Pavilion a410y machine.

This is an interesting development: my dad got one of these (a 1gb Zen V) for his birthday, and installed all the software on his PC (an HP Pavilion, different model than mine, 512 ram, 3.0ghz pentium 4). He succeeded in putting all his songs on my player, so I decided to try his PC, since he already had all the software. His PC's Media Explorer recognized my player... and my player can play the radio and everything, so I'm guessing the problem is with my PC.

Any ideas? Thanks in advance!
Edit/Delete Message

Post a reply
Discussion is locked
You are posting a reply to: PC Not recognizing MTP Device... HELP PLEASE!!!
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: PC Not recognizing MTP Device... HELP PLEASE!!!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
(NT) Which XP?
by R. Proffitt Forum moderator / March 17, 2007 8:22 AM PDT
Collapse -
XP
by pedrossi24 / March 17, 2007 8:40 AM PDT
In reply to: Which XP?

XP Home Edition SP2

Collapse -
So it can preinstalled?
by R. Proffitt Forum moderator / March 17, 2007 9:18 AM PDT
In reply to: XP

A recurring issue are owners that reinstalled OS. Or ports that are dead. I always try the rear ports and install the motherboard chipset drivers. But I can't comment much since the gritty details are not in your posts.

Good luck with this.

Bob

Collapse -
Reinstall
by pedrossi24 / March 17, 2007 9:24 AM PDT

I did have to reinstall Windows once (it was the only alternative to a format) because I needed to upgrade to SP2 and my Windows Update was screwed beyond belief... What can I do if I've reinstalled before?

Collapse -
That's likely it.
by R. Proffitt Forum moderator / March 17, 2007 9:28 AM PDT
In reply to: Reinstall

The HP install would have all those drivers you hear about.

-> Let me be more blunt. Without the make and model number I can't point to which drivers I would install. And with each post you make is a reminder to tell such things.

Bob

Collapse -
Model number
by pedrossi24 / March 17, 2007 10:00 AM PDT
In reply to: That's likely it.

Sorry about that.
it's an HP Pavilion Desktop model a410y

Collapse -
Ok, now here's the motherboard drivers.
by R. Proffitt Forum moderator / March 17, 2007 10:07 AM PDT
In reply to: Model number

These are needed to properly enable USB and more.

http://h10025.www1.hp.com/ewfrf/wc/document?docname=c00063244&lc=en&cc=hk&dlc=zh-hant&product=402250&rule=41820&dest_page=documentIndex# notes it's an Intel 845GV chipset. Intel supplies this package.

http://downloadfinder.intel.com/scripts-df-external/filter_results.aspx?strTypes=all&ProductID=816&OSFullName=Windows*+XP+Home+Edition&lang=eng&strOSs=45&submit=Go%21

" This utility installs INF files that inform the operating system how to properly configure the chipset for specific functionality such as USB and AGP. "

Hopefully this will kickstart your USB ports proper and it will work. Be sure to leave any USB things unplugged until this is installed and you reboot. Be sure to use the rear ports too.

Bob

Collapse -
USB ports
by pedrossi24 / March 17, 2007 11:46 AM PDT

I ran that installation and restarted the PC, plugged the USB cables back in (to the back ports) but it's still not recognizing the player. Any ideas?

Collapse -
Do other devices work?
by R. Proffitt Forum moderator / March 17, 2007 12:11 PM PDT
In reply to: USB ports

Try all ports and be sure you are not using a "limited account."

And just to repeat, I think you said that cable and device worked on another machine?

Bob

Collapse -
Works on other machine
by pedrossi24 / March 17, 2007 12:14 PM PDT
In reply to: Do other devices work?

Yes, I used this device and cable on another PC, and it worked perfectly.
My other USB devices are working as well (I get my internet from a USB network adapter plugged into my PC, and my mouse is USB as well)

Collapse -
Admin
by pedrossi24 / March 17, 2007 12:15 PM PDT
In reply to: Works on other machine

Also, I'm using an administrative account (only account on this PC)

Collapse -
Ok, let's look at the yellow Zen item.
by R. Proffitt Forum moderator / March 17, 2007 12:56 PM PDT

Pull that up and uninstall it. Or right click remove. Which ever is offered. Since it's already installed that why our drivers had zero effect. We need to toast that item so the next it plugs in XP will have to deal with it.

Bob

Collapse -
Uninstalled
by pedrossi24 / March 17, 2007 1:01 PM PDT

Ok, I uninstalled that item. It's gone from the Device Manager. What next?

Collapse -
Sorry, I think I'll have to stop.
by R. Proffitt Forum moderator / March 17, 2007 11:28 PM PDT
In reply to: Uninstalled

It took many times for you to see the forum note. This time you didn't read my last reply about what to do next. We were at 10+ posts before you shared the machine details and now you are adding another post just to have me tell you to reboot and plug it in.

Why are you dragging this out?

Bob

Collapse -
.
by pedrossi24 / March 18, 2007 3:22 AM PDT

I'm not dragging this out. I did reboot and plug it in, that was obvious, but the problem is still there, which is why I asked what to do next. I want to get this fixed as soon as possible, there's no reason why I would want to make it take any longer.

Collapse -
Tell the details please.
by R. Proffitt Forum moderator / March 18, 2007 4:02 AM PDT
In reply to: .

If I must ask for such each time it takes far longer and I must stop.

-> Tell me about the yellow or not item in the device manager. You offered this in your first post and we need to work on that.

---> More answers ahead of your reply to that question.

If there is a new yellow item for the player, unplug the player then remove it again. Go back to the device's CD and install it again. Or uninstall then reinstall.

Then plug it in and see if the yellow item shows up.

What to do if the yellow item shows up? Double click on it and reveal any and all words it reports.

Bob

Collapse -
right back at ya BOB!
by stewpadaso / October 25, 2009 8:29 AM PDT

I've been following along for all 18 painfully dull and simple thread posts. waiting. patiently waiting...for...
some freak'n info I can use then whammo! Bob decides he has been dealing with a maroon long enough?
but....but... won't there be a happy ending? I paid my 50 bucks...oh wait wrong story sorry.

what a jip you are just as much to blame or more so bob. thanks for nothing

Collapse -
You're being unnecessarily harsh
by MajorHart / April 14, 2010 4:42 PM PDT

If you don't want to help him don't but don't be so harsh.

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech for the holiday

Find recipes for July 4 with these foodie apps

The Fourth of July means fireworks, fun and food. If you're planning on a barbecue this weekend, we've got the apps to help you find holiday-inspired recipes.