Windows Legacy OS

Question

Password protected sharing on XP.

by Datche / January 14, 2013 8:44 PM PST

Hi all, i'm having an issue with networking.

I'm trying to network to xp computers together and share files and a printer.

I've successfully set up the network with a hub. I can share files in the shared folder and I can share a printer fine.

However, I am trying to share my C drive as a password protected drive. I have changed the option in the folder settings so I now see the option to set a password. I share the drive, then I go to 'select users or groups' however in the 'locations' setting it only shows the local computer and not the second computer on the network.

Any ideas why?
If i go to view computers on homegroups, both computers are visible, between that and the fact i can create a file on one and see it on the other i'm pretty sure the two are networked.

This is my last hurdle so any help is appreciated.

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Password protected sharing on XP.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Password protected sharing on XP.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Most common? Accounts.
by R. Proffitt Forum moderator / January 14, 2013 11:59 PM PST

Most folk forget to create the account on both machines to setup that share. The password is the account's password.

Let's say your are "datche". You must be able to log on to each machine as "datche". That's step one. Now to share something, you log onto the machine you want to share from as "datch" and create the share. Now logout and go to the second machine, logon there as "datche" and connect to the share.

Most folk I know forget the account setup.
Bob

Collapse -
thanks
by Datche / January 15, 2013 5:59 PM PST
In reply to: Most common? Accounts.

I will give this a go, but this requires each computer to have all of the users on. So for example if i network three computers on a network and 5 users on each computer that means I need to have 15 users on each computer so they can access the drives via passworded sharing.

It seemed like it was going to be easier, especially as when I tried to share it asked for the 'location' of the user. I assumed that I could find the remote computer and select the user from that computer!


I will mark this as answered after I try the fix. Happy thanks.

Collapse -
So you see the reason for a server and Active Directory
by R. Proffitt Forum moderator / January 16, 2013 12:11 AM PST
In reply to: thanks

Now that you get the picture it's this simple. The computer with the share must know about the user that is attaching to the share. The server can accept that you are someone else that they don't know about.

-> You've written why folk use Windows Server.

Bob

Collapse -
This did not work
by Datche / January 17, 2013 1:00 AM PST

I'm afraid this didn't work.

I created identical accounts on both computers and this failed to work.

However i still dont understand why in permissions it lists the permitted users as PCNAME/USERNAME
if it is only looking for the same username.

I'm still currently getting not authorised to view. Even though the accounts and everything are identical.

Collapse -
And there is more to look at. For example a router.
by R. Proffitt Forum moderator / January 17, 2013 2:46 AM PST
In reply to: This did not work

See page 43
"Your modem router has a firewall that blocks unauthorized access to your wireless network and permits authorized inbound and outbound communications. Authorized communications are established according to inbound and outbound rules. The firewall has the following two default rules. You can create custom rules to further restrict the outbound communications or more widely open the inbound communications:
• Inbound. Block all access from outside except responses to requests from the LAN side.
• Outbound. Allow all access from the LAN side to the outside"

Notice how an inbound access from WiFi is blocked? You'll want to change that.
Page 44 (using the page counter in the PDF viewer) shows the default is BLOCK ALWAYS.

Again, firewalls like this are a cause for many of these issues. Your choice to allow communication.

At least you are aware of accounts and permissions but there's a lot to cover. Including connection limits in XP. In some versions it's as low as 5. Hope you are not counting on this to work.
Bob

Collapse -
Answer
Featured removed from XP
by JiniOnline / January 17, 2013 7:28 PM PST

This feature is removed from Win XP.
It was in Win 98. Sorry! you can't do it.

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

CNET Magazine

The summer issue is here!

In the latest edition of our quarterly magazine, we look at how you can spend your summer getting fit and having fun. Pick up a copy on newsstands today or order it now.