Office & Productivity Software forum

General discussion

Outlook 2003 won't download pictures

by j341 / March 29, 2007 6:23 PM PDT

This is not the usual confusion from someone who doesn?t know that Outlook 2003 blocks graphics downloads by default. In my case, when I right-click to download pictures in an email, the pictures still don?t appear, even though they have been downloaded. The pictures are not displayed; I still see the red X for each graphic. If I save, close, then re-open the email, the pictures are then shown. This began happening a couple of months ago after several years of using OL 2003, but I?ve never found the solution. More recently, one of the PCs in our office began showing the same behavior.

It could be described as intermittent, though it happens probably 95% of the time. On rare occasions, the pictures are displayed as soon as they are downloaded.

If I set Outlook to download pictures automatically, they are shown immediately with no problem.

I?ve tried the repair option for MS Office, no difference. After numerous Google searches, I?ve found a few other people who have experienced the same problem, but no one has posted a solution.

I?m using WinXP SP2, Outlook 2003 SP2. I?d appreciate any assistance or suggestions.

Discussion is locked
You are posting a reply to: Outlook 2003 won't download pictures
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Outlook 2003 won't download pictures
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Try tapping the F5 key after...
by R. Proffitt Forum moderator / March 29, 2007 11:21 PM PDT

the "right-click to download pictures". I don't know of a firm fix here since I've encountered issues like this and traced it back to Norton or Mcafee privacy protector features. Since it's more than Outlook 2003 at play here you can see why no firm fix.

The F5 key worked for one person so I pass that along.


Collapse -
Outlook 2003
by j341 / March 30, 2007 3:48 PM PDT

Thanks Bob for the reply. Unfortunately refreshing doesn?t help.

I don?t use Norton, just NOD32 for virus software. It has no additional privacy features other than virus protection. And I use ZoneAlarm for a firewall. The fact that the images definitely download but simply fail to display make me think this is more of a formatting or viewing issue. If I don?t open the email by double-clicking on it, but just view it in the reading pane, the images display correct every time. It?s only when an email is viewed in its own window that the display problem occurs. All signs point to an Outlook problem.

I checked another computer today at work that has Outlook but is seldom used, and it also has the same problem. I?m still hoping someone can come up with a solution.

Collapse -
Me too
by upstairs6 / April 10, 2007 2:27 PM PDT

I have the same problem you have on my desktop PC, but my laptop -- which has the same anti-virus and anti-spyware software -- is working fine. I have noticed, though, that when I download pictures, the pictures get downloaded to the preview pane, but not to the opened mail message. If I turn off the preview pane, then the download works ok. In that case, if I don't save changes after downloading pictures, the pictures get saved, anyway. It appears to me that Outlook is downloading the pictures to the wrong image of the message.


Collapse -
Outlook 2003 won't display images
by rchipman / April 11, 2007 6:22 AM PDT
In reply to: Me too

I ran into a similar thing that is being described here with images not being displayed in Outlook 2003 messages. I found a solution that helped me so I wanted to post it here.

It has to do with the Outlook Temporary Items folder. Close Outlook before preceding to the steps below.

1. Locate the Outlook Temporary Items folder by opening the Registry and finding HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\Security. Double click on the OutlookSecureTempFolder key.
2. Right click the Value Data field and select Copy. It should be in the form of %USERPROFILE%\Local Settings\Temporary Internet Files\OLK6 where OLK6 is some randomly generated string that always starts with OLK.
3. Open Windows Explorer, paste in the Address field and press Enter (or select GO). You will be navigated to this folder.
4. Select All the files in this folder and Delete.
5. Launch Outlook. The images should now appear in the Email.

Hope that helps.

Collapse -
Nice try, but that wasn't it
by upstairs6 / April 11, 2007 1:59 PM PDT

I gave your solution a try, and it didn't change the behavior of my PC a bit. I also tried "detect and repair", including resetting parameters to defaults, and deleting a lot of old registry entries for prior versions of office, and still no change. I haven't been able to find a single setup difference between Outlook on my desktop and on my laptop, but they sure behave differently on this.

Thanks for the suggestion. I had high hopes while I was trying it.


Collapse -
Still not working
by j341 / April 11, 2007 2:17 PM PDT

That solution didn?t work for me either. There was only one file in that temporary outlook directory anyway, so that?s not it. Thanks for trying though.

Collapse -
rchipman Solutions Works Great...
by jbhaire2004 / February 5, 2008 1:36 AM PST

rchipman your solution worked great for me and was a lot easier than my method. For the users that are having an issue, the other method I have used is deleting the user profile. For those that are unaware of what that is or how to do that I'm going to plagurize a post I left else where that explains step by step how to accomplish this.

"The user profiles are the store for each users unique information. This includes the user accounts settings and folders such as the favorites, desktop, my documents, outlook email files, application data, etc. The user profiles are accessible by right clicking on the My Computer icon, going to properties, the advanced tab. Under the advance tab the second section is the settings for user profiles. If you are only a user you are going to have to get your IT dept with admin rights to do this. First you log in with an account with admin rights other than your own (although in this case it isn't relative). Next open the user profiles settings and create a copy of your current user profile by clicking the "copy to" button. Copy it to a folder outside the "Documents and Settings" folder in the OS drive root. This will enable you to get the data later. Depending on whether or not your company uses a domain or local account the steps will be different for recreating your account. (On a domain you simple log into the machine with a username and password. If it is a local account you have to verify that the account still exist. If it is, log back in. If not recreate your user account and log back in.) Windows creates the user profile on the initial log into to any machine."

I think that this unusual behavior relates directly to an outlook file not being quite right. This is a rather brut force method however if rchipman's method didn't work it is the only other way I found to fix this. I have used this on several occasions for user's who could view pictures in outlook. Delete the profile, log them back in and the issue was resolved.

Collapse -
rchipman Solution modified...
by jbhaire2004 / February 5, 2008 4:45 AM PST

I went through and found a step missing from what rchipman described and what worked for me. I am going to repost the entire solution as outlined by rchipman with the additional step included. What made the difference in my case was that I changed the OLK path in the registry key and increased the number following OLK by 1. (ie OLK4 became OLK5). That created a new folder. I then went in and manually deleted all of the content in the Temporary Internet Files folder. (You may need to change some Windows setting to get to this folder. This is a hidden system folder. To make it assessable modify under Windows Explorer -> Tools -> Folder Options. Under the View Tab uncheck "hide protected operating system files" and select "show hidden files and folders"). This solved the issues I was having.

Below is the modified rchipman instructions:
Images not being displayed in Outlook 2003 messages.

Issue has to do with the Outlook Temporary Items folder.

Close Outlook before preceding to the steps below.

1. Locate the Outlook Temporary Items folder by opening the Registry and finding HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\Security. Double click on the OutlookSecureTempFolder key. The value data is the path of the storage folder for picturse and starts with OLK. Change the OLK* to a number larger than the current value. (Best to increase the number by 1. i.e. OLK4 becomes OLK5)

2. Right click the Value Data field and select Copy. It should be in the form of %USERPROFILE%\Local Settings\Temporary Internet Files\OLK* where OLK* is some randomly generated string ending with a number that always starts with OLK.

3. Open Windows Explorer, paste in the Address field and press Enter (or select GO). You will be navigated to this folder.

4. Select All the files in this folder and Delete.

5. Launch Outlook. The images should now appear in the Email.

Collapse -
rchipman solution was always fine in my case
by Hayrolr / March 7, 2008 12:19 AM PST

Hi rchipman, thanks for that wonder solution. I was several days (maybe two months) looking for a solution to this issue. The images on each message only showed up when I make a replay or forward email to the original, that was a pain. I was close to delete/create the user profile, as my last chance to do, but thans to you I got the problem resolved.

Btw, the steps given for you are correct ... no mather what path you found in the OutlookSecureTempFolder key (in the registry) it's the right path to the folder that you need to clean (in my case the last part of the path was named OLKE (not number at the end, just a "E") .... and the only thing you need to do is copy this path and go there with the Windows Explorer (please, for thoses that are reading bad the steps) and delete all the content.

Thanks again.


Collapse -
Thanks! - Worked for me
by slackticus / January 27, 2009 8:00 AM PST


Deleting the contents of the OLK*** folder worked like a charm for me.

XP SP3 - Outlook 2003

I would have added that you can get to the registry by going to Run.. and entering "regedit" and then following these paths:

Outlook 97 ---> HKEY_CURRENT_USER\Software\Microsoft\Office\8.0\Outlook\Security
Outlook 98 ---> HKEY_CURRENT_USER\Software\Microsoft\Office\8.5\Outlook\Security
Outlook 2000 ---> HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\Security
Outlook 2002/XP ---> HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\Security
Outlook 2003 ---> HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\Security
Outlook 2007 ---> HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Security

Collapse -
deleting OLK temp directory contents
by dmollico / March 20, 2009 2:44 AM PDT

I am in a corp email outlook 2003, exchange 2003 environment.
We all have the same(ish) signatures with the same picture - just our names and office information are different.
I was able to create a new email message and our logo showed up just fine. But when i clicked send to say myself - the picture showed up as a red x in oulook 2003. Any other emails i received showed up as a red x as well.
i deleted the contents of the outlook temp folder - re-launched and it worked perfectly.
thank you very much!

Collapse -
by tomron / April 11, 2007 2:38 PM PDT

"This began happening a couple of months ago"

Did you up grade to IE 7?


Collapse -
Re Outlook
by j341 / April 11, 2007 2:48 PM PDT
In reply to: j341

Yep, I sure did. I've wondered about that connection. I believe every computer here that has the Outlook problem has IE7. Any idea how they?re connected?

Collapse -
by tomron / April 11, 2007 3:23 PM PDT
In reply to: Re Outlook

I didn't read the whole page,but maybe a possible solution,LINK

There are know issues with IE 7,many people revert back to IE6

Collapse -
Re: Outlook
by j341 / April 11, 2007 4:49 PM PDT
In reply to: j341

Thanks tomron for the lead. Yes, that?s obviously the source of the problem. Unfortunately the fix they suggest (the same one posted above by rchipman) doesn?t work for me. I tried it again and even threw in a reboot for good measure ? still doesn?t work. I guess we have to wait for MS to fix their booboo or revert back to IE6. I?m not sure it?s worth that hassle. For now I?ve just allowed all the graphics to download.

Thanks again tomron for the help. At least now I know where the problem lies.

Collapse -
(NT) Your welcome.thanx for posting back
by tomron / April 11, 2007 11:05 PM PDT
In reply to: Re: Outlook
Collapse -
by upstairs6 / April 12, 2007 1:41 PM PDT
In reply to: j341

Thanks, Tomron, for the good tip. I uninstalled IE7, and the problem had gone away. I re-installed IE7 (plenty of time to play solitaire), and the problem was back.

Interestingly, I have two other computers running IE7 and Outlook 2003 that are working just fine.


Collapse -
(NT) Your welcome,thanx for posting back
by tomron / April 12, 2007 1:56 PM PDT
In reply to: Confirmed
Collapse -
Suddenly, outlook 2003 emails won't show HTML photos.
by craiglv2 / April 13, 2010 8:40 AM PDT
In reply to: j341

I had this same problem and here is the fix that worked for me
Open IE and select TOOLS. Then select INTERNET OPTIONS, then select the ADVANCED Tab. Go to the bottom and click RESET INTERNET EXPLORER and then above that click RESTORE ADVANCED SETTINGS. save and close, and reboot. Then open Outlook and you should be able to see all your email HTML photos. Good Luck..

Collapse -
Outlook 2003 (and other email clients) won't diplay pictures
by grahamlinter / February 23, 2010 6:58 PM PST

If you are not seeing pictures in your emails then the first things to do are:
1) Open your preferred browser and check that it is set as the default browser. For example, if you use IE8 then click on the 'Tools' option, select 'Internet Options', select the 'Programs' tab and then check that Internet Explorer is set as the default browser. If it isn't then click on 'Make Default'.
2) If the above doesn't work and you are using Outlook then I would run a 'Repair' install.
The above have always worked for me when dealing with this problem.

Collapse -
Outlook 2003 won't download pictures
by budoinbatu / October 1, 2010 1:31 AM PDT

I just opened up IE and deleted the Temporary Internet files.

I don't know how/why that folder conflicts with my Outlook loading pictures, but "whatevah." As soon as I clicked the "Delete" button, the images came through. B*stard machine.

Collapse -
This one might be known.
by R. Proffitt Forum moderator / October 4, 2010 2:24 AM PDT
Collapse -
Outlook 2007 won't display images in email....
by sdruid / November 9, 2010 11:26 AM PST

After toying with Outlook for some time, I might have found a possible simple solution.
There are 2 changes that have to made under "Tools" and "Trust Center".
First, under "Automatic download" - uncheck the box labelled "Don't download pictures automatically in HTML email messages".
Last, under "Email security" - uncheck the box labelled "Read all standard mail in plain text"....
That should do it....

Collapse -
That opens the door to exploits.
by R. Proffitt Forum moderator / November 11, 2010 4:43 AM PST

The old corrupt jpeg problem makes me wonder if this is a good idea.

Collapse -
How to make images in your signature load in outlook 2003
by Walla121 / August 16, 2011 10:54 PM PDT

I found that I was loading the signature in a way that wouldn't work. By adding my signature a different way, the images load.

So, instead of adding a signature by going to tools, options, mail format and adding signatures... If i instead add a signature using that method then go on to alter it by following these steps:

1. Open up a new email to send to someone.

2. Right click on image in signature.

3. Click on 'email signature'

4. In the 'E-mail Options' box create a New signature. Save a new name for the signature and paste your new signature into the available box.

5. Click 'OK'

This should work now. I found the images in my signature work this way now.

This is the box that I was using to add a new signature: (FOLLOW LINK FOR PHOTO)

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions


Having Wi-Fi troubles?

From the garage to the basement, we blanketed every square inch of the CNET Smart Home with fast, reliable Wi-Fi.