Linux forum

General discussion

openSSO version 9.5.2 installation from response file

by egulik1 / November 2, 2012 6:27 AM PDT

Hello, all

I've been trying to install openSSO v _9.5.2_RC1 using a response file with openDS(ldap) backend and have a problem for which I can't seem to find a real answer, so any tip would be helpful. I'm running CentOS release 6.3 in a virtualbox with 1,5 GB of RAM. I was able to install openDS and start it but I'm not sure if its configured correctly. I'm attaching a script that I used for auto installation. (openDS-autoinstall.txt)

If I ask lsof here is what I get:
[CODE]$ lsof -i -n -P | grep 4444
java 6658 ldap 75u IPv6 37916 0t0 TCP *:4444 (LISTEN) -- which is ok, right :)[/CODE]

If I ask ps about openDS here is what I get:
[CODE]$ psg opends
6658 pts/3 Sl 2:47 /usr/lib/jvm/java-1.6.0-openjdk- -server -

Dorg.opends.server.scriptName=start-ds org.opends.server.core.DirectoryServer --configClass

org.opends.server.extensions.ConfigFileHandler --configFile /u02/OpenDS-2.2.1/config/config.ldif[/CODE]

Here are couple of more information that might help:

][CODE]$ showmemusage
6764 /usr/sbin/httpd
7208 /usr/sbin/httpd
7372 /usr/sbin/httpd
9856 /usr/sbin/httpd
12028 /usr/libexec/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --log-

error=/var/log/mysqld.log --pid-file=/var/run/mysqld/ --socket=/var/lib/mysql/mysql.sock
12580 /usr/sbin/named-sdb -u named -t /var/named/chroot
36920 /usr/bin/ruby /usr/sbin/puppetmasterd
131508 /usr/lib/jvm/java-1.6.0-openjdk- -server -Dorg.opends.server.scriptName=start-

ds org.opends.server.core.DirectoryServer --configClass org.opends.server.extensions.ConfigFileH
283748 /usr/lib/jvm/java-1.6.0-openjdk- -

Djava.util.logging.config.file=/u02/tomcat/conf/ -server -Xms512m -Xmx512m -

XX:MaxPermSize=256m -Djvm=tomcat_virtualbox -D

$ free -m
total used free shared buffers cached
Mem: 1478 1277 201 0 73 634
-/+ buffers/cache: 568 910
Swap: 2015 0 2015[/CODE]

The problem is that if I try to use this command as tomcat user it will give only one error message:

[CODE][tomcat@cent01 work]$ java -jar ~/work/opensso/tools/configurator.jar -f /home/tomcat/work/test.testdomain.example.config
Configuration failed!
[tomcat@cent01 work]$[/CODE]
- which is very helpful :(( I'm attaching this file as well. (test.testdomain.example.config.txt)

Here is the output from the tomcat log:

[CODE]Nov 2, 2012 1:33:42 PM org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet [AMSetupServlet] in context with path [/opensso] threw exception

[AMSetupFilter.doFilter] with root cause
com.sun.identity.setup.ConfiguratorException: Cannot connect to Directory Server.
at com.sun.identity.setup.ServicesDefaultValues.setServiceConfigValues

at com.sun.identity.setup.AMSetupServlet.processRequest(
at com.sun.identity.setup.AMSetupServlet.doPost(
at javax.servlet.http.HttpServlet.service(
at javax.servlet.http.HttpServlet.service(
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter

at org.apache.catalina.core.ApplicationFilterChain.doFilter(
at com.sun.identity.setup.AMSetupFilter.doFilter(
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter

at org.apache.catalina.core.ApplicationFilterChain.doFilter(
at org.apache.catalina.core.StandardWrapperValve.invoke(
at org.apache.catalina.core.StandardContextValve.invoke(
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(
at org.apache.catalina.core.StandardHostValve.invoke(
at org.apache.catalina.valves.ErrorReportValve.invoke(
at org.apache.catalina.valves.AccessLogValve.invoke(
at org.apache.catalina.core.StandardEngineValve.invoke(
at org.apache.catalina.connector.CoyoteAdapter.service(
at org.apache.coyote.http11.AbstractHttp11Processor.process(
at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$

If I try to use status command then here is what I get:

[CODE][user1@cent01 openDS]$ sudo service opends status

>>>> Specify OpenDS LDAP connection parameters

Administrator user bind DN [cn=Directory Manager]:

Password for user 'cn=Directory Manager':
Unable to connect to the server at "" on port 4444

--- Server Status ---
Server Run Status: Started
Open Connections: 0

--- Server Details ---
Host Name:
Administrative Users: cn=admin
Installation Path: /u02/OpenDS-2.2.1
Version: OpenDS Directory Server 2.2.1
Java Version: <not available> (*)
Administration Connector: Port 4444 (LDAPS)

--- Connection Handlers ---
Address:Port : Protocol : State
-- : LDIF : Disabled : SNMP : Disabled : LDAPS : Disabled : LDAP : Enabled : JMX : Disabled

--- Data Sources ---
Base DN: dc=testdomain,dc=com
Backend ID: userRoot
Entries: <not available> (*)
Replication: Disabled

* Information only available if you provide valid authentication information
when launching the status command.

The best thing is that if I go through web wizard and follow that web-wizard it will work without any problems but I don't want to do it in that way. I would like to have automated with a script from a command line Happy

Thanks for any kind of tip or direction !!!

Post a reply
Discussion is locked
You are posting a reply to: openSSO version 9.5.2 installation from response file
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: openSSO version 9.5.2 installation from response file
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
by R. Proffitt Forum moderator / November 2, 2012 6:35 AM PDT

After I read I decided I would never go near this one and would look at the alternatives below. I can only guess why you want to be near Oracle.

Collapse -
solved: openSSO version 9.5.2 installation from response fil
by egulik1 / November 5, 2012 1:20 AM PST

Hello all,

I figured it out and just wanted to share this with everyone who may experience the same thing.
If you get error like this:

[CODE][tomcat@cent01 work]$ java -jar ~/work/opensso/tools/configurator.jar -f /home/tomcat/work/test.testdomain.example.config
Configuration failed![/CODE]

and nothing else in the screen then I advise you to check your 'input' file as in my case is: /home/tomcat/work/test.testdomain.example.config. The issue in my case was that for some reason configurator thinks that line that starts with '#' sign means something and doesn't know what to do with it, so for every comment that you placing in this file you have do it like this:

# Configuration data store configuration

Here is the way I had it before:

# Configuration data store configuration

Good luck.
Administrator - please mark this thread as solved.
Thank you

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

CNET Holiday Gift Guide

Looking for great gifts under $100?

Trendy tech gifts don't require a hefty price tag. Choose from these CNET-recommended useful and high-quality gadgets.