Windows 7 forum

General discussion

Not enough storage is available to process this command???

by wyrmzr / February 19, 2010 12:15 PM PST

I've got a fairly recent Win7 x64 install on my system.
Since Beta, I've been getting an error message "Not enough storage is available to process this command", which is accompanied by a stop code 0xc142 when launching items like Task Manager.
I've seen the first error is typically related to the Windows Desktop Heap, but I've set from the original (2GB if I'm reading it correctly), to 4GB of space.
I'm running a system with 1.7TB of AVAILABLE drive space (20GB on the OS drive as it's a smaller SSD drive) and 6GB of RAM. I've tried varying the windows page file from 500MB to the system-controlled 6GB with the same result.
Has anyone else seen this, and does anyone have an idea what I may be missing here?

Post a reply
Discussion is locked
You are posting a reply to: Not enough storage is available to process this command???
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Not enough storage is available to process this command???
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
And if you google it
by Jimmy Greystone / February 19, 2010 9:03 PM PST

And if you google it, how do the various suggestions for fixing it that you find fail exactly?

Collapse -
Presumably a desktop heap issue
by wyrmzr / February 19, 2010 10:21 PM PST
In reply to: And if you google it

Well, the registry edit that's commonly recommended notes that Vista and 2003 saw the Desktop Heap change from 512MB to either 768MB or 3GB (according to When I checked my registry settings, Win7 was at 2GB of Desktop Heap. I've increased this to 4GB, but, no matter which programs I run during the day, I still continue to get this message.
I've changed web browsers, tried using multiple other programs for my basic text editing needs, and in general modified my activities as much as I can to try and determine whether I've simply got a "leaking" program. But, given the popularity of my Firefox browser, and only using programs like Wordpad most of the time otherwise, I'm getting this error.
If my (very) common programs have huge memory leaks, I'd at least expect to see more results in a Google search....

Collapse -
And just to be sure...
by wyrmzr / February 19, 2010 10:30 PM PST

The 3rd number in the registry entry was 768, which is the non-interactive heap. I've been seeing several sites tell me NOT to increase this by very much, but if it will fix the issue without causing other problems, then maybe it's worth a try?
I try to be conservative when making such changes, but if my system specs are *that* much higher than what was planned for Win7 x64... Well, I'll be surprised, at least.

Collapse -
Not sure where
by Jimmy Greystone / February 19, 2010 10:48 PM PST

Not sure where you came across that, because after a bit of Googling myself, everything seems to keep pointing back to this MSKB article.;en-us;177078

I wouldn't be surprised if you had Norton or Symantec AV installed and they never quite squashed this bug. Symantec doesn't exactly have the best of reputations for that sort of thing after all. I mean, it took them like 2 weeks to sort out a bug in their enterprise AV client that prevented it from accepting any definition update with a time stamp in 2010. A bug that should have been caught and fixed back when there was a mad scramble for the Y2K fix.

But I digress. Take a look at that MSKB article, and give it a try. Most likely worst case scenario is it does nothing. Might also be prudent to really scour your system for any trace of malware.

Collapse -
Wrong error message
by wyrmzr / February 19, 2010 10:57 PM PST
In reply to: Not sure where

That error message is similar, but not the same. Server storage space isn't mentioned in this one (and I'm not running Symantec or McAfee).
This one has all the symptoms of a Desktop Heap failure, but I should have all heap necessary.
(That message did also come up in Google searches, but ends up being totally unrelated, despite the similar wording)

Collapse -
Oh, and..
by wyrmzr / February 19, 2010 11:05 PM PST
In reply to: Not sure where

I've been trying to get dheapmon to run to analyze for what may be taking up my desktop heap, but am unable to get the symbol server to cooperate.
I know dheapmon 8.1 is compatible with Vista, at least, and is supposed to be x64 compatible as well, but even the remote symbol server using dheapinst.exe -y srv* is giving "driver installation error occured (124)".
If there's another program that will monitor my desktop heap, I'd love to see it.

Collapse -
by D34d10ck / March 8, 2011 8:24 AM PST
In reply to: Oh, and..

Did anyone fix this my win 7 just started doing the same thing. I don't use symantec or mcaffe either. I have been IT for 20 years and never seen this many bugs as in win 7 server 2008 r2 ent and exchange 2010 I am so fed up with this micro-crap software. I wish I could just use my Android for everything.

Collapse -
by D34d10ck / March 8, 2011 8:25 AM PST
In reply to: Not sure where

Any luck anyone. I'm wiping and reinstalling but the machine won't even let me plug in a thumbdrive.

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

CNET Holiday Gift Guide

Looking for great gifts under $100?

Trendy tech gifts don't require a hefty price tag. Choose from these CNET-recommended useful and high-quality gadgets.