TVs & Home Theaters forum


No video playback with LG Plasma through smart hub samsung

by girlvstech / September 18, 2013 4:16 AM PDT

I was able to hook up my Samsung SMART HUB Blu-Ray player Model BD-D5300 to my roomate's 2007 LG 50PC5D-UC Plasma television.

I set the Blu-Ray player to 720p and successfully connected to the Smart Hub and internet connection.

All still pictures show fine. Whenever you try to run a video (in this case it was through HULU Plus) I got audio but the video was just a blank turquoise screen.

I found something about possibly needing to update the firmware on the television, but have unsuccessfully located how to do that for this model.

Am I doomed with this combination of electronics to stream video?

Thanks in advance!

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: No video playback with LG Plasma through smart hub samsung
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: No video playback with LG Plasma through smart hub samsung
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Maybe there's a fix
by Pepe7 / September 18, 2013 4:29 AM PDT

I would post your question over at AVS forum. Look in the plasma sub-forum.

*search for a thread on that particular LG plasma by using the model number. It's an older model, so there might not be much until you scroll back quite far in the archives.

Collapse -
further info on things I have tried...
by girlvstech / September 18, 2013 4:59 AM PDT

I set the aspect ratio on both the blu-ray and tv to the lowest 4.3. Requested videos be streamed in SD. (I actually tried all the options.) Still that darn blue screen.

I will try that AVS forum next. Thanks!

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

CNET Holiday Gift Guide

Looking for great gifts under $100?

Trendy tech gifts don't require a hefty price tag. Choose from these CNET-recommended useful and high-quality gadgets.