Computer Newbies forum

General discussion

No Sound using an HDMI cable from a laptop to a TV

by lil_goldie / January 14, 2010 6:55 AM PST

I know there is a similar thread about this problem, but we've tried everything suggested to no avail.
We're trying to connect an Acer laptop running Windows 7 to a Samsung Plasma.
We're read the plasma manual and it told us we needed HDMI and a 3.5mm RCA to the Audio In. I'm confident we have all the plugs in the right spot.
I tried to follow their directions on
http://support.gateway.com/s/Mobile/2009/PSeries/P-78/P-78faq22.shtml

Both the parts are not helpful.
The bottom portion is called
"Follow these steps to change the audio output settings for the HDMI option."
We make it all the way to step 5, however no HDMI sound option is available.
Acer would like me to pay for technical support or they said our driver may not support the sound part.
The computer has an HDMI output, how can this not be working for us.
Any thoughts?

Post a reply
Discussion is locked
You are posting a reply to: No Sound using an HDMI cable from a laptop to a TV
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: No Sound using an HDMI cable from a laptop to a TV
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
No model number
by R. Proffitt Forum moderator / January 14, 2010 8:23 AM PST

So I can't check if this model does sound over HDMI.

But don't plug in any speaker, headphone or 3.5mm RCA to the Audio In if you want to pipe audio over HDMI. That's one way to disable audio over HDMI on some machines.

Again, if you posted the model number and I missed it, sorry.
Bob

Collapse -
Hmm. In my control panel, HDMI is the audio playback.
by R. Proffitt Forum moderator / May 9, 2010 4:49 AM PDT
In reply to: No model number
Collapse -
No model number
by whatthedilio / September 7, 2011 1:06 PM PDT
In reply to: No model number

I'm having a similar problem. I have a Dell Inspiron 1525 (Windows XP Pro SP3; SigmaTel Audio; Intel High Def Audio HDMI). When new, the HDMI cable delivered sound and picture flawlessly. The hard drived failed so I got a new one and reinstalled the system. . . now there is a picture but no sound through the HDMI cable, even after implementing the change in Control Panel|Sound|HDMI...

Collapse -
My bet is someone updated the drivers.
by R. Proffitt Forum moderator / September 7, 2011 1:11 PM PDT
In reply to: No model number

I'd go back to what worked.

Collapse -
No model number
by whatthedilio / September 7, 2011 2:29 PM PDT

Nope, it was the original drivers. I just updated the drivers to see if that would help but it did not. Oddly enough, when I plug in the HDMI cable and select the appropriate input, the tv (Sharp Aquos) won't allow changes to the audio -- when using the tv normally (i.e., watching cable tv), I can toggle between mono, stereo, or CC.

Collapse -
Then there's little else to be done.
by R. Proffitt Forum moderator / September 7, 2011 2:40 PM PDT
In reply to: No model number

Since using the Dell site, Service Tab and Dell's drivers do not correct it you are faced with a total reload with the Dell CDs. I would have used the Driver CD but that's not an option it seems.

Workaround? Get an audio cable.
Bob

Collapse -
Try This Instead

Hi, found another cause for others who are still facing this problem:
This is due to Nvidia updated drivers- that somehow cause some conflict.
Go to "Control Panel", then "Uninstall programs" then uninstall "Nvidia updated drivers" if you have any.
This helped restore the sound to my TV via HDMI.

Collapse -
Use SPDIF as the default playback
by duf15 / May 9, 2010 1:58 AM PDT
In reply to: Try This Instead

Control Panel>Sound

Change default playback to SPDIF

Collapse -
HDMI use SPDIF
by duf15 / May 9, 2010 1:56 AM PDT

You need to go to control panel>sound. Use SPDIF as the default playback.

Collapse -
steps to get sound using an HDMI cabel from laptop to a TV
by sam09092009 / August 7, 2010 6:04 PM PDT

1- go to sound option

2-click on TV showing on the sound option

3- your in properties find high definition audio device click on properties

4- your in high definition audio device click on properties click on change settings

5- click on DRIVER option

6- click on ROLL BACK DRIVER IF THAT DONT WORK TRY TO UPDATE DRIVER

Collapse -
thanks a lot
by drokstef / January 25, 2011 1:30 AM PST

that really worked ! on my HP laptop connected by HDMI with my tv Philips

Collapse -
I KNOW THE ANSWER
by anisahu / February 25, 2011 7:37 AM PST

so .. if your in sounds and in play back and you dont see hdmi.. right click in the white area and select show disabled devices.. and hdm1 will show up if you do have an hdmi output on your computer.. hope this helps:)

Collapse -
Thank you
by foysta / May 20, 2012 6:33 PM PDT
In reply to: I KNOW THE ANSWER

Hello anisahu,

You are a champion, i accidently disabled HDMI sound and have been trying for days to inable again, your advise was spot on.

Thanks

Collapse -
You da man
by Mastershrek65 / June 7, 2012 8:01 AM PDT
In reply to: I KNOW THE ANSWER

Thanks so much. No offense to others but it seemed like a lot of the answers on this thread didn't even relate to this problem. Thanks again.

Collapse -
Change Default device
by suwondo_alim / April 20, 2012 1:19 PM PDT

I'm using HP notebook using XP, this one works for me :
Go to Control Panel -> Sound Audio Device -> Audio -> Sound Playback
Change Default device to Intel Display Audio Output

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Big stars on small screens

Smosh tells CNET what it took to make it big online

Internet sensations Ian Hecox and Anthony Padilla discuss how YouTube has changed and why among all their goals, "real TV" isn't an ambition.