Phones forum

Question

network login problems from smartphone

by hvfd13 / February 15, 2012 7:00 AM PST

I have my router's port forwarding configured so that i can access what's called "aquacontroller" from the outside world. This way, no matter where i go i can view and change my aquarium settings via the internet. (for example, turning on and off lights, heaters, pumps, ect.) On a computer, it works like a charm, and always has. However, smartphones (other than the iPhone) have a problem logging in. When you go to the site, and type in the credentials it just continously pops up the credential page to login, making it useless. Ive tried multiple Androids and Blackberrys and they all have the same problem. iphone is the only smartphone that works correctly. Does anyone know what the problem could be?

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: network login problems from smartphone
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: network login problems from smartphone
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
So it does not work.
by R. Proffitt Forum moderator / April 3, 2012 1:29 AM PDT

You'll have to chalk it up as the author of the system has not tested and corrected what needs to be fixed yet.

For your part, did you contact the author/support of this aquacontroller?
Bob

Collapse -
Answer
Browser Configuration?
by kosai19 / April 17, 2012 9:37 AM PDT

Hi,

I work for a telecom comp. supporting smartphones and I've come across this type of issue many times. It's harder to pinpoint since the reason changes why it happens but generally there are two main ones:

1. Browser type: Most websites will change the way they display pages depending on what browser is used to view the page. In order for the site to know it gets the browser title from your computer/device. It sounds like your website login doesn't support being used by mobile devices, so it may not have an entry for them. iPhones use the safari browser, which is on the Mac (a supported browser). So that may account for it. Also, the iPhone in general handles web pages more like a computer so it can typically view pages other devices can't. Solution: For the Blackberry try changing the "browser type" option. It lets you modify this since there are comptability issues like this for pages that don't work with mobile devices. Change it to internet explorer and it will tell you if it has to do with browser type.

2. The website is using an unsupported feature: This is most likely the cause as the iPhone connects to pages more like a computer would than other smartphones. Java and Javascript for instance has limited supported on most mobile devices. They also lack many other features, like flash. So it depends on what Blackberry device you have and what software it has been updated with, since over the years the supported pages have grown with each update. If changing the browser type doesn't resolve it on the Blackberry it is likely because it's using some scripting language on the website that the device's browser doesn't support. One possible solution is to download another browser on the blackberry (using Blackberry App World). I have heard of this fixing this type of issue.

Hope that helps.

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech for the school year

Smart tech for smart students

Forget the pencils and notebooks. Gear up your students with these portable and powerful note-taking machines.