Computer Help forum

General discussion

Monitor won't wake up after sleep

by kaboyd / June 29, 2008 3:24 AM PDT

After putting my G4 Mac to sleep, I can wake it up just by pressing any key on the keyboard but about fifty percent of the time my monitor will remain dark (apparently, no power is reaching the keyboard). My only option then is to restart the computer. I would very much like to get rid of this annoying problem.

Discussion is locked
You are posting a reply to: Monitor won't wake up after sleep
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Monitor won't wake up after sleep
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
common
by squirtlewa / June 29, 2008 9:01 AM PDT

I don't know a good solution. I know it's common.

My not-so-good solution is to disable sleep. Silly

Collapse -
Waking sleeping Computer
by rmcharlie / March 7, 2009 11:18 AM PST

I have spent 3 days with the same problem, the concensus is to just turn off the sleep mode. Control panel, power options, change when the computer sleeps and put never. This works for a desk top. As for lap tops, i hope you have a lot of batteries.

Collapse -
This worked for me
by onedigger / December 23, 2010 11:33 PM PST

I don't know if this works for those that have more than one monitor but this solved our problem.

Vista: Go to: Start - Settings - Control Panel - Personalization - Display Settings - (If it shows two or more monitors, click on the other(s) that are not the default monitor and 'un-check' the box stating "Extend the desktop onto this monitor". Hit apply; hit Ok and reboot the computer.)

XP: Right click on Desktop, choose Properties - Display Properties - Settings - (If it shows two or more monitors, click on the other(s) that are not the default monitor and 'un-check' the box stating "Extend the desktop onto this monitor". Hit apply; hit Ok and reboot the computer.)

This should solve not only the sleep problem but the cursor going off the desktop screen. I don't know why but it worked for us and we only have one monitor. For some reason the computer and graphics card think we have more than one monitor.

Hope this helps!

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Tech explained

Do you know what an OLED TV is?

CNET explains how OLED technology differs from regular TVs, and what you need to know to make the right shopping decision.