Computer Help forum

Resolved Question

Many problems re: Java

by hikergirl / February 11, 2013 11:37 PM PST

-I have XP Pro w/SP3, FF
-Two days ago, I began updating all software. Only one problem, that I'm getting help w/elsewhere.
-Today, I get an error window: jusched.exe: App name: jusched.exe; ModVer: 5.1.2600.5512; AppVer:; Offset: 000187f1; ModName: user32.dll.
-In Downloads, I put: jre-7u13-windows-i586.exe. When I attempted to install this, I got ...applicationdata\Sun\Java\jre1.7.0_13\java_sp.dll is corrupt
-I went to the Java Sun Website, that instructed to use offline installer. I got the message that the software has already been installed on your computer. Would you like to reinstall it? I chose "no".
-Java site has instructions to delete old versions - thought to be security problem. When I attempted to uninstall: Java 6, Updates 2, 5, 7 and SE Runtime Environment 6 Update 1, I got "fatal error during installation".
-I installed the newest Java Runtime Environment plug-in. A window came up indicating it was already installed (but Java 7 Update 13 - not plug-in - was already installed). I instructed to reinstall & Java Runtime Environment 1.7u13 was installed.
-I noticed the Java icon is now missing from Control Panel.
-Again, I attempted to delete old version, with same results as above.
-I came here for help, as I cannot pay $50+ for Java help.
-Please keep any instructions basic and simple - I don't understand computer terminology.
-Many thanks.

hikergirl has chosen the best answer to their question. View answer
Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Many problems re: Java
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Many problems re: Java
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Best Answer chosen by hikergirl

Collapse -
Re: Java
by Kees_B Forum moderator / February 11, 2013 11:48 PM PST
In reply to: Many problems re: Java

Looks like it's some mess.

But let me start asking: do you need Java? Many people don't.

If 1.7u13 (the most recent version) says it's installed I assume it is, more or less. Did you ever use the Java icon in the control panel in the past? So let's do a basic test: does Java work?

If you don't trust it, try System Restore back before 2 days ago. But that will undo all your other updates also (if it works, sometimes it doesn't for some unclear reasons). That was the moment I started using Acronis so I could go back to the image of my OS disk.


Collapse -
Java is a must for photo sharing
by hikergirl / February 12, 2013 6:21 AM PST
In reply to: Re: Java

So, yes, I need Java. And, yes, it works.
The Java icon in the Control Panel is missing. This happened once before, but I have no memory of what I did to get it back.
It's too long a story to go into, but I cannot use System Restore - it doesn't work.
Do you think that uninstalling, and re-installing, 1.7u13, will solve the problem of how to get the Java 6 updates 2, 5, 7 and SE Runtime Environment 6 Update 1 deleted?
I'll try to uninstall/reinstall right now.

Collapse -
Try Using Java Ra to Uninstall All Java
by Grif Thomas Forum moderator / February 13, 2013 6:09 AM PST

First, attempt to uninstall all Java from the Control Panel-Add/Remove Programs.. Once that's done, download, unzip, then install and use the Java Ra program to uninstall everything that's left..

If you still have remnants, then use the freeware version of Revo Uninstaller from the link below.. Install and run Revo, then select ONLY the Java items listed and let the program remove them.

Hope this helps.


Collapse -
unistall Java
by hikergirl / February 13, 2013 10:00 PM PST

Grif - I have deleted the latest Java, but, as previously stated, the remaining attempts were "fatal error during installation."
I downloaded javara, as you suggested. I unzipped the program; however, once I unzipped the downloaded program, there is no way to install and run the program. The only option I see is to open all the machinations of the program.
Any suggestions? Thanks.

Collapse -
When you unzipped ...
by Edward ODaniel / February 14, 2013 4:36 AM PST
In reply to: unistall Java

the JavaRa download (file should have been named - if not download the proper file from this link - ) there is no installation. You will see a sub folder of whatever folder you unzipped it to that is named JavaRa and it will contain JavaRa.exe, JavaRa.def, and config.ini as well as a subfolder named localizations. Run the executable JavaRa with an administrator account (right click it and select to run as administrator) - if you do not have your file manager set to show extensions the icon for the executable will look like a blue cloud with a sun behind it.

The link above offers you all the documentation you should need.

Collapse -
by hikergirl / February 14, 2013 5:33 AM PST
In reply to: When you unzipped ...

Thank you, Mr. ODaniel.
I did exactly as you said. Here is what I got:
"JavaRa.exe .NET Framework Initialization Error - Unable to find a version of the runtime to run this application."
All the MS updates were done this a.m. Any ideas?
Is it OK to go ahead and use the revouninstaller, as suggested by Grif Thomas, at this point?

Collapse -
One Of Two Options Now...
by Grif Thomas Forum moderator / February 14, 2013 8:00 AM PST
In reply to: JavaRa.exe

Either install NET Framework (According to Singular Labs, the provider of Java Ra, any version will work), or you can run the Revo Uninstaller and see how it goes.

If you'd like to download and install a version of NET Framework, you can use the link below to do so.

NET Framework 4.0 Standalone Installer

Hope this helps.


Collapse -
by hikergirl / February 14, 2013 8:54 AM PST

I have: .NET FW 1.1 + 2 security updates; .NET FW 2 SP2 w/all its parts + update; .NET FW 3 SP2 same as FW2 SP2; .NET FW 3.5 SP1 w/all updates + 1 hotfix; and .NET FW 4 client profile w/security updates.
1) Is it really necessary to install .NET FW 4.0 Standalone Installer, with all these I have?
2) "See how it goes" re: Revo Uninstaller, leaves me feeling very uneasy.
Any reassuring words? I have had many problems with deleting another program, because it would not update. I'm feeling this entire process has become very burdensome, and I do not wish to cause more problems than with what I am already dealing. Reassure me....

Collapse -
The NET Framework Version You Have Should Be Fine
by Grif Thomas Forum moderator / February 15, 2013 8:20 AM PST
In reply to: .NET FW

Since "any version" should allow Java Ra to work, you shouldn't need to install 4.0.. That said, give a try to Revo Uninstaller.. I've used it a number of times and it's fairly straight forward.. Just be sure to ONLY select the Java items when identifying which things you want to uninstall.

Hope this helps.


Collapse -
For Pros - only
by hikergirl / February 15, 2013 10:00 PM PST

I installed the revouninstaller program - which is only for Pros.

Since I do not understand computer-speak, I cannot use this program.

I tried to delete one Java item at a time, only to be faced with a number of sub-parts, which can be chosen only one at a time - not an entire program.

Unless you have something else up your sleeve, I am dead in the water.

Since I had deleted what Java programs I could, my computer will not boot readily. The first time I attempted to boot, after deleting Java programs, it took 3 tries to boot.

Then, yesterday, I had to abort a log-on time, as the screen went totally black - not the usual shimmery gray/green - and would not come back. I had to force the shut-off.

Help! Please.....

Collapse -
There Is A Freeware Version Of Revo...
by Grif Thomas Forum moderator / February 16, 2013 2:50 AM PST
In reply to: For Pros - only

It's at the same link I provided earlier.. It isn't that difficult to run but if it's beyond your ability, then maybe you need assistance at your location. And yes, you may need to remove one piece of java at a time as that's what Revo Uninstaller does when there are "remnants" on the machine.

Unfortunately, I'm not sure that Java or NET Framework are the only problems with your computer.. I've never seen issues such as yours when simply trying to install/uninstall Java.. It sounds like you've got issues with other system files besides NET Framework, etc. Although I might suggest running System File Checker "SFC /scannow", or even running a repair install, I'm not sure performing such steps are in your skill level. You may need to get some personal help at your location.

Hope this helps.


Collapse -
.NET could well be ...
by Edward ODaniel / February 15, 2013 1:37 PM PST
In reply to: .NET FW

the root cause of your problems.

Sometimes it gets corrupted and since the versions are cumulative it is hard to fix.

Generally removing all then installing 1.1 alone gets you going. This is because any app that requires a higher version informs you and generally offers to install what is needed.

Here is a link to a VERY HANDY uninstaller for .NET -

READ that page to understand just what it does then go for it.

Collapse -
by hikergirl / February 15, 2013 10:06 PM PST
In reply to: .NET could well be ...

All the .NET FW programs were newly installed and updated on Dec. 12, 2012.

For a longtime (since last summer), I could not get any type of update from Microsoft. But, in the meantime, I had run the defragmenter with the OS. There were lots of fragments. I tried running the defragmenter, but no success.

One day last December, I was running ccleaner and saw their defraggler listed. All the bells went off; I installed and ran the program. A miracle had occurred. The fragmentation is what had kept the .NET and all other updates from updating. The system remains in good shape, fragment-wise.

So, everything .NET is only 2 months old. As there is nothing updated since 12/13/12, everything should not be corrupted.

Collapse -
revouninstaller pro
by hikergirl / February 18, 2013 7:43 AM PST

OK - My first attempt at using this was not good - operator error Shocked
I tried, again, yesterday and had total success. Seems I was trying to make something easy, difficult.
So, many, many thanks for helping me clean out all the old Java stuff - and, believe me, it was old.

Collapse -
(NT) Good Job & Thanks For Posting Back !
by Grif Thomas Forum moderator / February 18, 2013 8:12 AM PST
In reply to: revouninstaller pro
Collapse -
Uninstall Java, then download & install
by wpgwpg / February 11, 2013 11:44 PM PST
In reply to: Many problems re: Java

Try uninstalling Java (via Add/Remove Programs applet of Control Panel), then go to and download & install Java again. I assume you're aware of the many recent warnings about security exposures with Java. A lot of folks are uninstalling it and not reinstalling. However if your application(s) are dependent on it, it's a risk you may have to take. If so, be sure to have a good antivirus program, keep it up to date, and stay behind a firewall.

Good luck.

Collapse -
Java security problems
by hikergirl / February 12, 2013 6:24 AM PST

Although I was not aware of it, now that you mention it, when I'm in my photobucket account (which requires Java), I'm continually getting red messages that malicious URLs are being blocked (my OS, for one, and Firefox).

Is there anything else that does the same thing as Java and would be acceptable for use in photosharing???

Collapse -
I use photobucket and don't have JAVA installed.
by R. Proffitt Forum moderator / February 12, 2013 6:50 AM PST
In reply to: Java security problems

I do have javascript enabled but that's not JAVA.

Tell more.

Collapse -
java disabled
by hikergirl / February 13, 2013 5:49 AM PST

I disabled the Java plug-in.
Now, I need to know how to delete the old versions of Java. It is my understanding they create a potential security problem.
I have not yet gone back into photobucket, because 1) they are in beta; 2) beta has made a horrible mess of my albums, and 3) no one is able to get in to look at the pics.
I'll run ccleaner, again, to see if it picks up anything re: Java.

Collapse -
See below.
by R. Proffitt Forum moderator / February 13, 2013 6:42 AM PST
In reply to: java disabled

I was going to mention JAVA RA but see our good guy Grif has it covered below.

Collapse -
Java installer is corrupt
by hikergirl / February 12, 2013 6:48 AM PST

Because I don't know if I can get Java reinstalled, I left it in place. I did attempt to download the installer. This is what I got>>
"Error - Java Installer: Downloaded File c:\DocumentsandSettings\customer\ApplicationData\Sun\Java\jre1.7.0_13\java_sp.dll is corrupt"
Any suggestions? Logic tells me that, without an installer, one cannot install the software. Thanks.

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions


Having Wi-Fi troubles?

From the garage to the basement, we blanketed every square inch of the CNET Smart Home with fast, reliable Wi-Fi.