MacBooks

General discussion

Macbook 2,1 Built In Sound Stopped Working after Snow Leopar

by cobrie04 / September 4, 2009 7:02 AM PDT

I have a macbook 2,1, the white one. Has anyone else had their regular built in sound just stop working right after upgrading to snow leopard? I can get sound to play through headphones, but once I up plug them the little sound icon in the menu bar will grey out and I will not be able to get sound to play through the internal speakers.

If I go to the Sys Pref > Sound > Output Pane, it will say "The selected device has no output controls" in the Settings for Selected Device section.

Any help would be great!!! I upgraded my girlfriends laptop to Snow Leopard even though she could care less. Now she's all mad cause the sound doesn't work.

THanks!

Discussion is locked
You are posting a reply to: Macbook 2,1 Built In Sound Stopped Working after Snow Leopar
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Macbook 2,1 Built In Sound Stopped Working after Snow Leopar
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
MacBook1,1 - Same problem
by macgeek415 / September 10, 2009 3:43 PM PDT

I have a MacBook1,1 - with the exact same problem. Works fine with headphones, I get startup chime, but shortly after finder loads the sound icon is suddenly and inexplicably going grey until I use headphones. Clearly there's nothing wrong with my sound card - and I didn't have any trouble until upgrading to 10.6.1 Sad

Collapse -
Oops
by macgeek415 / September 10, 2009 4:06 PM PDT

Turns out it was only coincidence in my case, that it was right after I upgraded. After posting that, I noticed a red light coming out of my headphone jack. I plugged in some headphones and gently wiggled the plug as I pulled it out. Red light went off and sound options came back.

Collapse -
Same problem-- built in speakers don't work!
by twirlingsheep / September 12, 2009 9:06 AM PDT
In reply to: Oops

Exact same problem, except that I can't get the built-in speakers to work by wiggling the headphone cord. I can listen to sound through my headphones, but not through the speakers. In the system preference there is no option under "output" for built-in speakers, only the option to choose headphones. It is really odd. You simply wiggled a cord? I still have the red internal light. Did you recently install/uninstall anything? Any suggestions?

Collapse -
No cure but,
by mrmacfixit Forum moderator / September 13, 2009 1:15 AM PDT

the red light is the optical output of that port

P

Collapse -
Built in sound stopped working
by jgmoore / September 16, 2009 4:56 AM PDT

I've had the same problem with my MacBook Pro 17" after upgrading to Leopard and it continues with Snow Leopard. Resetting PRAM restores only the startup chime and then it the sound output stops. Headphones work fine and the headphone output shows up in the sound preference pane. When headphones are unplugged the preference pane only shows the digital sound output.

If this is a driver issue, the driver seems to disappear on it's own.

Any other thoughts out there?

Collapse -
aghh!
by ajacob24 / September 22, 2009 9:47 AM PDT

I don't think this is a driver issue, but I am experiencing the exact same issue as everyone else. I have been able to get the opening chime sound, but that is all. One minute the sound was working fine, then I used headphones for a few hours, then the sound stopped! I'm currently on hold with apple in hopes that someone can give me some insight as to what happened.

Collapse -
Calm down and take a deep breath...
by jgmoore / September 22, 2009 10:22 AM PDT
In reply to: aghh!

I've done a lot of research on this particular problem and I think they fall into two groups, software and hardware.

Many of the forums out there say the problem occurred after yanking out a set of headphones and may be fixed by poking a toothpick in the headphone socket or wiggling the headphone jack. Many posts say this worked but did not work for me.

My problem started when I inherited a MacBook Pro 17" laptop with OS 10.5.6 installed on it, but the machine had no built in sound and the only driver showing in the sound preference pane was the digital output driver. I upgraded to OS 10.6, then OS 10.6.1 and the problem continued. I then wiped the disk and installed OS 10.5.1 and did a combo updater to 10.5.8, then installed OS 10.6. The problem was still there.

I then wiped the drive clean and installed OS 10.5.1 (without doing any updates) and immediately upgraded to OS 10.6.

Voila! My sound is back without any problems and the sound preference panel shows the built-in sound driver (without any digital out driver).

My belief is that if you have the software issue, then it depends on how you go about doing the updates or upgrade in Leopard and/or Snow Leopard.

Anyone else have any ideas?

Joe

Collapse -
Re: Calm down and take a deep breath...
by ajacob24 / September 22, 2009 10:44 AM PDT

I think I found a solution. After resetting the System Management Controller by holding left-shift+control+option my sound has been restored!

Depending when your Mac is made, there are a few different ways to go about this... I found some info here http://support.apple.com/kb/HT1411

Collapse -
Macbook loss of sound
by Baron Bolligrew / December 31, 2009 7:58 PM PST

I had exactly the same problem and the thought of having to do all those re-installs scared me, quite frankly, so I went for the gentle prodding with a toothpick option.

That didn't work - So I got a set of headphones and tried inserting and removing the jack a few times. This did nothing. I then tried with the same jack but as I inserted it, I applied downward pressure to the rubber moulding of the jack, so in effect aiming the pin of the jack at the upper, inside section of the jack socket to try poking at whatever connection may be stuck! I repeated this many times - slowly applying pressure to the rubber moulding in all directions (imagine a clock face) and when I removed it each time, I waited for the red light tome come back, which it always did.

Until it finally worked!

I should point out that after several failed attempts and the re-install option looming - I may have got a bit over zealous with the pressure I was applying and was probably lucky I didn't break the jack and leave the pin in the socket!....Be careful and good luck!

Collapse -
Macbook loss of sound
by dungerees / February 15, 2010 10:21 AM PST
In reply to: Macbook loss of sound

Great! That worked for me a treat. I had the same thing of having sound only through the headpones but not the speakers. Sound incon grey'd out, red light from the jack etc.

I put a headphone jack in the hole and gave it a good old shove (pretty hard) and sure enough, the sound icon started working again. All good, thanks very much

Collapse -
Macbook(Intel) OS X 10.5.8 sound stopped working
by Qsisto / April 9, 2010 11:43 PM PDT
In reply to: Macbook loss of sound

Macbook(Intel) OS X 10.5.8 sound stopped working, sound options lists only Built-in Output and under the settings portion for them it states that the selected device has no output controls. Tne volume bar is full but there is a circle with a line slashed through it. No red light in the headphone socket. I bot used headphones and updated before sound stopped working. Headphones still functional and I get startup chime.

I read through many similar threads and tried re-booting, command+control+P+R and updating. I tried plucking in and wiggling the headphone cord, it did not work (be carefull not to overdo this). Did this numerous times until I got the red light in the headphone socket(sound still not working). Tried then pressing the metal bars on the insides on both sides of the socket. The other one turned the red light of but no sound and light came back. Then pressed firmly both down until light did not return anymore and restarted computer. Sounds working perfectly now, there was obviously a glitch in the headphone socket that prevented the functioning of the output device.

Collapse -
Macbook(Intel) OS X 10.5.8 sound stopped working
by thomasvanschaik_dotmac / April 10, 2010 12:32 AM PDT

The same problem occurred on my MacBook(intel) and OS 10.6.3. I tried the manipulations as described and found that this a mechanical problem.
If you look inside the earphone connection hole you see in the front two copper-coloured connections you can push a little to the left and right. These are not the ones you want.
If you look deeper you see in the centre rear a point and to the right a similar pushable connection as in the front. This is the one you need. Push this one back and you're in business.
It worked like a charm.

Collapse -
Macbook(Intel) OS X 10.5.8 sound stopped working
by joshmonty996 / May 31, 2010 10:43 AM PDT

i can vouch for this, have spent hours trying everything from a software point of view i can think of, never occured to me to check in the headphone port to solve the internal speaker not working! many thanks

Collapse -
re
by lazybird3 / June 10, 2010 4:08 PM PDT

the red light is the optical output of that port

Collapse -
briliant !
by boofcontrol / January 4, 2011 11:12 PM PST

this advice worked perfect !!! did exactly what you wrote ,and the red light disapear , and the sound came back to the speakres of the leptop !
many thanx !

Collapse -
work
by jamess11 / March 9, 2011 6:18 AM PST

hello

same problem as above in mac book pro tried it a few times, then used headphones jack inserted with only downward pressure. Fix it Happy thanks

Collapse -
Sound problems with Snow Leopard
by kaarebrauti / July 29, 2011 8:31 AM PDT
In reply to: work

I upgraded to 10.6.8 the other day and all sound disappeared. System preferences had been changed from headphone/speakers to Sound tap recorder as default. Changed it back and I can enjoy Bob Marley again.

Collapse -
Heeeeeeellllppppppppppp!!!
by ejcortespr / November 11, 2011 9:08 PM PST

I did the safety pin method and managed to turn off the red optical light but my volume still appears with the prohibit sign and no sound comes off my speakers. when i plug headphones neither i also lost my internal mic and line in!!! they both appear but do not pick up any sound. When i reboot i can hear the chime. i wiped the disk re installed leopard and the issue persist.. as a dj and producer this has rendered mi macbook uselesss for my purposes. Can someone give me a hint on what is happening!!! I guess its a hardware thing.. but what exactly...

Collapse -
Instead of hijacking an old thread
by Jimmy Greystone / November 11, 2011 10:12 PM PST

Instead of hijacking an old thread, you should create a new one in the future.

Anyway, considering you've gone and tampered with the unit you've just voided even the OOW coverage on the unit, so your only hope here is to reset the SMC. If that doesn't fix it, you probably shorted something out when you were digging around in there with some metal object. It's NEVER a good idea to stick something electrically conductive into a port where there's live current. Even if it's not enough to hurt you, it's probably enough to damage the electronics.

For anyone else who may be reading this. If you find yourself in this situation, there are two solutions which will not void any warranty coverage you have. The first is resetting the SMC. The second, is repeatedly plugging in and unplugging a set of headphones into the headphone jack. Sometimes that will fix whatever the issue is. If both of those fail to work, then the only real solution is a MLB replacement. Which is probably 50% cheaper if you don't go digging around in there with a metal object as our friend above did. In fact, if you call Apple, there's at least a small chance they'll issue a CS Code, which is a one time exception to the warranty coverage, that will cover the MLB replacement. You go digging around in there with a metal object though, and there's no way they'll even consider covering it. That's considered accidental damage, and they won't have anything to do with it.

Collapse -
No sound (startup chime works) but nothing else
by MacbookFail / January 18, 2012 6:21 AM PST

Long story short, I had switched out a hard drive on an older computer with the same system after a nice big computer fail and when I started up the "new" computer, there was no audio. The start up chime is still playing but my computer does not pick up input and output audio components.

Collapse -
you seem to have missed out the Sound Preference panel
by mrmacfixit Forum moderator / January 18, 2012 7:47 AM PST

Should be the first place to go

Collapse -
Macbook Sound Fail
by MacbookFail / January 19, 2012 6:41 AM PST

No input or output devices detected

Collapse -
Is there any sound when you
by mrmacfixit Forum moderator / January 19, 2012 6:59 AM PST
In reply to: Macbook Sound Fail

boot from the OS X installation disc?
<span>
<div>P
</div>

Collapse -
try this
by wizardmike / August 14, 2012 2:18 PM PDT
Collapse -
Response to MrMacFixIT
by MacbookFail / January 19, 2012 10:47 AM PST

Yes there was a chime.

Collapse -
OK, and is
by mrmacfixit Forum moderator / January 19, 2012 11:34 PM PST
In reply to: Response to MrMacFixIT

there any sound once booted from the disc?

Volume up/down keys, do they beep?

P

Collapse -
No/Yes
by MacbookFail / January 20, 2012 11:26 AM PST
In reply to: OK, and is

no

Collapse -
No sound
by mrmacfixit Forum moderator / January 20, 2012 11:02 PM PST
In reply to: No/Yes

Any chance you could put the original drive back in that machine?

Collapse -
?-
by MacbookFail / January 20, 2012 11:09 PM PST
In reply to: No sound

There is no other way to get the sound back besides that?

Collapse -
I offer suggestions,
by mrmacfixit Forum moderator / January 21, 2012 9:02 AM PST
In reply to: ?-

it is up to you whether you accept them or not.

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech for the holiday

Find recipes for July 4 with these foodie apps

The Fourth of July means fireworks, fun and food. If you're planning on a barbecue this weekend, we've got the apps to help you find holiday-inspired recipes.