Windows 7 forum

General discussion

Lotus Smart suite on Windows 7

by olton1893 / November 22, 2010 4:10 AM PST

I have some old files in Lotus Smarte suite that I need to open on a new computer in Windows 7. I have the original Lotus CD but it won't open with windows 7

Post a reply
Discussion is locked
You are posting a reply to: Lotus Smart suite on Windows 7
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Lotus Smart suite on Windows 7
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Just a thought.
by R. Proffitt Forum moderator / November 22, 2010 6:51 AM PST
Collapse -
Loading Old Versions Of Smartsuite To New Computers
by bluegrassguitar / January 22, 2011 11:39 PM PST

You might have figured it out by now, but you can install old versions of Smartsuite on your new computer. To do it, insert the CD (it will try to load but cannot), leave it in the tray, go to the start menu, locate the setup application file on the Lotus CD and click on it. You will probably get a message about compatability issues but click on "continue." All files will be loaded to your hard drive (C) inside a folder called "Lotus." Open that folder, then locate the folder for the application you want. Open that folder, locate the application file you want (the one with the icon that identifies it as an application file.) Right click on that line and drag it to your taskbar at the bottom of your screen. For some reason, the application (123, Wordpro, etc.) either won't open or won't work if you just copy it to your desktop. To open the application once you've pinned it to the taskbar, just click on it. I'm running Lotus Smartsuite Millennium v.9.6 this way and it works just fine! I've also copied my old Lotus files to my new computer and they open and run just as they did on the old one.

Collapse -
thank you for your tip.
by Vera1000 / March 2, 2011 6:02 AM PST

Thank you very much for your tip. it was extremely valuable for me. I had already made several attempts to install the Lotus suite millennium in my notebook that uses the windows 7. all my databases are on approach. I could not replace it, because it is very practical and intelligent. my knowledge about computers is empirical, dictated by the most pressing needs. your tip made a big difference to my life.

Collapse -
Damn Genius
by Caerlicyn / April 22, 2011 8:25 PM PDT

Well done bluegrass guitar. It worked perfectly, and I now have access to all my old files. I am pretty cute with Windows 7 and Smartsuite, but failed to work this one out after many frustrating hours. Well satisfied.

Collapse -
Loading old SmartSuite onto Windows 7
by Old_UK_Blue / January 7, 2013 11:43 PM PST

Thanks bluegrass guitar. Your tip worked fine for WordPro but not 1-2-3. I get an error message saying that the files I am trying to access (i.e. the ones I created on my SmartSuite 97 on my XP machine) cannot be accessed as they were created with a newer version of 1-2-3!!! But it's the same SmartSuite 97 on both machines!! Any idea what may be causing this???

Collapse -
One of those rare 64 bit OS anomilies?
by R. Proffitt Forum moderator / January 7, 2013 11:52 PM PST

Try it under a 32 bit OS (7 has that too.) Or look around the compatibility tab for XP.
Bob

Collapse -
wow that's good news, thanks for the info bluegrassguitar
by JMM65 / January 18, 2013 7:40 AM PST

wow, that is great news. I will resurrect my old copy of Smartsuite and begin to use my files again.

Collapse -
Lotus 123 on Windows 7
by Louassier / March 13, 2013 12:44 AM PDT
Happy Did as you suggested and Lotus now installed and working! Many thanks for your help.
Collapse -
Window 8 too !
by AllenD9 / January 20, 2014 11:33 AM PST

I was able to install Lotus SmartSuite Millenium products (123 and WordPro) to a Dell laptop running Windows 8.
I had to drag to *.exe files to the desktop as a shortcut (and rename them) to have a way to open the programs.

Collapse -
loading Lotus
by alinasophia / August 15, 2014 2:23 AM PDT

Thank you so much! It worked beautifully. So glad I don't have to redo my tax program on windows. Have always worked with Lotus.

Collapse -
unable to install Smartsuite 9.8 to my windows 7, Ultimate
by jkensmith / April 21, 2015 7:58 AM PDT

I left the DVD in the D: tray. it did not open. I rt clicked on start. selected Windows Explorer. I see the icon beside the name of the file, But, I have not been able to view any of the files. So, I can't get to the setup file you mention in your post.

Thanks,
J Ken Smith

Collapse -
(NT) start a new thread
by James Denison / April 21, 2015 4:45 PM PDT
Collapse -
Lotus Smart Suite for Windows 7
by lebsackr / April 22, 2011 11:31 PM PDT

I have Lotus 123 installed on Windows 7 and it works just fine. I did not install anything other then the spreadsheet since that is all that I needed.

Collapse -
Lotus Smart Suite for Windows 7 Basic
by GrahamAAB / June 8, 2011 9:18 PM PDT

I am trying to open open Lotus 123 release 4 files in Windows 7 Basic on my Macbook Pro (running Snow Leopard) using Parallels.
File error reads "Invalid Character in File Name" These files opened in Windows XP what do I need to do ?

Collapse -
FWIW...
by gordon451 / January 18, 2013 11:06 AM PST

I recently upgraded my box to a Core i5 and W7HPx64, and the Lotus SmartSuite 9.8 just slipped right in.

Of course, it's always a struggle to understand how the multi-user is done, but once I decoded the instructions it all worked -- except I managed to install it on E: rather than C: Confused

The only bit I haven't tested is Organiser, but ATM we don't need that one.

Gordon.

Collapse -
Approach Windows 7
by Ms445 / November 30, 2015 6:48 AM PST

I have been using Lotus Approach with no problems on my windows 7 laptop and all my dbf files were located in a specific location, but now when it is installed to a new computer running windows 7 by default it saves the dbf files in a different location inside a folder in C:\Users\NAME\AppData\Local\VirtualStore\Program Files. My database includes macros that search for these files in the original default locations I programmed in windows 98 so this does cause some problems. Anyone know a way to change the default save locations back to my originals??

Collapse -
Re: default location
by Kees_B Forum moderator / November 30, 2015 7:36 AM PST
In reply to: Approach Windows 7

I'm afraid few people here use Lotus Approach. So don't expect a quick answer.

On wikipedia I read: "In May 2013, IBM announced the withdrawal of SmartSuite. Marketing of the product ended in June 2013, followed by all support ceasing in September 2014. IBM has also announced that there will be no replacement for SmartSuite"
Isn't it a little bit risky to keep using an outdated product?

Anyway, I suppose it's a setting somewhere. Check the user manual or look around in the product. If you don't manage to change the default, you'll have to change your macro's to look in the new location. Shouldn't be too difficult if you programmed it yourself 15 years ago.

Kees

Collapse -
Move the files?
by Steve_SEPDX / December 9, 2015 12:07 AM PST
In reply to: Approach Windows 7

Can't you just move the dbf, dbt, adx, and APR files to the original location where Lotus Approach expects to find them, presumably at C:\lotus\work\approach\?

Collapse -
Get IBM Fix Packs for Lotus Approach (HIGHLY RECOMMENDED)
by Steve_SEPDX / December 9, 2015 12:01 AM PST

Personally, I'm happy to see Lotus Approach is not yet dead among PC users. I think it is still the best database of its kind. In fact, there is no other database of its kind.

But I stopped using it when I discovered that, in Windows 7, some functionality was lost -- like the fact that all the explanatory text was missing from popup windows (like notices of field input errors).

I had a very sophisticated custom database, with many forms, macros, repeating panels, and tables (including alias tables), and such windows and messages were of great importance.

And to my frustration, IBM was insisting that I pay several hundred dollars (if not a thousand or more) for the "IBM Passport Advantage" in order to get the final 6 Fix Packs for SmartSuite, most of which were for Approach -- AND upon reading what they fixed, I discovered that Approach was unreliable without the Fix Packs: that query returns could not be counted on to be accurate and complete, among other things. I found this outrageous, because I'd paid 2-3 times for upgrades over the years, and I just ended up with a program which wasn't providing the basic function it promised (though it typically appeared to provide this function).

BUT now, I'm using SmartSuite again, believe it or not -- Approach and more, because some good soul has posted the IBM fix packs (and the entire 9.8 SmartSuite CD contents) on archive.org. (I know, you probably thought I was going to say the IBM has made all the fixes available now that support and development is officially discontinued for Lotus SmartSuite. But no. IBM still keeps the fix packs behind a crazy-expensive paywall.

I am hoping, however, that IBM will allow archive.org, at least, to continue making this software available free of charge. To get the entire Lotus SmartSuite, and the final, final version (via the final cumulative Fix Pack), go to:
https archive.org / details / LotusSmartSuite99

Please note, that it is'nt apparent that the final fix pack (6.1) is included, unless you click the 'show all' link. At first glance, the page appears to be offering only the contents of the last Lotus SmartSuite retail disc release. But it includes that, and the final cumulative fix pack from IBM Happy

Visit the appropriate IBM page to learn about the user-reported bugs fixed by the fix pack(s). My experience tells me that the fixes include more than those bugs too, because my window text problem is fixed as well, and it’s not mentioned in the text document.

In any case, it’s a vital update for Lotus Approach, and includes some fixes for 123, and Word Pro too.

The greatest problem for users of SmartSuite today, I think, beyond document sharing limitations, is the lack of support for OpenType and Unicode.

But if those limitations don't pose problems for you, and you've installed IBM Lotus SmartSuite Fix Pack 6.1, then personally, I see no reason why people (esp sole proprietors, etc) ought not use Lotus Approach, and other Lotus SmartSuite programs. (And remember, Lotus Approach can serve as a front end to many, many different types of databases. Likewise, those database tables created with Approach could be accessed with many other front ends too, like MySQL. This is one of the things that make Lotus Approach so much more versatile (and in a way, safer) than MS Access.

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

CNET'S TOP TV PICKS

Big screens for the big game

Still looking for the best TV deals ahead of Sunday's game? Here are our top three big screen picks.