Networking & Wireless forum

General discussion

LINKSYSWRT54G receiving but no internet

by crazycanuck36 / September 4, 2007 9:22 AM PDT

Hi everyone. I just bought a Linksys WRT54G Wireless router. My WLAN is picking it up just fine but the internet isn't working. I plugged the router into my cable modem and the internet doesn't work. When I plug the ethernet from the cable modem directly into my computer it does work however. I have tried the power method of getting it to click in, plugging and unplugging etc. Anyone have any other ideas of how to get my modem to communicate with my router?

Post a reply
Discussion is locked
You are posting a reply to: LINKSYSWRT54G receiving but no internet
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: LINKSYSWRT54G receiving but no internet
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
by roshkovsky / September 4, 2007 11:25 AM PDT

Did you try resetting the router? Worth a try. There should be a reset button on the back of the router that you can push with a paper clip. Note that if you have enabled any security settings, they will be lost. I found out the hard way.

Collapse -
No Dice
by crazycanuck36 / September 4, 2007 12:02 PM PDT
In reply to: Reset

I tried that already. I tried resetting the cable modem and the router and it still isn't working. Any other suggestions?

Collapse -
Did you try
by PudgyOne / September 4, 2007 1:16 PM PDT

setup should be

wall > cable modem/router > Linksys router > wirel/wireless

First plug the Linksys router into your computer with an ethernet cable.

Reset the router in the back

insert the disk that came with it

type in the default gateway and log in.(If you do not know the default gateway, click on run, type ipconfig /all)

Set up the router

Update the firmware
broadcast SSID
use WPA Personal security.
use nothing else.

click on apply.

Unplug your computer and try to connect wireless. If you cannot connect, restart your computer and try. If you get the message that there is a problem, follow the instructions to fix the profile.

Any questions, please post back.


Collapse -
It's Working
by crazycanuck36 / September 6, 2007 2:21 AM PDT
In reply to: Did you try

Thanks Rick,
My housemates and I are VERY grateful that thanks to your suggestion it is now working fine.
4 Girls + 1 Boy + University Classes + 1 Ethernet Internet Connection = 1 Very Messy Situation.
You may have actually saved lives

Collapse -
lol, Glad you got it working
by PudgyOne / September 6, 2007 5:55 AM PDT
In reply to: It's Working

Sounds like a messy setup.


Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

CNET Holiday Gift Guide

Looking for great gifts under $100?

Trendy tech gifts don't require a hefty price tag. Choose from these CNET-recommended useful and high-quality gadgets.