iPhones, iPods, & iPads

General discussion

LDAP account has stopped working in IOS7

by CWuser / September 25, 2013 10:56 AM PDT

I noticed that LDAP account which worked in IOS6 has stopped working in IOS7. Has anyone else noticed this?

It keeps throwing up the following error for user name/password entry i.e.

Unable to verify account information

I rechecked on IOS6 and same user settings work.

Can someone please help me with this issue?

Thank you

Post a reply
Discussion is locked
You are posting a reply to: LDAP account has stopped working in IOS7
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: LDAP account has stopped working in IOS7
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Huh ??
by birdmantd Forum moderator / September 25, 2013 11:54 AM PDT

.....what the heck is an LDAP account ???

Collapse -
LDAP account in IOS
by CWuser / September 25, 2013 12:10 PM PDT
In reply to: Huh ??

Hi,

This can be added under mail, contacts, calendar. You need to click on Add account and select other.

You can see Add LDAP account option over there. This helps organisations to access contact names/email ids from their active directory LDAP servers.

By configuring to access LDAP entries this way, you needn't have details of business/office contacts permanently saved in your phone.

This is really very useful.

Collapse -
When this happens.
by R. Proffitt Forum moderator / September 25, 2013 12:23 PM PDT

I'm on the phone with Apple. Be aware they do put you through the wringer but AFAIK, it's working in ios 7.

Collapse -
not for me :(
by CWuser / September 25, 2013 2:07 PM PDT
In reply to: When this happens.

No, I tried all permutations and combinations for our domain name/server/ip etc etc. It is just not taking it. I do have another iphone which is still on IOS6 and when i configured the same settings there, it is working fine.

Collapse -
And...
by R. Proffitt Forum moderator / September 25, 2013 3:20 PM PDT
In reply to: not for me :(

I've lost count of issues with odd names or passwords or versions of the server. Sorry that I can't look at this directly but if there's anyone that knows, they are at Apple.
Bob

Collapse -
Reset all device settings. Power off. Reboot.
by Pepe7 / September 26, 2013 6:20 AM PDT
In reply to: not for me :(

Then enter things from scratch. That's standard protocol if something stops working after an iOS update. Backup your data first, of course.

If it still doesn't work, consult with your IT folks @ work, then wait for the iOS7 patch in a few weeks if they don't have a near term fix for you.

FWIW, LDAP still works on my wife's iPhone 5. Just updated to iOS7 last night, in fact.

Collapse -
LDAP has stopped working in iOS 7
by lordgrymlock / September 28, 2013 6:29 AM PDT

We are experiencing the exact same issue. The other thing I noticed is that in the logs for the LDAP server the following error shows up every time we attempt to verify....

slapd[4274]: SASL [conn=18598518] Failure: no secret in database

Did Apple change the client to require SASL?

Collapse -
(NT) Nice find.
by R. Proffitt Forum moderator / September 28, 2013 6:50 AM PDT
Collapse -
Apple support response
by CWuser / September 29, 2013 4:03 PM PDT

Hi,

It looks like they have changed something. I managed to speak to Mac Support. They escalated my request to senior tech level but still this is not resolved. They did not ask me to do anything with the device except for one request. They wanted me to pay for the support even though my device was still under 90days warranty!!

I refused to do so and they told me to wait to hear from them and I am still waiting....

Collapse -
RE:
by lordgrymlock / September 30, 2013 3:41 AM PDT
In reply to: Apple support response

At least they acknowledged there is an issue...

Collapse -
me too
by Steve_Park / October 21, 2013 1:51 AM PDT

We have also same issue.

I reported it Apple Korea first and they consumed about 3 weeks.
And then they said "We cannot support it. Please require to Apple Headquarter".
As you can see, they have also no idea.

Anybody can help us?

Collapse -
Ldap problem on IOS
by jfegea / October 23, 2013 4:13 AM PDT
In reply to: me too

Same problem in new version IOS 7.0.3 Happy

Collapse -
LDAP search solution
by CWuser / November 7, 2013 7:00 AM PST
In reply to: Ldap problem on IOS

Hi All,



I have managed to make LDAP search work by doing the following, only for intranet use. I still can't make it work over the internet. I am still working on it now.

Server : name of your ldap server (only the name or ip address, ldap. or domain name should NOT be specified)

User name : uid=user name, ou=container, dc=domain name,dc=com (continue if you have .au or other extensions)

Password:user password
When you click on save, click on ok for non SSL and continue with save settings.

You should be able to see under the search settings your domain name appearing automatically.

Give a restart to your device and check LDAP search in contacts, email. It should work.

Please let me know if you get through with LDAP search this way.

Only thing i have changed here from earlier settings is the username format. I used to key in user name as domainname\user name earlier.


Apple has still not got back with a solution.


Cheers

Collapse -
more info
by CWuser / November 7, 2013 7:06 AM PST
In reply to: LDAP search solution

Hi,

I forgot to mention this. Please delete the existing entry and add a fresh one.

Cheers

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech Tip

Tired of your tricky Wi-Fi password?

Stop trying to memorize a complicated sequence of numbers and letters. Learn how to change the default password.