Headphones & Mp3 Players forum

General discussion

Is there a stupdaterapp.exe available for the Matsui 4G MP3?

by crossfell / October 6, 2007 12:07 AM PDT

Hi,

I've got a Matsui 4G MP3 (MAT140MR) which has become corrupted. It needs a firmware reload.

Does anyone have a copy of or knows where to find the stupdaterapp.exe application that works for this player?

I've looked on the disc that came with the 4G MP3 but there's no copy on there.

I've tried the application that came with the Matsui 2G MP3 but this refuses to recognise the player, so I assume there must be a separate version available for the 4G product.

You help would be appreciated.

Thanks,

Discussion is locked
You are posting a reply to: Is there a stupdaterapp.exe available for the Matsui 4G MP3?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Is there a stupdaterapp.exe available for the Matsui 4G MP3?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Recovery software needed for Matsui 140mr 4GB mp3 player
by mr fixy / October 7, 2007 9:56 AM PDT

Hi crossfell, I dont think the program is the issue. Ive tried lot of different flash tools and none seem to recognise the player. The problem is based around the chip, all of the other Matsui players that ive seen use the Sigmatel stmp3500 chip but the 140mr uses the stmp3600. The software disc I received with my player wont even install on my computer, it goes through the installation process and then after clicking finish theres nothing, no programs or drivers installed anywhere. Others have also experienced this problem from what I have read on the internet.

Ive scoured the net looking for drivers for the 3600 chip in the Matsui but there isnt any available and the manufacturer doesnt seem to offer any support but continue to sell the product. This is where the whole problem sits in my opinion - without the drivers for the chip installed in your pc the flash tool cannot correctly communicate with the player, regardless of whatever program it is.

Hopefully someone on this forum can shed some light on the problem and if I manage to figure it out I will let you know.

Best Wishes
Mr Fixy

Collapse -
Recovery software needed for Matsui 140mr 4GB mp3 player
by crossfell / October 11, 2007 4:12 AM PDT

Thanks Mr Fixy,

I share your frustration. I've done the same and your summary fits with my experience.

I agree it's unlikely to be the app itself but more a question of finding the right driver (or perhaps an appropriate .dll associated with the updater?).

One hope is that Matsui issue a later version of the software disc that then includes the updater itself (although this is pure wishful thinking! considering that Matsui is not an actual MP3 manufacturer but simply an 'own brand' name for PC World/Currys products). Anyone out there got such a disc?

On the issue of software installation from the current disc, mine does exactly the same as you describe however my assumption is that the disc only contains Win98 device drivers so when the install software detects a different Windows OS (XP, 2000 etc.) it correctly decides not to install these on your system.

Cheers,
crossfell

Collapse -
Player can get recognized but won't complete
by htelephone / October 29, 2007 12:41 AM PDT

I have managed to get the computer to recognize the player and begin to load some firmware. However, when it gets to the erase disc it crashes. The problem is that the firmware files from firmwareextract are not complete. The program only extracts 4 files from the mp3 when it needs 5. I fixed the files (filefixer.exe www.htelephones.co.uk) and renamed a few to match the hostlink.sb bootmanager.sb etc but am one file short.

You hold the M and wait a good three minutes for it to lock the drives, then another 4 minutes before it starts. It puts the resource and verifies and nearly completes. The problem is compounded by the lack of other files for other mp3 on the net.

I have tried to decomplie the firmwareextract program to see if it could be changed but it is written in some oddball language. Shame there is no source code for it.

Collapse -
Player can get recognized but won't complete
by crossfell / October 29, 2007 5:54 AM PDT

Yes I've found that too. The firmware extract application only extracts 4 files.

The remapping I did was as follows:

bootmanager.sb -> bootmanager.sb
resource.bin -> player.rsc
stmpsys.sb -> player.sb
usbmsc.sb -> usbmsc.sb

I've been scouring the web for anything remotely like the Matsui 140 but with no success. By opening the MP3 I know that it's powered by a Sigmatel STMP 3630 device. With this in mind I looked for any other players with the same or similar device and found the following posting:

http://forum.mp3store.pl/index.php?showtopic=14695, with these listed as being based on the Sigmatel 36xx:

Samsung YP-Z5 >> STMP 3650
Creative Zen V /Zen V plus >> STMP 36xx
Trekstor Vibez >> STMP 3650
IXINg (Technonia) TM-S4 + IXINg Duo >> STMP 3650
Siren IV Edge>> STMP 3600
RAmos RM-650 >> STMP 3650
Sandisk Sansa Express >> STMP 3630

Clearly the most promising is the Sansa Express but unfortunately the firmware updater appears to be incompatible with the Matsui. Of the others that I could track down, none were appropriate for the Matsui.

I note that you believe it requires 5 files in total but I have seen another post suggest 6 (which seems to be backed up by the readme file that came with the player). What do you think?

Coming back to potential firmware, the closest player firmware I've found is from the Maxfield MP3 family.

http://www.maxfield.de/index.php?id=1&L=1

If you haven't been there before, go to Support and choose either:

-> G-FLASH NG 2G (has three different firmwares available) or,
-> MAX-IVY 4G (two different firmware versions)

With a bit of luck (combined with the partial success you've had) you may find the additional file you're looking for.


My current situation (and has been for little while) using Win XP is:
- mp3 is recognised everytime I plug in
- MP3 screen lights up blue and the graphics show PC and Disk logos with the message 'Ready'
- however it is never recognised by any stupdaterapp I try to use
- shows up in Computer Management -> Device Manager -> Storage Volumes as a Generic Volume and under Universal Serial Bus controllers as USB Mass Storage Device
- but shows up under Computer Management -> Removable Storage -> Disk Management as: (in my case) Disk 2, Removable (G:), Unreadable

That very last part is the killer. If it had shown up as anything other than 'Unreadable' I believe I would have been able to reformat it using Win XP. I assume that the firmware has become corrupted sufficiently for it not to allow a PC operating system to interrogate it. That's why I'm banking on an updater app to remedy this for me.

As a matter of interest which stupdaterapp have you had partial success with? I tried your suggested method and still couldn't get a response. I've been using the Max-Ivy updater found inside the firmware zip file mentioned above.

Collapse -
Possible Fix
by latedeceiver / October 30, 2007 7:53 PM PDT

Hi,

I'd like to share my experiences with the Matsui 140 (a real pain as I'm sure you've already found), and hopefully it will be of some use.

I had similar problems to the above posters, my XP recognised the Matsui as a generic device and I was able to transfer songs directly to the Mp3 but when I came to turn it on I was left with a 'boot error' message.

After following a lot of advice I found around the Internet, such as 'chkdsk (drive letter): /f' in command prompt and no success, I tried crossfells suggestion of downloading the MAX-IVY 4G firmware zip from the maxfield website.

Again no success with the firmware program itself but I decided to try and simply copy the files in the 'Binary' folder directly to the Mp3 and this has apparently fixed it.

The zip filename I used is MAX-IVY_V4.301.025 and the files I copied from the 'Binary' folder to the Mp3 were:

- bootmanager.sb
- hostlink.rsc
- hostlink.sb
- player.rsc
- player.sb
- stmfgmsc.sb
- updater.sb

I also have the following folders, which may or maynot play a role in the solution but I think it wouldn't hurt to have them anyway:

- Music
- Player
- Playback
- Playlists
- Record

On the first boot it got past the 'boot error' to show the menu screen but then it crashed and turned off. Filled with dubious hope, I tried a couple more attempts at booting up and finally it 'stabilised'. It has worked fine up until now without any apparent bugs, with a good 10 hours of solid use whilst I was at work.

I've since found 4 new .DAT files on the Matsui named:

- RAMLIST
- STDBDATA
- STDBSTR
- SETTINGS

As well as the files:

- STDBDATA.IDX
- STDBSTR.IDX

And I am guessing these were created after I had copied the file and tried to reboot the Matsui.

This may all be a case of very good luck but nonetheless I wish you the same

Collapse -
Unfortunately not for me.
by crossfell / November 4, 2007 1:42 AM PDT
In reply to: Possible Fix

Hi latedeceiver,

Thanks for sharing your experience. These little swines seem to have a mind of their own with a variety of failure modes. It's interesting to note that yours could not be recognised by any firmware updater application (like mine) but could be by the PC to such an extent that you could transfer files to it (mine can't, even though it's installed as a 'USB Mass Storage Device').

So that means I cannot actually transfer files to it to complete the last part of your suggestion. However I can't help thinking that it was a happy coincidence that your routine worked. I didn't think you could update these players in this way. I'd be interested to know if the files in question remained on the player once you'd rebooted the Matsui or if they were deleted by the update process.

Nevertheless, well done!

Collapse -
140mr
by htelephone / November 21, 2007 8:01 AM PST

You can use the one from maxfield. (stupdater) or a generic one

I have renamed files in a similar fashion to you and have had some 'success' sort of. I managed to at least kill a few players then bring back the matsui logo.

It is the fifth or sixth missing file which is the key. All told a lot of effort for little gain. Altough I have about 80 of these the value is dropping fast - now only

Collapse -
some progress
by htelephone / November 21, 2007 8:46 AM PST
In reply to: 140mr

Ps. use the maxfield stupdater (hold M) it will do the following:
>Searching
>Initializing "This device can perform faster message"
>Then ready.
I tried with and without format and most times it will complete the whole process. I have an issue with the hostlink/usbmsc as when you plug in without holding the M after it starts, "matsui", "Checking disc", "buildingDatabase" - akin to what it would do if you put a battery in. The USB part fails to connect it to a computer. I tried different bootmanager.sb files but am sure I have the right one. With Resouce.bin renamed to player.rsc. player.sb is the possible problem as we have nothing to substitute for it.

If you want my files to have a play with let me know

Collapse -
So near, yet so far
by crossfell / November 24, 2007 11:25 PM PST
In reply to: some progress

Thanks htelephone for your update, it's much appreciated. I recognise that it's starting to follow the laws of diminishing returns but I don't want this to defeat me, not least because I want my player back.....

I intended to post earlier with my progress but delayed in the hope that I could report a success but unfortunately I still can't.

I finally managed to get a stupdaterapp to recognise my player. What I didn't realise (and discovered through pure chance) was that you ALWAYS have to put the player in recovery mode (by keeping M pressed before and after plugging it into the PC) before it can be recognised. This is not the case with the other Matsui USB stick style MP3s because they are recognised by an updater as soon as you plug it into the PC - so it's this bit that threw me. By the way, for anyone else interested, the extra hurdle to overcome is that the disc that comes with the player does not supply a recovery driver (I had to get it from somewhere else).

But not only this, I also found that to correctly 'initialise' the player you needed a very specific updater.sb file. By working through several updater applications I found the Maxfield G-Flash family of stupdaterapps to be the most suitable, and more specifically GFLASHNG025. For those that need to get the updater (like Mr Fixy earlier in this post), use this link http://www.maxfield.de/index.php?id=19&L=1, choose G-FLASH NG 2GB, click on the Downloads tab and select "G-FLASH NG Firmware 4.301.025 / Software".

This updater has worked every single time for me, it always completes it routine. And as expected the application has been able to re-format my player so I've finally regained a readable (~4GB) file system on it. I've also found that updaters that only need 4 firmware files initiate the player OK (as long as you re-label the useful updater.sb to usbmsc.sb) but they never get to the stage where you see a summary of the firmware loaded on the player.

- - - - - -
In response to htelephone's observations, these are my thoughts about the firmware files:

I believe we're looking for five firmware files, these being:

bootmanager.sb
hostlink.sb
player.sb
player.rsc
hostlink.rsc

This is supported by the following observations (all of which might be flawed assumptions!)

1) The 140MR readme file on the software disc lists all 5 files, plus updater.sb [which I've discounted because I believe this is only used to 'initialise' the player with the updater application]. Intriguingly, as mentioned by htelephone, the updater.sb results in a "This device can perform faster" message during initialisation but fortunately this doesn't matter once the full set of firmware is flashed.

2) When you run the FirmwareExtract tool, you get the following result:

1. partition(0)\ ........data...............(data)........................3923968KB
2. partition(1)\.........unknown......(null).................................2048KB
3. partition(2)\.........system.........bootmanager.sb..............256KB
4. partition(3)\.........system.........usbmsc.sb........................512KB
5. partition(4)\.........system.........stmpsys.sb.....................1024KB
6. partition(5)\.........system.........resource.bin...................1536KB
7. partition(6)\.........system.........(null)...................................256KB

My assumption is that the extractor application is written in such a way that it always identifies valid firmware files as 'system' files. So to my mind partition(1) is not a firmware file while partition(6) is. Of course the problem is that the application only extracts four files (partitions 2-5) with the sixth partition not extracted.

3) I've tried a stack of stupdaterapp.exe programs. Some never recognise the player and those that require six files usually end up with the requirement for multiple resource.bins. Also when you request an updater application to "Show [Firmware] Details", all the "Current Version" fields become fully populated ONLY when the updater firmware files match the five files listed in 1) above.

As I said, these may all be flawed assumptions but I believe the order in which the files are extracted match the order of the updater application, therefore the re-mapping we need to settle on is:

bootmanager.sb -> bootmanager.sb
resource.bin -> player.rsc
stmpsys.sb -> player.sb
usbmsc.sb -> hostlink.sb

this leaves us looking for a valid hostlink.rsc for the Matsui (ver: 001.003.018).

I believe it's this firmware file that presents the "PC icon and Ready" graphics on the MP3 when connected to the PC. I learnt this the hard way because I went ahead and updated the firmware using my extracted files plus GFLASHNG025's hostlink.rsc file. This screwed up my "connected to PC" graphics. Suffice to say I've tried plenty of hostlink.rsc files but I haven't found one on the net that gets me back to where I was.

A question for htelephone:

with all the experimentation you've done does your player still switch on in battery mode (even though it may not fully start)? and do you still have the expected graphics when connecting to a PC? Do these graphics sometimes corrupt when trialling other firmware combinations but you're able to get the original one back if you use a specific combination of firmware? If you can, then clearly I'm wrong about the re-mapping combination.

The ironic situation I've found myself in is aside from the corrupted graphics described above is that in my early days of experimentation (before I found the GFlash updater) I seemed to have flashed a file on the MP3 that now refuses to allow the MP3 to recognise the Start button (i.e. I can't switch it on in battery mode). But what does work (and you might like to try this yourself) is that if you offer the MP3 to the USB port just enough to engage the power pins but not the data pins, the player will go through the whole of its start-up routine and actually get as far as the menu screen so that you can play music and do all the things you can in battery mode. For this reason I feel I'm very close to solving it, but it's that elusive fifth file.

So to summarise my situation:

o I have a pefectly fine 4G memory stick because I can read/write files to the player without any problems
o The player functions perfectly if I use the power source of the PC (but not the battery)
o The graphics on the player, when connected to the PC, are very basic with a single dot traversing across the screen to indicate data
activity

By the way, of the many MR140s that you have I guess plenty say BootError on start up. Of these did you try to reformat any of them using "Disk Management", under XP Computer Management? I know someone who did this and recovered his player, thus saving themselves the task of re-flashing.

Collapse -
Whoa, Hold the Front Page!
by crossfell / November 25, 2007 12:05 AM PST
In reply to: So near, yet so far

As soon as I finished and released my last post it kept bugging me why the player should switch on using power from the PC and not the battery. And guess what? when I looked into the battery compartment I couldn't see the positive terminal. I'd obviously trapped it behind the plastic casing when I last opened the player. Duh!!

And guess what.......

Now that I've brought it back within the battery compartment it can switch on. Hurrah!

And better still the whole player works just fine, apart from the loss of graphics (that I described in my last post) when I connect it to the PC.

htelephone, could you please confirm that you get the same results using my suggested combination of firmware bearing in mind that you'll be sacrificing one of your players with inferior 'USB connection' graphics.

Collapse -
Wow
by htelephone / November 25, 2007 3:26 AM PST

Hi Crossfell, seems that you may have solved it. I will repeat what you have done tomorrow and report back. Mine power up when you plug into the computer and go nearly to full start up. They no longer register on the computer at all - unless by holding the M prior.

I have tried all kinds of format windows style on XP and Vista + the internal one but they never work fully. Sometimes you get it to fire up ok then c*ck back up next time you test them. From experience and without being boastful we have done several thousand mp3s over the years and reflashing is the only true reliable cure.

I find that progress is made when others are trying too, much harder on your own, so your feedback and notes above are appreciated greatly. I recall spending days on the MPMAN fol7 and then throwing in the towel at 3 in the morning, to then have one last go with the laptop and solving it instantly.

Collapse -
Matsui mr140
by newlookat / November 27, 2007 4:23 AM PST

Hi,
I also tried it and was successful.
Small problem that I got: just few battery charging icons in different parts of display, but players work perfectly and I did it with 9 players.
Just want to say thanks crossfell for his hard job.

Collapse -
Indeed good job
by htelephone / December 4, 2007 11:38 PM PST
In reply to: Matsui mr140

My problem lay with Vista as after re-flashing no mp3 would recognize until a restart. So XP is the best platform for sure.

I have also noticed that if you pull the mp3 out without doing an eject disc it does a long disc check at start up. Sometimes taking 2 minutes to come on ready to play. Whereas if you eject it is says "MATSUI", then "Building Database" then on in only a few seconds.

Collapse -
Matsui
by Paulie Walnuts / December 10, 2007 8:46 PM PST
In reply to: Indeed good job

Hi,

I am unable to try any of the firmware solutions with my Matsui player, because my player will no longer turn on - whether through battery power or laptop power. It is totally dead, no matter how long I hold 'm' for recovery.

Anyone help?

Thanks

Adam

Collapse -
Matsui 140MR firmware files
by JustinKlim / July 5, 2008 7:01 AM PDT
In reply to: Matsui

Hi,

I realise this is an old topic and I'm a little late to the party and all but...

Does anyone have a copy of the Matsui 140MR firmware files? I have the ability to flash my device but I don't have the firmware files.

Thanks in advance.

Collapse -
help matsui 4gb player
by eagleypark / August 7, 2008 11:17 PM PDT
In reply to: Matsui

Dear Forum
I also have this model of mp3 player. My situation is that the player will not play music or load the matsui logo for that matter (in fact the blue light does light up but there is no logo or anything at all.

Whilst it will not work as an MP3 player it does in fact still function as a "flash drive" in that when one plugs it into the usb socket the blue light comes on and the drive is recognised in "my computer" In this regard I am able to copy files to and from the "removable drive" and also down load to the matsui.

I would like however (as with the other forum members on this thread) to be able to use it as a music player again.

In this regard I notice from this long thread much progress has been made in trying to solve the problem ie as to what files to download; (where to get them from) and , not least, how to install them.

I would be grateful if one of those involved would please be so kind as to make a list of the procedures to go through (from start to finish) in order to rescue the player; as I found it difficult to follow the thread .

If anyone can assist I would be most grateful please
Ian

Collapse -
Locked.
by R. Proffitt Forum moderator / August 7, 2008 11:19 PM PDT

This discussion is a bit stale. Make your own new posts now.

-> Just so you know, a few member's devices look dead. Since there are no parts that can be replaced, it's time to go shopping!

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Tech Tip

Stuck without Internet and want to watch movies?

CNET shows you how to download movies and TV shows onto your device using Amazon Prime so you'll always be entertained.