Windows 7 forum

General discussion

Internet Explorer Incredibly Slow

by Frankie787 / September 12, 2010 8:32 PM PDT

So I have Windows 7 on my laptop. I bought this laptop to replace the last one which died on me, and I switched from IE to Firefox because IE was so slow to open, there was a significant delay when I tried to input text. I thought perhaps this was due to some virus or something on my old computer.

However, IE is doing the exact same thing on this new computer. It's not a major problem, more that some links within documents that I click on open up by default in IE and it would be good if it ran at a normal pace.

Anyone know why it is so slow and if there's anything I can do about it? Or indeed how to make Firefox the default browser for all links clicked whether on the Internet or from say a .doc?

Post a reply
Discussion is locked
You are posting a reply to: Internet Explorer Incredibly Slow
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Internet Explorer Incredibly Slow
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
So.
by MarkFlax Forum moderator / September 12, 2010 8:44 PM PDT

Such IE problems can often be traced back to bad or infected add-ons.

In IE, goto Tools > Manage Add-ons, and review the ones you have. Testing is difficult as you may need to disable an add-on, test, then disable another and test again.

Mark

Collapse -
IE problems
by brett_windows_team / September 16, 2010 7:54 AM PDT
Collapse -
There is a setting
by peacox / September 19, 2010 3:35 PM PDT
In reply to: IE problems

in IE that has the potential to waste time during the application load process.
Go to Tools ->Internet options ->Browser History Settings.
Under "Check for newer versions of stored pages" make sure "Every time I start Internet Explorer" is not checked.
I always set it to "Every time I visit a web page" since if I'm going there anyway, I want the info I see to be up to date.
I don't know if this will make any difference, but it can't hurt, also I can't find an equivalent setting in Firefox which might explain why it loads faster.

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Big stars on small screens

Smosh tells CNET what it took to make it big online

Internet sensations Ian Hecox and Anthony Padilla discuss how YouTube has changed and why among all their goals, "real TV" isn't an ambition.