Mac Desktops forum

General discussion

Installing New Video card- wierd stuff

by fotogra / September 10, 2010 6:26 AM PDT

I installed the ATI Radeon x1900 card (512MB) in my 2006 Mac Pro. Can't change resolution- it's at 1200x800 on my 30 in cinema monitor and there is a warning that my video cable needs to be plugged in. There is no video cable, the card just plugs in.

Any ideas? I did zap the pram.


Post a reply
Discussion is locked
You are posting a reply to: Installing New Video card- wierd stuff
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Installing New Video card- wierd stuff
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Sorry- video card info
by fotogra / September 10, 2010 6:36 AM PDT

Ah, I called the company and they forgot to put the video cable with the card. there was no cable with the 256 card I replaced, so that's why I didn't know I should have received a cable.
I couldn't find a link to delete this posting.

Collapse -
(NT) let us know if it all works well when the cable arrives
by mrmacfixit Forum moderator / September 10, 2010 6:46 AM PDT
In reply to: Sorry- video card info
Collapse -
Works Fine
by fotogra / September 11, 2010 4:04 AM PDT

I received the cable from the company and installed it and it all works fine. I can set the rez and I also reset the Pram again.

I happen to live near San Jose and there a dedicated MacPro store there.
Thanks for your interested

Collapse -
Glad you got it fixed
by mrmacfixit Forum moderator / September 11, 2010 9:17 AM PDT
In reply to: Works Fine

thanks for following up


Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

CNET Holiday Gift Guide

Looking for great gifts under $100?

Trendy tech gifts don't require a hefty price tag. Choose from these CNET-recommended useful and high-quality gadgets.