TVs & Home Theaters forum

Question

I have an mkv file that by default the audio track is french

by jeff5hole / May 7, 2012 12:35 PM PDT

I have an mkv file that by default the audio track is french, in VLC on my computer I can change to english. However, I have a samsung Tv (LN40D630) and I am running AllShare on my computer & can't figure out how to change to the english AUDIO TRACK!!
If this is not possible on the tv, is there a way to change the default track of the file?

Thanks,
Jeff

Discussion is locked
You are posting a reply to: I have an mkv file that by default the audio track is french
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: I have an mkv file that by default the audio track is french
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
I'd look at MKV audio track "swappers."
by R. Proffitt Forum moderator / May 7, 2012 12:44 PM PDT

I might try such a search on google. And yes, TVs rarely can match wits with a PC and VLC Player.
Bob

Collapse -
Answer
Try MKVToolNix
by Pepe7 / May 7, 2012 1:13 PM PDT
Collapse -
MKVMerge & GUI
by jeff5hole / May 7, 2012 11:14 PM PDT
In reply to: Try MKVToolNix

This worked great by removing the french track.I tried changing the default track and forced flag, it worked on computer but not on the TV.
Jeff

Collapse -
Many discover
by R. Proffitt Forum moderator / May 8, 2012 12:58 AM PDT
In reply to: MKVMerge & GUI

That you have to put the track in an external file. Some don't want to do that but all I can offer is "go with what works." Samsung is rather mum on what works.
Bob

Collapse -
Answer
re:
by tyrexden / May 16, 2012 2:10 PM PDT

Download AVIDemux. Its a free program for Windows, Mac, or Linux.... Within that program, you can set the primary track to be the English one. (Its probably currently labelled track #1, and the French track is labelled track #0). After setting the primary track, just resave... It won't take too long... About 10 minutes for a feature length 1080p mkv. Its not actually rerendering. The video portion will be a direct stream copy, while the audio stream is just being swapped for the other...

Then, your set will play the mkv with the new primary track that you set.

Collapse -
AVI DEMUX WORKED FOR ME!
by hitecluddite / December 3, 2012 8:45 PM PST
In reply to: re:

Had to try a couple different configurations but thanks to my corei7 it was no big deal to proces it and test till I got it right. I swithced primary audio tracks on a movie so that it plays properly on my WDTV!

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

CNET Forums

Looking for tech help?

Whether you’re looking for dependable tech advice or offering helpful tricks, join the conversation in our forums.