Computer Help forum

General discussion

How to make a window open at maximum

by Claudia_T / January 22, 2006 10:30 PM PST

You know how when you first open a web page the window opens to a small window and then you have to click on the middle thing next to the X with the squares to maximize the window?

Well I do web design and so all day I am having to open and close windows and I wish so much it would just automatically open up with the full maximized window. I use Windows XP.

Can anybody help with this please?


Post a reply
Discussion is locked
You are posting a reply to: How to make a window open at maximum
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: How to make a window open at maximum
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: How to make a window open at maximum
by Tufenuf / January 22, 2006 11:23 PM PST

Claudia, Here's a solution which should work (compliments of Toni Hackler).
Follow the instructions below exactly and your problem should be solved.
Right click the shortcut icon for IE next to the Start button, choose Properties, change it from 'normal' to 'maximized'. Now open it.
Now right click any link on the page, choose Open In New Window....don't maximize it....instead, use the mouse to resize it to what you want it to be.
Now close the FIRST window you opened, and then close the new one you just resized.
Reopen IE from the shortcut icon again, and all windows from now on will be the size you chose and created.

Note: If you don't have an IE icon next to the Start button (Quick Launch area) use the shortcut in your Start/Programs/Internet Explorer and follow the instructions above.


Collapse -
Well, that only works. . .
by Coryphaeus / January 23, 2006 2:10 AM PST
Collapse -
Every shortcut to a program or file
by TONI H / January 23, 2006 5:10 AM PST

on your desktop, in the QuickLaunch area, Programs list, etc. can be right clicked, choose Properties, and change it from 'normal' to 'maximized'.

If the shortcuts you have are to files, such as text or document types, it works for those as well.


Collapse -
Just IE. . .
by Coryphaeus / January 23, 2006 10:18 AM PST

I tried your original instructions a long time ago. Setting the "Open Maximized" would only work (for me) if I used Quick Launch. It wouldn't work reliably with the standard desktop icon or the Office Toolbar (which I prefer).

I just like the little utility, it works every time.


Collapse -
IE icon
by TONI H / January 23, 2006 7:53 PM PST
In reply to: Just IE. . .

If you have the shortcut on QL, the large icon on the desktop defaults to that setting automatically as well.....if you have no shortcut for IE in QL, you can get the same results by changing the shortcut to IE icon in the Start/Programs menu instead and then the large desktop IE icon will default to that setting.

I'm not saying that using your program recommendation wouldn't do it for everybody as well...I'm just saying that since there are so many ways within windows to get the same results, why use a third party program if you don't need to?

My personal preferences have always been to install as little as possible for tweaking purposes since there are so many that, except for a setting or two, accomplish the same things and I've suspected for a long time that having more than one program installed results in those programs colliding with each other when those programs are similar to each other. It makes it easier to troubleshoot problems when you have less to look at when you can't pinpoint the problems down to one particular installation.


Collapse -
by Corca147 / August 14, 2010 5:32 PM PDT

Thank Tulenet, worked like a dream from any IE application shoutcut.

Great little find.

Collapse -
java script
by dell1225 / January 24, 2006 2:41 PM PST

Hello there,

If you do not mind putting a temp piece of code to your page, just put the javascript that resizes web page to max size to the page you are working on. Remove it when you are done.

Good luck,

Collapse -
There is another way...
by skycatcher / January 26, 2006 8:00 PM PST

I too use and it 'usually' works. I find that setting the QuickLaunch icon properties to maximized only works for the first screen - right-click on a shortcut and 'Open in New Window' goes back to a smaller box if you are not running iemaximizer so.....

Firstly, close everything except one small IE screen. Put your mouse pointer on to the blue bar at the top of the box (or whatever colour you have), left-click and hold as you mover the box neatly into the top-left corner of the screen, so you can only just see the edges. Now go to the bottom-right of the box, so you get the double-ended arrow, left-click and hold as you drag this corner to the bottom-right of the screen.

Now close the box and shut down your PC. Re-start and from then on you will have full screen display, although the middle icon of the three in the top-right of the window will still show a single box.

Give it a try it works and you don't have to load the iemaximizer.

Collapse -
Ok,for me
by colon1148 / January 26, 2006 10:35 PM PST

I tried what you proposed and it worked fine.I never had this problem before,it suddenly appeared.Thanks.

Collapse -
WIndow open at maximum
by i4usmart / January 27, 2006 10:40 PM PST

Hello, The same problem happen when you open a web page it open to a smalll window,the best thing which you can do with keyboard is just press "alt+space bar+X",when you press these three buttons atlogether ,window automatically open to a maximize.This is fast and you not need to click on the middle thing next to X every time when you open web page.

Collapse -
You can also
by TONI H / January 28, 2006 12:18 AM PST
In reply to: WIndow open at maximum

right click in the Back/Forward toolbar, choose Customize and add the FULL SCREEN option button to the toolbar. Then you can just click the Full Screen button to change the window to that setting. The problem with full screen though is that all of your toolbars are now located in one line across the top and you end up with chevrons ( >> ) next to each vertical spacer line. I detest Full Screen since I use three toolbars on a normal basis:

The File/Edit with the Back/Forward and Google toolbar all on one line, the Address toolbar on the second line as it goes completely across the screen, and then the LINKS toolbar as the third under the address toolbar. The LINKS toolbar is the only one with chevrons at the end as I have MANY shortcut links in it, even though they are all shortened to fit as many as possible across the screen (such as CH for Computer Help and 9X for the W95/98 forum)


Collapse -
IE windows at max
by rgpool / January 30, 2006 3:38 AM PST
In reply to: WIndow open at maximum

Open the page, maximize, hold down Control, and close IE. It opens maximized when you open IE next.

Collapse -
And one more way...
by Edward ODaniel / January 30, 2006 9:23 AM PST

1. Open a single Internet Explorer window to the smaller size as normal.

2. Drag the corners of the window until it completely fills the screen. Do not use the maximize button to enlarge the window.

3. Hold down the Ctrl key while using the mouse to click the File Menu and then Exit on the menu bar. Do not use the "X" in the upper right corner to close the window.

4. Internet Explorer should now open in a full window.
If it still opens to a smaller size repeat the above instructions, substituting the "Shift" key for the "Ctrl" key.

Collapse -
window 7 computer
by explanation / February 28, 2010 1:12 AM PST

I would like someone to tell me of how to "maximize the display on the
window 7 computer" because each time I open this window 7, the window
open in a mini format. And I would like it to open in a full screen.

Carlos J. Mulgrave

Thank you

Collapse -
(NT) I have the same problem, opening in max. Who can help??
by ohngren1 / April 11, 2012 1:33 AM PDT
Collapse -
Auto Sizer2.7
by mopscare42 / April 11, 2012 5:14 AM PDT
Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

Smart Home Help

Light bulbs you shouldn't buy

There are plenty of dimmable LED light bulbs, but make sure you don't buy the ones that flicker when you dial them down.