Networking & Wireless

Question

How to connect wireless canon printer to Belkin N150 router

by mdavis166 / November 26, 2012 9:45 AM PST

I can't seem to get my Canon MG5220 Wireless Printer to connect to my Belkin N150 wireless router. The printer sees the belkin wireless router network name but cannot connect to it( after entering the correct security key). It worked fine with a previous wireless router. My desktop PC is connected to the belkin router via direct ethernet, and I want to be able to access my wireless printer which is located in another room from my PC. I think I remember reading that the canon mg5220 may not support WPA2 security, but Its only a year old and would prefer not to regonfigure my router's security setting. Any ideas on how I can get this printer to connect to my router? Any other ways to access this printer from my PC which is connected to LAN via ethernet?
Thanks,
Matt

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: How to connect wireless canon printer to Belkin N150 router
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: How to connect wireless canon printer to Belkin N150 router
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
I went to Canon's site and looked at the manuals.
by R. Proffitt Forum moderator / November 27, 2012 12:41 AM PST

Your post is a good start but I can't tell if your router had the firewall turned on. WPA2 is supported, WPA2 Enterprise is not. It's rare to see the latter.

There are other reasons but as it stands the incomplete details mean I can't offer much other than the usual issue of the router firewall.
Bob

Collapse -
Reply
by mdavis166 / November 27, 2012 5:31 PM PST

I set the Firewall to disable through the Belkin Router setup in my browser. Doesn't work either way. Do you need any other information?
I am running windows XP 32bit. Thanks for any help!

Collapse -
Since the WiFi printer does not connect to the router.
by R. Proffitt Forum moderator / November 28, 2012 1:41 AM PST
In reply to: Reply

It appears the issue is not the PC.

Your post is still incomplete. No mention of security choice. We know this issue happens with Samsung a lot and you can read that post in this forum.

In short, router defaults, simple broadcasting SSID and get that working first. Move to WPA2 personal security and we're done.
Bob

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

CNET Magazine

The summer issue is here!

In the latest edition of our quarterly magazine, we look at how you can spend your summer getting fit and having fun. Pick up a copy on newsstands today or order it now.