Browsers, E-mail, & Web Apps forum

General discussion

How To change language in firefox

by rakshithraor / February 27, 2007 4:03 AM PST

i downloaded firefox but it is in a diff language.all d toolbars r in a diff language n cant figure out how 2 change it.plz help

Discussion is locked
You are posting a reply to: How To change language in firefox
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: How To change language in firefox
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Open Mozilla Firefox
by PudgyOne / February 27, 2007 5:15 AM PST

click on tools

click on options

click on advanced

click on general

click on languages

use the botton drop down menu to select your language.


Hope this helps.


Rick

Collapse -
cant
by rakshithraor / February 27, 2007 2:31 PM PST
In reply to: Open Mozilla Firefox

dude i dont no were is tools coz its in a different language.can u plz tell me wich were 2 click frm d left or sumthin like that

Collapse -
plz
by rakshithraor / February 27, 2007 4:36 PM PST
In reply to: cant

p[lz help me

Collapse -
Open Mozilla Firefox
by PudgyOne / February 27, 2007 5:54 PM PST
In reply to: cant

click on the 6th item across

click on the bottom one

click on the last one

click on the first tab

click on the button by itself

click on the arrow in the little window and choose the language you want to use.

click the first button on the bottom and close Mozilla Firefox. Wait 10 seconds and the open Mozilla Firefox and it should be ok.


***Please note, some languages are not in the same format as the English language. Some go from right to left instead of left to right. The placement of the words and buttons may be opposite from what is stated.


If this does NOT work then

go to control panel and remove Mozilla Firefox.

Right click on start

left click explore

click on the + sign in front of Program files

look for the Mozilla Firefox folder

right click on the folder and delete it.

Restart your computer.

Log in to an unrestricted account.

go to

http://www.mozilla.com/en-US/

Download and install Mozilla Firefox from the beginning. I hope you wanted the English version.

Everything should be where you can then understand it.


Rick

Collapse -
button
by hsharky2506 / March 6, 2009 6:20 PM PST
In reply to: Open Mozilla Firefox

u said click on the button itself? which button is, itself? c'mon i really need this info!

Collapse -
You are posting to a 2 year old thread.
by MarkFlax Forum moderator / March 6, 2009 8:37 PM PST
In reply to: button

I assume you noticed that with your, "come on!" comment.

Since then, Firefox has been updated a number of times. I am using version 3.0.7. Which version are you using?

In version 3.0.7 the language option has moved. With Firefox open, goto Tools > Options, and click the "Content" tab.

There you will find a section called Languages, and a button for "Choose". Click that.

In the new window, where it says, "Select a language to add...", click the down arrow. Scroll down to the language you want to add. Click Add.

Move the language you have just added to the top of the 'order of preference' list in that window, or wherever you want it placed.

Perhaps you could have found this yourself with a little delving and looking around.

Mark

Collapse -
Mark is right!
by PudgyOne / March 7, 2009 3:34 PM PST
In reply to: button

Firefox has been updated many times since then.

Click tools, options,content(3rd tab), choose(bottom button in box)

Then select the language in the white box or use the drop down menu to choose a new language, not listed.


Rick

Collapse -
No, that's for changing the web pages language.
by anagath / March 14, 2008 10:06 PM PDT
In reply to: Open Mozilla Firefox

These steps you mentionned don't change the language of Firefox menus and titles. They change the display language of the web pages.

Collapse -
Replying to a post that's over a year old
by PudgyOne / March 15, 2008 3:47 AM PDT

Doesn't seem right.

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.


Rick

Collapse -
how to change Firefox from Spanish to English language
by suziq6638 / August 16, 2010 9:47 AM PDT
In reply to: Open Mozilla Firefox

I love these kind of instructions, step by step. I used to have Firefox in English, but it somehow changed to Spanish. The instructions below from Rick work up to the 4th item, click on general. Then there is no language box or icon to click on. In this box I have Accesibilidad with 3 check boxes under it, then Navegacion with three boxes under it, then Por Drfecto with one check box. None have anything to do with language so far as I can tell. Under Options, Contenido, there is a language selection, and I have selected English, but the menus in Firefox do not change.

Collapse -
That sounds right
by MarkFlax Forum moderator / August 16, 2010 8:51 PM PDT

The Language option in browsers helps us to read displayed web pages in different languages. It does not change Windows and so does not change the overall look of the browsers.

Your problem looks like a Windows problem, not a browser problem.

Mark

Collapse -
Why not uninstall this English version ...
by Kees Bakker / August 16, 2010 8:53 PM PDT

and download and install the Spanish again?

Kees

Collapse -
OUT OF DATE
by TrophyJoe / January 2, 2012 9:03 PM PST
In reply to: Open Mozilla Firefox

Does not help for Firefox 8.0

Collapse -
Well, that post
by MarkFlax Forum moderator / January 2, 2012 9:08 PM PST
In reply to: OUT OF DATE

was made in 2007 so I would assume you are using a different version of Firefox than then.

Did you try Firefox > Options > Options, (again), > Content tab?

Mark

Collapse -
As an update...ADVANCED should be CONTENT
by Jules70100 / January 14, 2014 1:57 AM PST
In reply to: Open Mozilla Firefox

Click Tools > Options > Content > At languages click Choose > CLick Select a language to add if the language you need isn't already in your list. > Move up or Down so that desired language is on the top of your list.

Collapse -
(NT) Why not uninstall and download the right version?
by Kees Bakker / February 27, 2007 6:07 PM PST
Collapse -
change language (menu items)
by spamgoesaqui / October 6, 2008 8:07 AM PDT

in the url bar, type in

about.config

find the line:

general.useragent.locale

and change to en-US for us language.

Collapse -
woops
by spamgoesaqui / October 6, 2008 8:09 AM PDT

my mistake, i meant type about:config NOT about.config

Collapse -
THANK YOU
by Chickenmobile / March 24, 2010 2:31 PM PDT
In reply to: woops

This helped so much, my GUI was in German and I couldn't understand any of it except OK... xD

Collapse -
In Firefox 3.0.3 the language settings has moved
by PudgyOne / October 6, 2008 8:14 AM PDT

tools

options

content

languages


Rick

Collapse -
Firefox_language
by Vickeych / March 21, 2010 3:12 PM PDT

It works for me. Thanks.

Collapse -
Thanks
by thisisamar / August 30, 2010 12:55 AM PDT

Thanks... that solved everything...

Amar

Collapse -
Thanx
by GayanChinthaka / May 17, 2011 8:24 PM PDT

Thanx buddy.it help me too Grin

Collapse -
not quite.
by mdmaZOR / January 3, 2012 6:11 PM PST

went through the config files and changed to en-US from TH, *very difficult language...*
now what? restart? close the file?? not changed from the VERY difficult language.
plz help have a native reader and she cant figure out. not sure what version firefox im using, im guessing out dated too! maybe gonna have to download the new one. but still trying.

Collapse -
Did you try
by MarkFlax Forum moderator / January 4, 2012 5:02 AM PST
In reply to: not quite.

the simple way?

Firefox > Options > Options, then Contents tab, then Languagess

if that fails, then I'm guessing uninstall and reinstall is the only option.

Mark

Collapse -
Firefox 3 Language setting - sure it's not Google?
by joq8 / December 10, 2008 7:16 PM PST

I came across this thread while trying to correct my own firefox 3 langauge problems. I got stuck with Arabic, based on location, despite dowloading en-gb. Changing the settings within firefox made no difference and the firefox menu bar WAS in English. I got the answer on another site and thought I'd post it here - my settings problem was in Google, the default display page, not Firefox. To correct it, open firefox and when the google page comes up, click on the 'google' shortcut - the only thing I had in English - change your settings, save your preferences, and voila, it displays correctly. Hope this helps someone else.

Collapse -
re-download firefox
by maxseed9 / January 30, 2009 10:31 AM PST

1. Remove firefox
2. set Location on Control Panel/Regional and Language options to United State (if you need all menu bar in English)
3. Open browser, go to www.mozilla.com, it will re-direct you to en-US page
4. Download firefox
5. Install firefox

Collapse -
How To change language in firefox
by techservices24 / March 18, 2009 9:04 PM PDT

Could you please tell me that which version of Firefox you are using ?

Collapse -
Why do you want to know
by MarkFlax Forum moderator / March 18, 2009 9:43 PM PDT

This thread was started in 2007. Why do you want to know that now, 2 years later?

I suspect the original poster has either solved the problem or moved on.

One other thing. Firefox has been updated a number of times since then. I can't remember what version of Firefox I was using 2 years ago.

Mark

Collapse -
In my post Dated 3/7/09
by PudgyOne / March 19, 2009 12:45 AM PDT

I gave instructions using version 3.0.7


Rick

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech for the school year

Smart tech for smart students

Forget the pencils and notebooks. Gear up your students with these portable and powerful note-taking machines.