Networking & Wireless forum

General discussion

Home network set-up not successful.

by Syncopator / February 21, 2013 11:15 AM PST

I have two computers, both with XP SP3, one Home, the other Pro, and a router.

The XP Home computer is connected directly with an ethernet cable to the router, the XP Pro is connected to the router through ethernet over the a.c. supply through two of those whatever you call them "adapters".

Both computers connect to the internet ok but they apparently can't see each other - the network which I thought I had set up doesn't appear in My Network Places, nor can the XP Pro machine use the printer which is connected to a USB port on the XP Home one.
When I try to print something from the Pro machine, the printer's (Epson) window opens up, telling me that the "Printer is not ready to print".

I may have overlooked something, or perhaps the various instructions which I have read have not mentioned something which they should have.

Can anyone suggest a reliable and complete set of instructions which I can consult?

Post a reply
Discussion is locked
You are posting a reply to: Home network set-up not successful.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Home network set-up not successful.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Have you looked at the built in Windows help?
by wpgwpg / February 21, 2013 11:35 AM PST

Have you tried the Windows help that's built into your system? Have you run the networking wizard from the Control Panel? Have you marked your printer shared? Have you turned on shared files and folders? Usually that's about all it takes.

Good luck.

Collapse -
Today's routers block the home networking.
by R. Proffitt Forum moderator / February 21, 2013 1:30 PM PST

As there is no router model noted, I can't write much more.

Collapse -
need more info
by bangaloredatacom / February 21, 2013 2:46 PM PST

kindly provide more information on this share

Collapse -
Windows help/router.
by Syncopator / February 21, 2013 3:28 PM PST

Yes, I have run the wizard (several times), the printer is marked as shared. I have set some folders as shared.

How do I get access to the Help to which you refer?

The router is an DSL-2640R.

Collapse -
Links, comments.
by R. Proffitt Forum moderator / February 22, 2013 1:10 AM PST
In reply to: Windows help/router.

I see there are 2 versions. I will only check the B1 version. If you have the A1 version I will wait a few days before I comment again. Please folk, supply the details if you want the best help.

This model does not appear to have the firewall that blocks Windows Sharing.

As such it appears you have something else going on. I'll wait for you to share what web site you are using to setup your networking shares.
Collapse -
Router - perhaps?
by Syncopator / February 22, 2013 3:13 AM PST
In reply to: Links, comments.

Thank you Bob.

It has hardware version B2 and firmware version V1.18.

I had a brief look at the advanced settings but see nothing about networking.

I do see, though, that in a couple of those links, it says " ... sometimes even the Windows firewall has to be told that you have a new trusted device on the network."

Ok, how do I tell that to my firewall?

Oh, by the way, I noticed that in their description of it they say that it has a "Non-detachable diversity antenna". Yes, it's not detachable, but since it's on its own it ceratinaly ain't one of two or more antennas which are necessary for (space) diversity reception. I wonder where some of these people get their ideas from?

Collapse -
As to the firewall.
by R. Proffitt Forum moderator / February 22, 2013 5:26 AM PST
In reply to: Router - perhaps?

When I'm trouble shooting the setting is OFF or Disabled. Your new techs tend to not get why we do that and stumble for days as the firewall blocks their efforts.

-> Keep in mind we are on a LAN behind a NAT ROUTER so only the new networker seems to ask why we turn off the firewall on the LAN machines.

I'll keep trying but I'd like to read about how you set up the printer share, if the workgroup names are the same and well, in short, what web page did you consult to set up the printer share?

Lastly, a few printers do not support printing over the LAN. I read EPSON but no model number so I can't check into that. I don't want to upset you but without the details we end up with a lot of posts.

Try adding these details.
1. How did you share the printer.
2. What Epson.


Collapse -
Printer etc
by Syncopator / February 22, 2013 7:02 AM PST
In reply to: As to the firewall.

Sorry, I should have been a more thorough.

It's an Epson Stylus SX-125. I enabled sharing by right clicking on it in Control Panel > Printers and Faxes, then clicking Sharing and then, under the Sharing tab, enabling Share this Printer. I also enabled "Turn on file and printer sharing" in the Network Setup Wizard.

I have seen this instruction on several sites I visited, - can't remember them, there have been quite a few.

I entered the same workgroup name on both computers.

Collapse -
Quick question.
by R. Proffitt Forum moderator / February 22, 2013 7:39 AM PST
In reply to: Printer etc
Collapse -
Epson Network and Driver package.
by Syncopator / February 22, 2013 9:33 AM PST
In reply to: Quick question.

No I didn't. Never heard of it before.

Anyway, I have downloaded it. I would guess that it has to be installed on both computers?

Collapse -
The firewall
by Syncopator / February 22, 2013 7:19 AM PST
In reply to: As to the firewall.

Having searched for advice regarding this, I have looked at Exceptions and found that "File and Printer Sharing" is ticked, and, in Add Program > Change scope (what a strange choice of words), I have enabled "My network (subset) only", but upon reurning to this window/tab I find that it is no longer enabled, the setting having reverted to the default "Any computer (including those on the internet)"

Collapse -
by R. Proffitt Forum moderator / February 22, 2013 8:00 AM PST
In reply to: The firewall

If there's a firewall, all your work could be blocked. Until you get it working, disable it.

Collapse -
Disable it?
by Syncopator / February 22, 2013 9:38 AM PST
In reply to: Yup.

I think I shall excercise a bit more patience before resorting to that.

Collapse -
I like this approach.
by R. Proffitt Forum moderator / February 23, 2013 8:36 AM PST
In reply to: Disable it?

This often ends up with the service techs coming in. Good to read as folk can't seem to grasp why a firewall on a LAN is going to make trouble. As I can't teach everything here, I hope you think about your discussion here.

Collapse -
A few steps forward, and one or two back.
by Syncopator / February 24, 2013 4:44 AM PST
In reply to: I like this approach.

I installed the Epson Network and driver package on both machines. It didn't seem to make any difference.

I then disconnected the internet cable from the router and switched off the firewall on both machines. No change.

I checked again, using the Network Wizard, everything ok.

I used Microsoft's Network Troubleshooter and disovered that the workgroup name (in the Computer Name tab) was not what I had entered and was displayed in the Network Wizard.

After changing it, I was able to see both computers through My Nertwork Places/"View workgroup computers", and from each computer was able to see the files with sharing enabled on the other one.

Remembering that my printer is on a USB port on the Upstairs computer, I tried to print a document from the Downstairs one. The expected windows were displayed, but, on clicking Print, the printer window's progress bar filled up very quickly and I found that the file had not been printed.

I forget the exact sequence of the next one or two steps (having found this whole matter so frustrating, I have had a bit of a rest from it).

Next time I looked, although both computers were still shown in "View workgroup computers", I was unable to see anything on the Upstairs one from the Downstairs. I was presented with the message " \\Home is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. Access denied".

Well, I am the administrator, and he doesn't know !!

I had had quite enough again, thank you, so shut both machines off again.

This evening, I fired them back up.

I was able, from the Upstairs computer, to modify a file on the downstairs one, and tell the downstairs one to print a jpg file, which it did.

Going downstairs again I was unable to see anything on this (the Upstairs one) from it again and was presented with that same message.

Anyone got any ideas?

Collapse -
re. my previous ...
by Syncopator / February 24, 2013 4:49 AM PST

Perhaps I should point out that in the message regarding lack of permission/s, "Home" is what the system calls the "Full computer name", while "Upstairs" is the one I gave it for use on the network.

Collapse -
Ahh. Accounts, permissions and more.
by R. Proffitt Forum moderator / February 24, 2013 4:53 AM PST

"\\Home is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. Access denied". "

That's your clue that there are account issues. For example I log onto my PC as "bob" but if there is a shared printer on another PC I must have an account on that PC called "bob".

This is basic Windows 101 networking (not class 100) so it's quite close. Sounds just like the old account issues.

Your comment about administrator is, well, read all the time. But unless the accounts are there, you get such messages. Sometimes after you create the accounts you have to unshare and re-share the printer or folder.

Collapse -
by Syncopator / February 24, 2013 7:44 AM PST

I never gave a name to the Downstairs default account, just accepted the default, which was, I think, "User".

Anyway, I have changed its name to be the same as the one on this machine. It didn't make any difference.

Would just changing the name have been sufficient?

I have now un-shared the printer, and then shared it again. Going downstairs to see if anything has changed ....

Collapse -
by R. Proffitt Forum moderator / February 22, 2013 1:25 AM PST

I've yet to find a reliable and complete set of instructions that don't include a full course in Windows and more. I see a lot of guides out there on how to share a printer on Windows XP but I take it those have not helped so sharing another one is not going to help.

It took a few posts to dismiss a problem I encounter a lot today and the details are still slim. For example, tell the forum more about how you setup the printer share.

Collapse -
by R. Proffitt Forum moderator / February 24, 2013 7:53 AM PST
Collapse -
by Syncopator / February 24, 2013 9:24 AM PST
In reply to: Accounts.

I don't see anything in that link which helps me, quite possibly because I simply don't understand most of it.

Can you enlighten me please?

Collapse -
There are 2 network choices
by R. Proffitt Forum moderator / February 24, 2013 9:32 AM PST
In reply to: Accounts

Simple file sharing and, well, the classic file sharing system. It appears we made a little progress but you are seeing why XP is fading. What should be simple can fall apart. And look up where we needed to get the firewall off during setup and you didn't want to do that. And then you pulled the internet out of the router which could have let XP fetch an update or driver automatically.

I've tried here but you can see why this is good for the geek squad folk.

Again, the router is a firewall in its stock form. Seems we lost time over that.

Collapse -
Firewalls off
by Syncopator / February 25, 2013 2:16 AM PST

I can see that you are, with some justification, losing patience. But I do appreciate your time Bob.

If you would persevere I would be grateful. If you can't, would you tell me where I might get further help?

Collapse -
I do keep trying.
by R. Proffitt Forum moderator / February 25, 2013 2:24 AM PST
In reply to: Firewalls off

And hope you understand that I don't want to upset folk as we work networking issues. There's a lot to go over and something is blocking the shares.

I FORGOT something. Sorry. After some of those changes we have to reboot. Again, XP is quite an old system and may not tell you need to do that.

Let's work the clue about the access to the computer. That is.
" \\Home is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. Access denied".

This is almost always the accounts issue. You see a lot of folk try to network with guest, limited user accounts or accounts that don't match up across the PCs and end up with no network.

Again, if I am to access \\Home, I must have an account there that matches the machine I'm logged into. So if I'm bob here I must have a bob account on the other PC.

-> Yes you could enable Guest Access if you want to forget all that. Your choice on that.

Collapse -
And again. About Simple File Sharing.
by R. Proffitt Forum moderator / February 25, 2013 2:26 AM PST
In reply to: I do keep trying.
Collapse -
Account names
by Syncopator / February 25, 2013 9:18 AM PST

I had already changed the account name on the downstairs computer to be the same as on the upstairs one.

In the last post in that link you gave, the author gives a registry mod which overcomes the permissions problem. I made the change and now I don't get that restriction. Ok.

I can now, from either computer, modify a file in the other.

What I still can't do is print from the downstairs one, it shows the printer windown briefly as I said before, but it doesn't print.

But I can still tell the downstairs computer, from the upstairs one, to print a file from the downstairs one and it works.

Collapse -
by R. Proffitt Forum moderator / February 25, 2013 9:27 AM PST
In reply to: Account names

OUCH, that walks right into issues I don't want to think about.

I create the missing account if need be. So that if my pc that I use has a bob account, I create a bob account on the other PC so it knows bob.

Changing the name? Tell me if that works.

Collapse -
Account name
by Syncopator / February 26, 2013 2:36 AM PST
In reply to: CHANGED????

I changed the default account name a few posts ago, the one dated 2/24/13 3:44 PM (sic).

No it didn't make any difference.

Neverthless, I have renamed it again to User, as it was before, and created another one with the same name as the account on the this, Upstairs, computer.

That has made no difference either.

I can still see the shared folders ok, but when I tried to print from downstairs I had to add the printer again. It still doesn't print though. I get the printer's progress bar filling quickly but no printing.

Collapse -
Sorry to write this.
by R. Proffitt Forum moderator / February 26, 2013 2:47 AM PST

But it appears that odd things are happening here. I write about the need for the accounts to be in sync and instead of creating an account with the matching name, an account is renamed. This should work but given we are on XP Home and mixing it with XP Pro and how this all works, you are going down pathways I don't go.

I'm sure somewhere there is a reason for this to work or not but this many posts and it's not working. I can't tell if the account rename is to blame here but it appears that it's time to forget all the accounts and just enable Guest access since we can't seem to complete this the way I have for years.

It is possible that this printer may have network issues and I had hoped it was networkable given Epson's network and driver download.

Since we can't accomplish the account work, I suggest you just open up the network to all users and guests with the following change. Link follows.

"I believe there is a feature to allow shared folders for ananymous access as well. Try these steps, if you are using WinXP Pro only!

1. Go to start-> run -> type "gpedit.msc" without the quotes.
2. Expand Computer Configuration
3. Expand Windows Settings
4. Expand Security Settings
5. Expand Local Policies
6. Click on "Security Options"
7. Find the entry "Network Access: Shares that can be accessed anonymously"
8. Type the share name on a separte line
9. Enable the Guest Account "

Collapse -
Guest access
by Syncopator / February 26, 2013 7:21 AM PST
In reply to: Sorry to write this.

There are a few things not clear to me, Bob.

The instructions you give at the end of your last post apply to XP Pro. It seems to me that those instructions imply anonymous access to files on that, i.e. the XP Pro, machine. If that is true, how will it help, since the problem is access to files (presumably that's what "shares" means) on the XP Home machine ( the Upstairs one)?

And the instruction number 8. what is a/the "share name"?

To comply with previous information, does enabling the Guest account on the one machine mean that I have to enable it on the other too, since you say both machines must be using identically named accounts?

I'm sorry, but so many terms are either ill-explained or not explained at all on most, if not all, of the sites I look at. They all use jargon which assumes prior knowledge.

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions


Having Wi-Fi troubles?

From the garage to the basement, we blanketed every square inch of the CNET Smart Home with fast, reliable Wi-Fi.