Phones forum

General discussion

Help with T-Mobile MDA WI-FI Not able to connect to own Net

by Captgilbert / May 19, 2006 9:45 PM PDT

I am having a problem connecting to my Cable Modem and(wirless home network). My T-Mobile MDA with Windows Mobile 5 sees and tries to connect and after about 10 seconds it try's the next connection that it sees. I have been on with customer
support with T-Mobile about 10 times and they have yet been able to resolve the problem. However my 2 computers (wireless) and PDA I-Paq all have no
problem connecting. The computers are running windows XP prof and my I-paq pda is running Windows 2003 2nd edition. I have gone as far as unsecuring the wirless network and leaving it open as well as turning off the firewall so it would make the connection. Again, it see's it and will state its
available. Once taping on it to connect, it will try and move down to the next connection the MDA see's.
With this being said, I have been able to connect to a local hotspot from T-mobile without any problems. Again, my home network works fine with my 2
wireless computers and PDA without any problems. The phone is new, that I have only had for 14
days. I did have T-Mobile change out the phone and I had the same problem with the replacement phone. I just want to be sure there is nothing I am missing. I am running a Belkin Wireless Pre N Router that supports A, B and G and MMO. Any information that you can provide would be deeply appreciated. Thank you for your time.


Post a reply
Discussion is locked
You are posting a reply to: Help with T-Mobile MDA WI-FI Not able to connect to own Net
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Help with T-Mobile MDA WI-FI Not able to connect to own Net
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Help with T-Mobile MDA WIFI not able to connect to own net

I am having the same problem. I even tried to change the key number on the router and the MDA. Still have the same problem.

OS: WXP Professional

Cable modem: Road Runner

Router: Belkin Pre-N MIMO wireless router

My HP RX 3115 PDA picked up the router right away, I typed in my key and away it went.

My MDA will not do that. I am able to connect to many other wireless access points, particularly at my favorite coffee house (not Starbucks, although I can connect there too, but it is a T-mobile hotspot.)

I just cannot connect to my own.

Also, does anyone know of a good WIFI access point organizer like Socket's WIFI Companion, that can be used with Windows Mobile 5.0?

Collapse -
Help with T-Mobile MDA WIFI not able to connect to own net
by dcardinale / May 28, 2006 10:17 AM PDT

My MDA worked at a friends place. He has a Belkin router 802.11b. However, I have not managed to get the MDA working at my home.

So, the good news is that the MDA is capable of accessing the internet using Wi-Fi without having a T-mobile data plan. The bad news is that it does notpick up all networks just as easily.

If someone knows of any Wi-Fi software that could fix this problem..please post it.

Collapse -
Try a different Router
by Captgilbert / July 14, 2006 10:21 AM PDT

After having the same problems and several conversations with T-Mobile support I found out the MDA will not work with the Belkin Router. I purchased a seperate Linksys and connected it to my Belkin Pre N wireless router. It saw the Linksys router and connected without any problems. This will sove any patches or download that you may have to do. Any router should work. For whatever reason, the MDA does not work with the Belkin Routers.

Collapse -
T-Mobile MDA Wi-Fi not connecting
by RBurttram / June 28, 2006 7:56 AM PDT

I had a similar situation with my home network which has a Linksys SRX Access Point.

My MDA had not be able to connect for months. when I turned off 802.11e (QoS) on the AP, the MDA connected right away.

Does your system have QoS turned on or off?

Let me know if this helps.


Collapse -
T-Mobile MDA Wi-Fi not connecting
by Captgilbert / July 7, 2006 4:26 AM PDT

I have turned it off I am still unable to connect. It sees the connection trys to make contact then goes to the next one. Still not connecting.
Any help would be appreciated.
Thank you,

Collapse -
My MDA does the same thing
by QuarterDigital / July 14, 2006 7:27 AM PDT

Have you had any luck isolating this problem?


Collapse -
MDA Problem Solved
by Captgilbert / July 14, 2006 10:25 AM PDT

Please read my posting July 14th. The MDA does not work with the Belkin Routers. I purchased a Linksys Router and connected to my Belkin Router. It solved the problem and works fine. They MDA will work with most routers except Belkin.

Collapse -
Try changing router settings

I had the same problem, but with a Linksys router - not a Belkin router as described elsewhere in this thread.

If you know how to point a browser to your router's control interface, then you might give this a try. Mine is a WRT54GX2, but the wireless setting options are common to many other devices, though the user interface may be different. Warning: It is a good idea to connect your computer directly to the router with an Ethernet cable when making configuration changes, as you will be interrupting everybody else's WiFi connection and changing the wireless settings during the process.

Under the WIRELESS tab, and then the sub-tab ADVANCED WIRELESS SETTINGS, change the Basic Rate Set from the default of Basic Rate Set #2 to Basic Rate Set #1. Don't forget to click on SAVE SETTINGS before exiting.

This did the trick for me, my MDA suddenly connected to my home network!

I assuming that Rate Set #1 supports lower data transfer rates than Rate Set #2, so if you have a different router, I suggest lowering the data transfer rate in whatever control panel you have access to and see if that helps. These changes may also affect other computers on your network, or affect overall performance, so be ready to change back to the original settings if you are not happy with the results. In my case, I haven't noticed a difference yet.

Collapse -
It worked on my Dlink , too.
by dholm99 / September 4, 2006 11:50 AM PDT

My MDA wasn't working either, so I lowered the wireless transmit settings of my router to "g" standard (instead of boosted to the dlink-compatible 22 mbps), and now it works. Thanks for the help.

Collapse -
WiFi access without data plan?
by bobwolfeum / September 4, 2006 4:31 AM PDT

It is good to hear that the MDA can connect to home wireless networks, based on the responses to this query. Do you need to subscribe to a TMobile data plan to use the WiFi in your home or at other free hotspots?

Collapse -
WiFi doesn't require a plan
by christinanity / September 4, 2006 9:37 AM PDT

You do not need to subscribe to T-Mobile's data plan to use the Wi-Fi capabilities. Assuming you get past the technical incompatibilities noted in this thread, the device will connect to any open network/hot spot.

Having a data plan is useful because it allows you to access the internet anywhere, via the T-Mobile GPMS cell phone network. The Wi-Fi connection operates independently of that (and at higher data speeds than the cell connection). For me, one of the best things about the plan I have is that it gives me unlimited access to T-Mobile hot spots without paying an access fee. I use that feature all the time (though from my MacBook, not my MDA), mostly in United Red Carpet Club rooms.

One thing to keep in mind is that when you activate Wi-Fi on the MDA, the battery will drain more quickly...

Collapse -
No data contract for T-Mobile MDA
by sgw333 / September 19, 2006 12:36 PM PDT

I do not have a Data contract and my MDA will not connect via WiFi.
The message appears "address not valid" is that a phone problem or the fact that the phone is not on contract. If a phone problem what is the solution to connect via WiFi without contract?

Collapse -
How I did Mines
by BamBamIsFresh / December 25, 2007 12:07 PM PST

I first went to the comm manager and turned on the wifi connection. Next I waited for my device to detect the wireless connection and and a popup showed which connections were available. I then picked my home wireless connection on the list and waited for it to connect. Then another popup came up requesting that I enter the passcode/key. My key was located on my router under "wepkey". I entered that in and hit connect and voila! I hope this was somewhat helpful because I actually just figured how to do it today lol.

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

CNET Holiday Gift Guide

Looking for great gifts under $100?

Trendy tech gifts don't require a hefty price tag. Choose from these CNET-recommended useful and high-quality gadgets.