Try opening Firefox Safe mode. Please don't confuse it with Windows Safe Mode but open Start>Programs then find Mozilla Firefox then click Safe mode.

When Firefox safe mode dialog box appears, check all boxes to reset your Firefox settings to default. See if you can visit any site again using this mode of Firefox. See for more info on Firefox Safe Mode.

Can you reset or reconfigure the settings of Avast Pro?
Have you tried running System File Checker in Windows XP? If not yet, please do this:
Open Command Prompt in Windows
Type SFC /scannow
Hit enter key on the keyboard
Let the system check for any issues. If you are prompted to insert your XP installation disc, do it.
See if that will do any help. Even if not, please try opening IE then visit Microsoft Update website for any updates. Install the critical updates if any is offered.