Peripherals forum

General discussion

Help me cure my jumping cursor while typing!

by Lee Koo (ADMIN) CNET staff/forum admin / July 30, 2010 8:26 AM PDT
Question:

Help me cure my jumping cursor while typing!


We have a new 2010 Dell Studio XPS laptop with Windows 7 and
are experiencing a cursor jump while typing. The cursor jumps
to a point above where it was during the typing (frequently
to the TO or CC line of an e-mail message). The jump is
unpredictable in terms of timing and position to which it
goes. When the jumps occur, we have not touched the touch
pad. This jumping occurs both with and without an external
mouse attached. Thank you all in advance for any advice you
can offer.

--Submitted by Mike T.

Here are some featured member answers to get you started, but
please read all the advice and suggestions that our
members have contributed to this question.

Jumping cursor --Submitted by rldunc
http://forums.cnet.com/5208-7590_102-0.html?messageID=3350275#3350275

JUMPING MOUSE POINTER --Submitted by GEO2003
http://forums.cnet.com/5208-7590_102-0.html?messageID=3348505#3348505

Jumping Cursor while typing --Submitted by mgmorgan01
http://forums.cnet.com/5208-7590_102-0.html?messageID=3348509#3348509

Jumping Cursor --Submitted by linda5674
http://forums.cnet.com/5208-7590_102-0.html?messageID=3348442#3348442

Jumping cursor while typing --Submitted by mbrice
http://forums.cnet.com/5208-7590_102-0.html?messageID=3348485#3348485

Check motherboard firmware version on Dell Support web site missophie212
http://forums.cnet.com/5208-7590_102-0.html?messageID=3349127#3349127

The Cure For Jumping Cursors While Typing --Submitted Mick.Jagger*
http://forums.cnet.com/5208-7590_102-0.html?messageID=3348662#3348662

Read all member contributions below for this topic

Thank you to all who contributed!
Post a reply
Discussion is locked
You are posting a reply to: Help me cure my jumping cursor while typing!
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Help me cure my jumping cursor while typing!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Jumping cursor
by omiller315 / July 30, 2010 10:06 AM PDT

I work in IT at an insurance company of over 300. I do repairs on the side as well.. This might be a band-aid fix but it does work. There is a program called TouchFreeze that disables your touchpad while you are actively typing. It can be found at the following link

http://code.google.com/p/touchfreeze/

I hope this helps.

Otto

Collapse -
Jumping cursor
by rockroserealty / August 6, 2010 11:36 AM PDT
In reply to: Jumping cursor

Hi, I had this problem too, on a Sony laptop, the solution I found was to get a plug in keyboard which cured the problem and I never had this issue again. A friend of mine had the same problem, tried this and it worked for him too. Not sure what is causing the problem but this is a good solution and you can type faster too. Most laptop carriers will allow you sufficient room to carry a spart keyboard.
Good luck Susan

Collapse -
Why do folks post solutions that have already been posted ?
by vonheise / August 6, 2010 12:27 PM PDT
In reply to: Jumping cursor

Posted at least ten times. Can't one read ? The problem is the hand on the touch pad. There are at least 10 better answers on this but I too use a USB remote keyboard and mouse, but on a airplane this fix is rather awkward, so maybe some will prefer an actual fix which there are many I have now learned...

Collapse -
Touchfreeze
by joed20 / August 7, 2010 4:53 AM PDT
In reply to: Jumping cursor

Hi Otto,
Thanks for the link to Touchfreeze and hopefully it'll work for me. I have a Toshiba laptop and was cursing them for the past couple of years as I was sure I had a faulty keyboard. Then I get my usual CNET e-mail this morning with the answer to all my problems. I was delighted to find out it was an easy problem to fix.
Best regards
Joe
Dublin

Collapse -
TouchFreeze Works!!
by TouchpadDemise / October 2, 2012 4:29 PM PDT
In reply to: Jumping cursor

Thank you - Thank you - Thank you for providing the link! I have been having the same problem with my HP dv7 and couldn't even finish typing one word before the cursor would skip lines and delete words along the way!! Now I can actually use my laptop the way I intended to use it, with the touchpad and not an external mouse! Imagine that HP!! Perhaps they'll issue a permanent fix one day to show concern for their customers... ehhh probably not.

Collapse -
Me too!
by BistroPithecus / October 30, 2012 1:02 PM PDT
In reply to: TouchFreeze Works!!

I too have a HP dv7 and I've become so enraged with it's skipping while typing issue. I just now downloaded TouchFreeze and so far I haven't had any more skipping problems. Happy so, thank you.

Collapse -
tried this and it works perfectly.
by muggins3000 / August 19, 2013 4:32 AM PDT
In reply to: Jumping cursor

thanks

Collapse -
(NT) Thank you very much Otto.I have sony vaio vpceb33fm.It works
by tesla_bl / October 26, 2013 11:22 PM PDT
In reply to: Jumping cursor
Collapse -
Jumpy Dell Curser
by aburkman / July 30, 2010 10:13 AM PDT

I think this is a Dell Laptop problem. I have had it with two different Dell Laptops. I will never buy another Dell Laptop.

Collapse -
Don't blame Dell, it is your hand on the touchpad,
by vonheise / July 30, 2010 11:48 AM PDT
In reply to: Jumpy Dell Curser

As other have stated, it happens with all brands but I still like my first solution best, and external USB keyboard and mouse. No more problems at all at home. On the road you can check all the other answers such as reducing the sensitivity, or disabling, but I just keep my hand off the touch pad while traveling, but haven's tried putting a small magazine over the touchpad as that too may work. Great technology sometimes bring minor irritations. Think back 15 years then you can appreciate what we have... This was spoked by a 65 year old man who remembers having to dial an operator to call a frined when I was a child.

Collapse -
Incorrect
by ggecko87 / November 25, 2013 9:19 AM PST

This problem is NOT related to the touchpad. I am using a DELL Latitude 6410 as we speak with the Touchpad disabled and connected to an USB mouse. I have been experiencing this problem for the past two weeks and cannot figure out the problem. It's disruptive as all hell when you're trying to type and the curser suddenly starts bulldozing half of some other sentence you've already typed across the page!

Collapse -
I taotally agree with the hardware error
by MNFsoft / July 30, 2010 10:10 PM PDT
In reply to: Jumpy Dell Curser

If you still have a garantee well use it is good chance that you have an error in the hardware so conact dell to send someone over to you to chack because I do not think it is a software error I face it ocationally (at start up usually) but it goes away by itself not only this it starts clicking randomly (left or right clicks).
If your garantee is over well try solving it by a program and check if ithappens or not if by using the program the problem presists then it is defenatly hardware!

Collapse -
touch pad causing jumping cursor
by ferraribeng / July 31, 2010 6:55 PM PDT
In reply to: Jumpy Dell Curser

I read many proposed solutions from different people. From my personal experience, I tend to agree that it is likely to be our hands lightly brush through the touch pad.

I have used 3 Dell laptops since 2001. My first was Dell Inspiron 4000. I encountered this annoying problem with it. After I changed the sensitivity setting of the touch pad to be less sensitive to my touch. The problem was gone.

I don't have this annoying problem with my subsequent Dell laptops: Inspiron 6400 and Precision 6400. I have also used my friend's Dell Studio and I didn't encounter the problem. Maybe I have adapted my typing habit with my hands avoiding the touch pads after last 10 years of using laptops.

If there is really hardware issue, do call up your friendly Dell Support. I recently had backlighting failure on my keyboard. They arranged a technicians to come to my office to fixed it. Within 20 minutes, they had the keyboard replaced. I'm now happily using my Dell Precision.

In my part of the world, Dell techinical support is 2nd to none. Maybe a bit troublesome trying to fix the problem over the phone initially. Once they have decided that it is a problem that cannot be fixed over the phone, they will send a technicians to anywhere within Singappore at my convenience and during office hour to repair my laptop.

Collapse -
Jumpy.
by vict8536 / August 5, 2010 4:18 AM PDT
In reply to: Jumpy Dell Curser

Not a problem with just Dell but with other computers a s well.

Collapse -
Agreed
by nascargirlgo14 / April 14, 2012 2:06 AM PDT
In reply to: Jumpy Dell Curser

I agree 100000000%!!! DELL SUCKS I have had nothing but TROULE out of my dell!!

Collapse -
Jumping Cursor
by ukenuke / July 30, 2010 10:13 AM PDT

It's possible that your hand is brushing or touching your Touchpad as you type. Good luck.

Collapse -
I have finally cured the problem with my laptop's touchpad!
by CMJPVE / July 30, 2010 10:16 AM PDT

With assistance and information from our son, I stopped the jumping cursor. I have a Sony Vaio laptop running Vista and Microsoft Windows office premium.

The classic cure for the jumping cursor on-line is to disable it and use a mouse. I don't like mice so that was unacceptable.

Go to Control Panel (classic view)>system>hardware>device manager>mouse devices> You will find the touchpad listed as a mouse device. I first searched for new drivers and didn't find any. I finally disabled it (uninstall). I then had to shut down and reboot. When I rebooted Microsoft reinstalled, and I had to shut down and reboot again.

It worked and my cursor no longer jumps, but I admit that I had grave doubts about uninstalling it. Hope it works for you

Collapse -
I'm confused
by hollhy65584 / August 7, 2010 3:00 PM PDT

Thanks for your answer, but I'm confused. You said you booted and re-booted. Is that fixing the touchpad or deleting (uninstalling) it?

If it is uninstalled, how would I get it back when I travel and don't want to use a mouse?

Thanks,
Holly ~

Collapse -
Jumping Cursor Blues
by BillyReeves / July 30, 2010 10:30 AM PDT

Hello Mike

I am running Windows XP Home. Try this and see if it does the trick.
GoTo:
Start->Control Panel->Printers and Other Hardware->Mouse->Pointer Options.
Remove the checkmark from "Hide Pointer While Typing" checkbox.
Click apply-> OK

Hope this helps

Billy Reeves

Collapse -
Sorry
by BillyReeves / July 30, 2010 10:34 AM PDT
In reply to: Jumping Cursor Blues

Sorry

I did not see your previous post. I answered from an email from CNET.

Thanks and keep computing...

Billy

Collapse -
Jumping cursor
by rblatt / August 10, 2010 5:41 AM PDT
In reply to: Jumping Cursor Blues

OK!
- Omiller's suggestion - http://code.google.com/p/touchfreeze/ - worked out fine with me.

- But "Start->Control Panel->Printers and Other Hardware->Mouse->Pointer Options. Remove the checkmark from "Hide Pointer While Typing" checkbox. Click apply-> OK" did not (well, thanks, anyway, Billy Reeves).

Many thanks, I thought this problem had something to do with the distance between keyboard and touchpad (and my inability at avoiding the thumbs to reach the touchpad), as it only happens with my Sony VAIO VGN-FZ350AE and not with my older ACER...

Collapse -
Jumping Cursor
by Arlie59 / July 22, 2012 11:59 PM PDT
In reply to: Jumping cursor

Thanks..I did exactly as you said and it worked like a charm. I don't think DELL is aware that it has a "glitch" in the cursor department...

Collapse -
Dells concen not yours
by justchuck69 / July 30, 2010 10:44 AM PDT

"We have a new 2010 Dell Studio XPS laptop with Windows 7 "

since it's new send it in for dell to fix or get your money back . .they should only be selling omputers in good working order not ones with bugs to fix!!!!

Collapse -
Dells concern not yours
by BillyReeves / July 30, 2010 11:31 AM PDT
In reply to: Dells concen not yours

Hello Chuck

I actually enjoy being a user of Microsoft products. Programmers and developers who work super hard, intelligently, and passionately are always trying to make the MS products better.
...ever pay any attention to the error report messages?
After enough of us "field testers/consumers" log an error report, MS takes it to the update level. Most Updates arrive at your IP around the 10th of each month from what I understand.

Loving It!

Billy Reeves

Collapse -
jumping curser
by Noel_francis / August 7, 2010 4:25 AM PDT
Collapse -
I had the exact same problem and found a cure
by Marymacmilton / July 30, 2010 11:01 AM PDT

I had the same issue and I contacted ACER, my computer's company for help. This is the email I received from them. It solved my problem. Good Luck!Thank you for contacting Acer America. If the mouse cursor moves erratically, it appears that you need to disable the "Tap to Click" feature of the computer.

Frequently when typing, your wrists will brush the touchpad, causing the cursor to jump around or even leave the window. To adjust the sensitivity of the touchpad, go to Control Panel > Mouse > Device settings > Settings, and you should see Sensitivity in the list on the left with + next to it. Click the + next to Sensitivity and adjust the settings to your liking. Also check the Palm Check settings for another way to tweak your touchpad settings. If this still does not solve your problem, it may be that part of your hand is still touching the touchpad. To test this, you can try typing with your touchpad turned off. You can turn it off by holding the FN key, and pressing the F7 key. Use the same key sequence to enable your touchpad again.
Another suggestion is to disable the tap-to-click option for your touchpad. I am including these steps below.
1.) In the system tray (Near the digital clock in the bottom right corner) right click on Touch Pad. This icon will look like a touchpad on a notebook or a red square with a white circular shape inside.
2.) Choose Mouse Properties or Pointing Device Properties.
3.) Click on the tab that says Tapping and proceed to step 4, or click on the tab labeled Device Settings and proceed to step 6.

4.) To disable Tap-to-Click while typing, ensure that the box next to "Tap off when typing" is checked. If this does not correct the issue, or you would prefer to disable the Tap-to-Click feature completely, ensure that there is NOT a check in the box next to "Tapping" (you can also adjust the speed of Tapping or the duration in which Tapping is disabled after you have pressed the last key while typing.)
5.) Click Apply and then OK.

6.) Click on the button labeled Settings.
7.) To adjust Tap-to-Click while typing:
a.) Click the plus (+) sign next to Sensitivity in the left menu.
b.) Click on PalmCheck
c.) To reduce the area required for tapping, move the slider towards Maximum. To increase the area, you can slide towards the Minimum
8.) If this does not correct the issue, or you would prefer to disable the Tap-to-Click feature completely:
a.) Click on Tapping in the left menu.
b.) Ensure that the box next to Enable Tapping is NOT checked.
9.) Click Apply and then OK.
If this does not resolve the issue, we suggest reinstalling the touchpad driver. I am including instructions on how to install the driver from your computer's hard drive, using the eRecovery utility. If this does not correct your problem, you can try downloading the software at www.acerpanam.com, in the Drivers and Downloads section.

1. To start the eRecovery program move your mouse over the Empowering technology widget and click on the eRecovery Manager icon. You may also press ALT and F10 on the keyboard to start the program.
Please note: The first time you access the eRecovery feature, you will be prompted to create a password. Be sure to write this password down somewhere safe. If for any reason you do not have the correct password you will be unable to use any feature of the eRecovery.

The next window will have the options at the bottom of the window.

2. Choose Restore
3. Next, choose Install
4. Click on Windows Vista on the left side of the page
5. Choose driver.
6. In the list choose the item you wish to install
7. On the right click the install link and follow the prompts.
8. The system may restart when installation is complete

Collapse -
No, don't jump!
by sregul / July 30, 2010 11:14 AM PDT

I read your question, and related back to when I used to use a laptop with a trackpad. If your laptop has a trackpad, that could be the culprit. Your palms could be bumping the trackpad, causing your cursor to 'jump'.

On my laptop, I could toggle the trackpad off. If you can do this, you might want to try it to see if it affects your cursor.

Otherwise, your cursor could have some Mexican jumping bean DNA in it. Better keep it out of the sunlight.

Collapse -
Dell Problem
by Lennatron / July 30, 2010 11:29 AM PDT

I think you need to contact Dell. Click start and type "Dell Support Center" Click on Dell Support Center then click technichal help and choose your help method.

Collapse -
I also have a Dell studio
by vonheise / July 30, 2010 11:34 AM PDT

The answer to the moving curser may be true of most laptops as this is the first one that I have used without a trackball. I solved it two ways, first with an external USB keyboard which makes it go totally away for good. However when I travel by plane I choose not to carry a keyboard seperately, so I just make sure I never let a thumb or anyother part of my hand touch the touchpad as that moves the curser and changes where I am writing forcing me to make corrections. It took me awhile to realize that I was causing the probem, but at times I still do it. I suppose the touch pad is in a logical position but it is right where my thumbs or even part of my hand wants to rest.

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech for the school year

Smart tech for smart students

Forget the pencils and notebooks. Gear up your students with these portable and powerful note-taking machines.