Mac Hardware forum


Hard disk failing

by AHornb / February 2, 2013 8:39 AM PST

Hello everybody,
My computer started having problems this morning.
I have a Macbook Pro Unibody from 2008 running Lion (the first unibody that came out) with 320 gb hard disk and 4gb RAM.

Yesterday, everything was doing just fine, I put on some music before going to bed and set up an app called iTaf to stop iTunes automatically after an hour. I didn't ask it to shut the computer down though.
When I woke up this morning, my computer was stuck on a grey screen and was completely unresponsive. I could'nt do anything else but force shut it down with the power button.
After rebooting, my computer was extremely sluggish and was pretty much unresponsive. I force shut it down a couple of times (it wouldn't shut down properly), but the problem was remaining.
I tried starting it up in safe boot mode, but after 2 hours, my computer still hadn't booted and the loading circle kept spinning.
Now, everytime I turn my computer on, I still have the safe boot mode screen (grey screen with the circle spinning and the loading bar filling a little bit, then disappearing and the circle keeps spinning, without anything else happening) and it won't reboot like it did before I started safe boot mode.
I ran Disk Utility through Internet recovery (I don't have a Super Drive anymore) and it says that everything's ok with my hard disk. Mackintosh HD is not mounted though and locked (I have Filevault enabled). When I try to unlock the drive, it won't accept my password (I have an azerty keyboard and the layout was set to US. I changed it back to French, but it still won't accept my password, probably because it contains the letter " a " with an accent on it (I'm apparently only allowed to type english characters here) and the french layout doesn't kick in.).
So I tried running single user mode, and when I type in the fsck -fy command, this is what I get:

CoreStorageGroup: :complete IORequest - error 0xe00002ca detected for LVG "Macintosh HD" (E97F03A2-D03C-48C0-85D2-B470539CC780), pv F0B573D5-41D5-42E9-8B1D-7E432E4C99F6, near LV byte
disk1: I/O error.
Invalid record count
(4, 279)
** The volume Mackintosh HD could not be verified completely.
/dev/rdisk1 (hfs) EXITED WITH SIGNAL 8

What is strange though, is that I can still run my computer under guest mode and surf the internet...

I don't understand what's going on, can anyone help me?

Post a reply
Discussion is locked
You are posting a reply to: Hard disk failing
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Hard disk failing
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

Coming soon

Get behind the wheel with Roadshow

Love cars? Climb into the driver's seat for the latest videos, reviews, shopping advice and picks by our editors delivered to your inbox every week.