Computer Help forum

Resolved Question

Google is blocked

by max.skjoldebrand / January 2, 2012 5:45 AM PST

I have a PC (running Windows 7) which I have inherited from someone else and which will not display any Google pages. Every time I try to do a Google search or try to access a Google web page I get a page with some Chinese characters and on the second line "NGiNX my SQL.php" and further down links to www.wdlinux.cn pages. Some time ago I downloaded a troubleshooting program which came up once only with a dialogue box in DOS stating that Google was blocked. The question is how do I unblock access to Google?

max.skjoldebrand has chosen the best answer to their question. View answer
Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Google is blocked
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Google is blocked
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Best Answer chosen by max.skjoldebrand

Collapse -
Google from what browser?
by Coryphaeus / January 2, 2012 6:28 AM PST
In reply to: Google is blocked

If it's a specific browser that's one thing. If it's from all browsers (Chrome, Firefox, IE, etc.) then it's a machine lock. Try clearing cookies, cache, and history on the unknown browser.

Collapse -
Google from what browser?
by max.skjoldebrand / January 3, 2012 12:18 AM PST

It applies to both IE and Firefox. I am unable to download Chrome. I have tried clearing cookies,cache & history but to no effect. How do I deal with a machine lock? Thanks.

Collapse -
I'd Do It This Way...
by Grif Thomas Forum moderator / January 3, 2012 6:23 AM PST

There are a number of ways which a website can be blocked.

1. Try checking your HOSTS file.. It resides in the C:\Windows\System32\drivers\etc folder. Once there, open the "HOSTS" file using Notepad.. (HOSTS will have NO file extension.. It will simply be HOSTS.) Open the file using Notepad.exe and check to see if there is a line indicating 127.0.0.1 google.com.

If it's listed there, simply delete the line, then save your changes and close the file. You'll need to perform these steps as an admin user.

2. Because malware could be causing the issue, if you haven't already, download, install, update, then run a full system scan using the free malware removal tool below. Delete anything it finds.:

Malwarebytes Antimalware

3. Website access can also be blocked by using your router's settings. If anyone but you has access to the router, then you may need to open those settings and check for blocked sites.

Hope this helps.

Grif

Collapse -
I'd Do It This Way..
by max.skjoldebrand / January 4, 2012 3:57 AM PST
In reply to: I'd Do It This Way...

Grif,
Thank you for your advice.<div>I have tried to locate the HOSTS file but found only "Imhosts". I opened this with Notebook but it seemed to be an explanatory statement only. I was accessing this as administrator.
I ran the Malwarebytes Antimalware full scan but it found nothing.
The router should not be the cause because 2 other PCs running off the router have no difficulty accessing Google. And no-one else has access to the router.
</div>Max

Collapse -
Make Sure You're Viewing "Hidden" Files In Folder Options
by Grif Thomas Forum moderator / January 4, 2012 9:17 AM PST
In reply to: I'd Do It This Way..

Hidden, and System files need to be viewed to see HOSTS.

Hope this helps.

Grif

Collapse -
Please Check Proxy Settings Like This
by Grif Thomas Forum moderator / January 4, 2012 9:19 AM PST
In reply to: I'd Do It This Way..

Open Internet Explorer and go to Tools-Internet Options-Connection Tab. Click on the LAN settings button. IF there is a check mark next to "Use a proxy server for your LAN", uncheck it. Click OK. Then OK, again.

Hope this helps.

Grif

Collapse -
Please Check Proxy Settings Like This
by max.skjoldebrand / January 5, 2012 6:52 AM PST

"Use a proxy server for your LAN" was unchecked. It did not help.

Collapse -
Worked, thanks!
by Papa_Dan / October 2, 2014 11:58 AM PDT
In reply to: I'd Do It This Way...

I've had this problem for some time on my XP, SP3 PC.

Your step 1 worked; checking the HOSTS file.

Thank you so much!

My HOSTS file had both google and bing in it.

Once I got around the file extension issue with notepad, it worked right away for both google and bing without re-booting or even re-starting Mozilla Firefox.

I also use and love MBAM. About 5 years ago, I was contemplating buying a new, faster, bigger PC for my office, because everything on it had slowed to a snail's pace.

I was running Norton at the time. On my tech's recommendation, I had purchased Symantec Corporate for all of the PC's in my office (all XP machines); expensive, but things only got worse!

His next recommendation was replacing all of the PC's.

Instead, I tried loading every other anti-virus software known to man (McAfee, AdAware, AVG, Avast, BitDefender, Grisoft, TrendMicro, etc.). Slower yet!

Keep in mind, I'm a businessman, and just want a working tool!

One day, in desperation, noticing that my PC was spending most of it's time running malware, to no benefit, I stopped work and started turning off and un-installing every anti-virus program, including Norton (not an easy task), as well as turning off the Microsoft firewall -- at this point, I was willing to overlook the ubiquitous "Your computer may be at risk" warnings.

It took several days to get rid of everything -- but things started to speed up!

Then, on a recommendation from someone at cNet, I downloaded MBAM, ran a scan, found and purged massive numbers of malware, and things got very fast!

The only problem remaining was slow internet browsing using Internet Explorer (5.0, I think). Tech says upgrade to 7.0; slower yet. Internet provider says to upgrade my bandwidth package -- no help.

So, once again, based on a cNet recommendation, I downloaded Mozilla Firefox -- BAM! Like having a new, incredibly fast computer!

So, I'm still running XP machines in my business -- and would probably have never changed; until Microsoft pulled XP support; and my software vendors are starting to follow suit.

I was wondering where those google and bing HOSTS file entries came from? In other forums, it was suggested that yahoo might have had something to do with it; but there are many "No, no, no" responses, but no actual fix for the problem.

I'm thinking yahoo; how about you?

Thanks again.

Collapse -
Nope, Probably The Malware...
by Grif Thomas Forum moderator / October 3, 2014 4:26 AM PDT
In reply to: Worked, thanks!

There are a number of malware types which "redirect" your searches away from the normal Bing and Google search sites. They are coded so any attempt to access the normal search will immediately take you to their own, advertisement filled, or infected websites. In order to do that, the malware places Google and Bing in you HOSTS file to prevent those sites from being accessed.

Hope this helps.

Grif

Collapse -
Shucks, another good conspiracy theory shot down...
by Papa_Dan / October 3, 2014 4:54 AM PDT

I see.

Too bad MBAM doesn't at least notify you to that situation when it gets rid of the malware.

But now I know where to look if anything like this ever happens again.

Thanks again

Collapse -
Since it is being blocked in both browsers ...
by Edward ODaniel / January 3, 2012 1:05 PM PST

try Griff's advice regarding the HOSTS file and then his advice to run MalwareBytes.

I would then suggest running Super Anti-Spyware

Now, in addition to checking to see if the URL or IP Address is blocked at the router I would suggest that you check your Firewall and also your Anti Virus application as several allow you to block sites. Avast for instance has site blocking available under the heading of Additional Protection.

Since you indicate "Every time I try to do a Google search or try to access a Google web
page I get a page with some Chinese characters and on the second line
"NGiNX my SQL.php" "
my bet is that it is your hosts file or malware. You can double check by seeing if this link gets you to Google (it is the actual IP address of 74.125.93.106 and will bypass the hosts file and most malware)

Collapse -
Since it is being blocked in both browsers...
by max.skjoldebrand / January 4, 2012 4:46 AM PST

Thanks for the additional suggestions. I have run the Super Anti-Spyware. Whilst it detected several tracking cookies, it did not resolve the problem.
The IP address works in both IE and Firefox and allowed me to access Google search. Via the Google search page I installed Google Chrome but it justs shows the page with Chinese characters etc. when opened.

Collapse -
Back to HOSTS
by MarkFlax Forum moderator / January 4, 2012 4:57 AM PST

You should have a HOSTS file.

The location in Win 7 is C:\Windows\System32\drivers\etc

Note, Hosts does not have a file extension. It may be hidden. To unhide it, open Explorer and go to Tools .> Folder options and in the new window, the "View" tab.

Look for these;

Hidden files and folders - select "Show hidden files, folders and drives".
Hide extensions for known file types - De-select.
Hide protected operating system files (Recommended) - De-select but ensure this is selected again after using it.

That HOSTS file should now appear. If it does, open it by right clicking and "Open" then select Notepad.

"BEWARE", if the "Always use the selected program to open this kind of file" is ticked, remove the tick before selecting Notepad.

Open the file in Notepad and look for any entries that mention Google and tell us what you find.

If you want to save the file, be sure to use "Save as" and save it as file type "All files". otherwise it defaults to a txt file and cannot then be used by browsers.

Mark

Collapse -
Back to HOSTS
by max.skjoldebrand / January 5, 2012 6:43 AM PST
In reply to: Back to HOSTS

Thanks for the advice. It worked up to the point where I tried to do the "save as" on the notepad HOSTS file from which I had deleted all the references to Google as per the instructions via "Yep, back to the HOSTS file ... " below, only to find that I "don't have permission to save in this location", even though I was logged in as the only user set up on this computer which is the administrator.
The entries which mentioned Google and which I deleted on the unsaved file referred to 204.152.194.148 several times over followed by various national google and search.yahoo web-sites.

Collapse -
You seem to forget this is Windows XP or later.
by R. Proffitt Forum moderator / January 5, 2012 6:49 AM PST
In reply to: Back to HOSTS

Even the administrator must obey file and folder permissions. There is no God account on the system that will over ride these things.

In a pinch I've booted a Linux Live CD (zero install and no learning linux) to edit this file. Yup, a God mode.
Bob

Collapse -
You seem to forget this is Windows XP or later.
by max.skjoldebrand / January 6, 2012 4:21 AM PST

Thanks. Noted.

Collapse -
Your Browser Must Be Closed When Saving HOSTS...OR...
by Grif Thomas Forum moderator / January 5, 2012 7:48 AM PST
In reply to: Back to HOSTS

..restart the computer into Safe Mode, then make the corrections and save HOSTS from Safe Mode.

Hope this helps.

Grif

Collapse -
Your Browser Must Be Closed When Saving HOSTS...OR...
by max.skjoldebrand / January 6, 2012 4:23 AM PST

Thanks for the advice. I managed to sort it out in normal mode.

Collapse -
Yep, back to the HOSTS file ...
by Edward ODaniel / January 4, 2012 2:08 PM PST

as that is where your problem lies.

Follow the instructions on this link (instructions work for Windows NT through Windows 7)

Pay close attention to ensure you enter spaces where needed in the commands.

http://en.kioskea.net/faq/15289-google-nginx-404-error

You might then want to boot into safe mode and run RKILL then TDSSKILLER (instructions and link here) then your favorite ROOTKIT scanner (just in case) and SOPHOs is a good one:
http://www.sophos.com/en-us/products/free-tools/sophos-anti-rootkit.aspx

Collapse -
Yep, back to the HOSTS file..
by max.skjoldebrand / January 5, 2012 6:15 AM PST

I have tried everything suggested in the link provided but it did not work for me. The right-click after typing cmd in the Search field did not provide me with the option to Run as Administrator. Carrying on regardless, the cmd line had the correct Administrator user ID but after Y after Command 2 and after Command 3 I was getting "access denied". Again carrying regardless, I got the notepad popping up and deleted the entries as directed and went to save it but there are no directions as to where to save it - saved it in the default documents folder. Typed final command 5 and got "access denied". Browser did not provide access to Google.

Collapse -
This is starting to sound like TAMPER PROTECTION is on.
by R. Proffitt Forum moderator / January 5, 2012 6:20 AM PST

Since you are getting access denied I wonder if you need to reveal what security software you run as well as if you tried the edit in SAFE MODE.

Collapse -
This is starting to sound like TAMPER PROTECTION is on. -
by max.skjoldebrand / January 6, 2012 4:25 AM PST

Thanks. Now sorted.

Collapse -
Good work on sorting it out.
by MarkFlax Forum moderator / January 6, 2012 8:02 PM PST

Can you tell us how you did it?

it would be nice to know, and useful for if and when others have similar problems.

Glad it's working for you now.

Mark

Collapse -
Good work on sorting it out. -
by max.skjoldebrand / January 7, 2012 1:24 AM PST

I followed the directions provided by Edward ODaniel above and below.

Collapse -
Nice one
by MarkFlax Forum moderator / January 7, 2012 4:22 AM PST

and thanks for telling us.

Mark

Collapse -
Since the file belongs at ...
by Edward ODaniel / January 5, 2012 8:28 AM PST
c:\windows\system32\drivers\etc that is where you want ot save it - the system cannot use it from your documents folder.

If, for some unknown reason you do not get the option to Run As administrator when CMD.EXE pops up when you type cmd in the search box then try this:

Right click on desktop and choose New then Shortcut. In the window that pops up type CMD.EXE then click Next. Now name it Command Prompt if you want and click Finish. Now right click the shortcut and choose Run As ..

Assuming you did type all the commands and switches properly ownership does override ACLs so giving everyone full permissions can be problematic is ownership is invested in system.

You mention you tried everything in the link -- did you try
http://security.symantec.com/nbrt/npe.aspx?lcid=1033 which is mentioned in that link?
Collapse -
Since the file belongs at ...
by max.skjoldebrand / January 5, 2012 11:47 PM PST

Thank you very much!!
Your solution has worked!
Ownership should not be a problem as there are only two users (using the same user account) and having access to the computer and there are no other users around. However, I will delete the shortcut and reinstate as and when needed.
<div>I did not try the link


http://security.symantec.com/nbrt/npe.aspx?lcid=1033 w

</div>I really appreciate your help.

Collapse -
Ownership can be a problem
by R. Proffitt Forum moderator / January 6, 2012 1:46 AM PST

Since this is XP or beyond even your one account must follow all the rules of the file system.

If you dismissed ownership because there are only two users (using the same user account) then you may have missed out on the fixes offered.

Don't fret it. Many folk learn this lesson this way.
Bob

Collapse -
same here
by nimala3490 / May 1, 2012 9:55 AM PDT

i am having the same problem ... can u please help me too....

Collapse -
How did you get on
by MarkFlax Forum moderator / May 1, 2012 8:05 PM PDT
In reply to: same here

with all the options offered in this discussion?

Mark

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Smartphone tip

Hoarding photos on your phone?

Those picture are hogging memory and could be slowing down your phone.