Please start with the most common setting I change. Here's the phrase I use on google. Do this first.

-> Disable Flash Hardware Acceleration <-