Ahhh... I had to do a bit of research to find out the rest of the story. It looks like HP is not supporting older scanners on newer operating systems - not just macs but Vista too.

I don't know what to tell you. I did find this link that discusses the problem for a variety of older scanners...

http://www.xlr8yourmac.com/feedback/scanners_with_OSX_leopard.html

Your HP is not mentioned, but perhaps some workaround for these scanners will work with yours.

The conclusion I found on several sites is to buy a new scanner or buy the available drivers if they will do the job. I'm not sure how old your HP 5510 is - it looks like HP's strategy is to just make their customers upgrade the equipment.

If you find a solution, please come back and post it.

Bon Chance

grim