MacBooks forum

Question

font error

by bafodelic / March 13, 2013 6:09 AM PDT

I'm not sure how to fix this but my laptop is acting a bit funny. some programs dont have this issues but others do - such as surfing the web, clock, and so on. basically its not in english. its like roman/latin font. and when surfing the web some of script is english & other is latin/roman - something unreadable to me. i checked my font book and everything seems fine. not sure how to fix this.

thanks

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: font error
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: font error
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Re: font
by Kees_B Forum moderator / March 13, 2013 6:19 AM PDT
In reply to: font error

- This is totally unclear, alas. English and Latin are languages, not fonts. Times New Roman is font and a very readable one also). By the way, there is a font called Wide Latin and I'm sure you can read that also. Have a look at https://www.google.nl/search?hl=nl&site=imghp&tbm=isch&source=hp&biw=1280&bih=834&q=wide+latin+font
- Scripts aren't written in English, but in a language called Javascript (or Ecmascript), and their font is totally irrelevant.
- Finally, fonts are in a folder, not in a book.

Can you make a screeprint or picture and publish that on your favorite photosharing site. Then post a link to that picture here, so we can see what's wrong.
And please also tell your OS (Windows what?) and browser you use.

Kees

Collapse -
Sorry, I now see it's Mac.
by Kees_B Forum moderator / March 13, 2013 6:22 AM PDT
In reply to: Re: font

So please read my last sequence as "Please tell your OS (what version of Mac OS) and browser you use.".

And forget my remark about book and folder. Mac-users have their own secret language and it can very well be that 'book' is exactly the right term.

Kees

Collapse -
screenprint
by bafodelic / April 14, 2013 11:41 PM PDT
Collapse -
screen grab
by bafodelic / April 14, 2013 5:14 AM PDT
In reply to: Re: font

sorry about not being clear. i have macbook pro - Os x version 10.5.8

here is a screen grab

<a href="http://tinypic.com?ref=154y4hv" target="_blank"><img src="http://i47.tinypic.com/154y4hv.png" border="0" alt="Image and video hosting by TinyPic"></a>

you can see that some of it is in english but a few lines aren't.

thanks

Collapse -
Answer
Open your Font Book
by mrmacfixit Forum moderator / March 13, 2013 8:17 AM PDT
In reply to: font error

and go to the menu and choose Edit > Look for enabled duplicates.
If it finds any, Fix Automatically.
Close Font Book

Open Safari (I presume you are using it as your default web browser)
Open Preferences > Advanced
Make sure that Default encoding is Western (ISO Latin1)
General Tab
Remove any check mark in Open "safe" files after downloading. (nothing to do with fonts but should be done anyway)

If you are using Safari 6.0 and above, there is no appearance preference to change. It you have one in your version of Safari, set the default font to Times New Roman or Times.

P

Collapse -
Answer
Try this...
by sandman619 / March 14, 2013 11:06 PM PDT
In reply to: font error

A) Font file corruption
B) Missing system font

Open Font Book & have it verify all installed fonts. It will list any font file inconsistencies. If any are system fonts, ie System/Library/Font then reinstall the OS then run System Update until there are no updates remaining. This will cure corrupted font files as well as reload missing fonts. Missing system fonts means that the OS will fall back to another font which can cause the English/Romanian text issue. If this is appearing in the menu bar or window title or any menues, that could be the cause

Cheers !

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Tech explained

Do you know what an OLED TV is?

CNET explains how OLED technology differs from regular TVs, and what you need to know to make the right shopping decision.