Browsers, E-mail, & Web Apps

Resolved Question

Firefox wants to save rather than display PDF's

by N.T.Gray / August 27, 2011 7:44 AM PDT

My Firefox 5 just developed an odd habit. When I click on any link intended to open a PDF document, I get instead a "Save To" dialog box. This weirdness began only a couple of days ago, and I am not aware of doing anything that might have provoked it. (Haven't knowingly installed any add-ons, for instance.) IE8 and Opera both behave normally on this computer. Any ideas what's happening (and how to fix it?). I'm running a Dell desktop with Win7 Home 64-bit.

*

N.T.Gray has chosen the best answer to their question. View answer »
Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Firefox wants to save rather than display PDF's
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Firefox wants to save rather than display PDF's
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Best Answer as chosen by N.T.Gray

Collapse -
Other than John's post
by MarkFlax Forum moderator / August 28, 2011 9:20 PM PDT

is Firefox's PDF reader add-on enabled or disabled?

I had a similar problem the other day and when I checked I found I had disabled the add-on.

Mark

Collapse -
I'll try this next
by N.T.Gray / August 28, 2011 11:12 PM PDT
In reply to: Other than John's post

I did the Adobe re-install that John recommended (which also entailed an upgrade from 9.4 to 10.1). It made no difference. How do I enable/disable add-ons in Firefox?

NTG

Collapse -
Try this.
by MarkFlax Forum moderator / August 29, 2011 4:44 AM PDT
In reply to: I'll try this next

If you have Firefox 4 or upwards, click the Firefox button top left of the browser window then select Add-ons.

Find the PDF Reader add-on and enable it.

Mark

Collapse -
Tried it. Didn't work.
by N.T.Gray / August 29, 2011 7:22 AM PDT
In reply to: Try this.

I found the add-ons section. Adobe Reader 10 was already enabled. I disabled it then re-enabled it. No change.

NTG

Collapse -
Do you get the option
by MarkFlax Forum moderator / August 29, 2011 8:21 PM PDT
In reply to: Tried it. Didn't work.

to Save or Run?

Or do you only get the option to Save?

If you 'only' get the option to save, then head over to Firefox > Options > Options, (yes, 2 Options), then the General tab and tell us what Firefox's setting is for Downloads.

Mark

Collapse -
Looks like an Acrobat "Save As" box
by N.T.Gray / August 29, 2011 10:58 PM PDT
In reply to: Do you get the option

Do you get the option to Save or Run?Or do you only get the option to Save?

My Download options are Show the Download Window. . .Close window when finished downloading. . .Always ask me where to download. But the box I am getting looks like a Save As window from Acrobat, not like a Save or Run box for a normal file download.There's a snapshot of part of my desktop, a field below that for naming the file, and a field below that for choosing the type of file (Acrobat or All Files).

NTG

Collapse -
That;'s very strange.
by MarkFlax Forum moderator / August 30, 2011 6:59 AM PDT

Hi NT.

Well, I'm stumped. Same settings as me but I don't get an Adobe Save As dialog whenever I click on a PDF link.

Can I ask for a link to one of your sites that has a PDF link you are trying to open? I would like to test this for myself.

Thanks.

Mark

Collapse -
Any and all pdf files
by N.T.Gray / August 30, 2011 8:08 AM PDT
In reply to: That;'s very strange.

As a test, I Googled "articles pdf". Every link to a pdf article did the same thing.
My other two browsers behave normally.

NTG

Collapse -
I knew that!
by MarkFlax Forum moderator / August 30, 2011 9:14 PM PDT
In reply to: Any and all pdf files

I could have done that, Google "Articles PDF" ! Happy

So I did that, and found a very interesting PDF about the future of the oil and gas industry!

I tried this a couple of ways. My own Foxit PDF Reader in Firefox enabled, and then that add-on disabled.

Have a look at the image below, it shows both options;
http://imageshack.us/photo/my-images/163/pdfaddon.jpg/
(You may have to use the magnifier to enlarge the image).

Left hand side, add-on enabled, the PDF opened in a Firefox tab. Right hand side, add-on disabled, and I got the "Save dialog".

Points to note, whether relevant or not.

Each time I right clicked the Google entry to select, "Open in a new tab".

The "Save" dialog also has an "Open with" option that defaults to Foxit Reader, (my only installed PDF reader).

Can we compare?

Mark

Collapse -
Found it
by N.T.Gray / August 30, 2011 10:03 PM PDT
In reply to: I knew that!

The solution wasn't in Firefox/options/general, it was in Firefox/options/applications. I found that the setting for Adobe was "save" and I reset it for "use Acrobat Reader (default)". Problem solved. (Have no idea how the setting was changed, of course, but now I know how that works if there are any future problems.)
Thank you for your help.

Nathanael

Collapse -
That's great.
by MarkFlax Forum moderator / August 31, 2011 4:59 AM PDT
In reply to: Found it

And of course I (also) knew about those options! Devil

But I forgot. Glad you have sorted it out, and thanks for reporting back.

Mark

Collapse -
More information
by N.T.Gray / September 1, 2011 10:37 AM PDT
In reply to: That's great.

OK, now I know how my setting got changed, and it appears to be because of a change in Firefox.

I download a lot of pdf files because I manage the web site for my
church. When I get a pdf file in my gmail, the attachment shows with two
choices: View and Download. I click on Download, select the destination
location, and get the file. And when I would view a web site that had a
link to a pdf file, I would just click on the link and the file would
open up. The two different operations didn't interfere with each other.

But now whenever I touch a pdf file, Firefox is remembering and
trying to do the same thing next time. I now seem to have only three
choices: always open the file, always save the file, or always ask which
I want to do (which is what I get if I choose an operation different
from the last one, but do not check the box that says "Always do this
for this kind of file." This never happened until a few days ago, so
something in Firefox must have recently been upgraded.

So Firefox has changed, and I have to live with it unless Firefox 6
doesn't do this. (And I don't want to upgrade from 5 yet because a
warning screen told me that some of my add-ons won't work in 6).

So at least I know why this thing is happening. Now I have to
decide whether I can live with the small hassle, or whether I'll just
move to a different primary browser that doesn't do this.

Nathanael

Collapse -
So thankful you found it!
by tkshane / July 14, 2014 4:08 AM PDT
In reply to: Found it

Hello,

Your suggestion fixed my problem as well. So thankful for these post!!!

You guys rock!

Tk Happy

Collapse -
Answer
Reinstall Adobe Reader...
by John.Wilkinson / August 28, 2011 7:54 AM PDT

The simplest solution is to reinstall Adobe Reader or which ever PDF viewer you prefer. That will cause the browser plugin to be reinstalled, and thus PDFs be able to open directly within your browser.

Hope this helps,
John

Collapse -
Answer
Continued here
by MarkFlax Forum moderator / September 1, 2011 9:47 PM PDT

I've continued from here in reply to your More information post.

I'm not sure Firefox has changed in this respect as the "Application" tab has always been the same, as has download/save options in the General tab. But I won't contradict you as you have been used to things differently in the past.

However this is getting complicated because there are a range of different combinations that can be used here.

For example, email attachments should be different from normal web experience. But again, complications because I am guessing you manage your emails in the web browser, and not using email client software like Outlook, Thunderbird, Windows Live Mail, etc.

What you are doing with email attachments is right in my view. We always recommend saving emails to the hard disk so they can be scanned with the users anti-virus scanner before opening. When using email client software the anti-virus scanner, (if it is set up to scan emails, not all are), only takes a cursory look at the attachment. But when saved to the hard disk, the user can perform a manual full scan with the AV on the attachment. I assume that is the same when users manage emails in a web browser instead of using email client software, and in fact even more so. AV's do not scan web pages unless there is some specific AV Add-on included. This is because the AV scans the browser itself when it is first opened, then leaves it alone because it has done its job.

All that just to say, when you download a PDF file from an email, the file is then on your hard disk and not in the web browser. So when you open that file it should be opened by whichever application has been associated with .pdf files. I think that application is Foxit PDF Reader in your case. Note, I don't mean Firefox's Foxit Add-on, I mean the Foxit application itself which is installed on your system as a separate application.

So Firefox should not be involved in what you do with PDF files saved to hard disk from an email. The only way it might be involved is if Win 7's file association is set to use Firefox to open these PDF files. Whilst that is possible, it is not normal. PDF files on the hard drive would normally be opened by a stand-alone PDF reader application.

I have just tried this and get strange results. I downloaded any PDF file from a Google search to my hard drive. I scanned it, as normal, then clicked to open, (on my system I only need to click once, not twice). Foxit Reader opened to display the PDF file as expected. I then closed Foxit and right clicked this PDF file and selected "Open with". The Open With dialog opened and only Foxit displayed. I had to 'browse' to find another option and navigated to the Firefox folder and chose Firefox.exe. (I made absolutely sure that the option to "Always use this application to open this type of file was not ticked). Firefox then opened, (in fact a new tab because it was already open), and then Firefox offered me the choice of opening with Foxit, (the add-on), or Saving the file. That makes sense because Firefox treated this file as data from the network, usually the internet but in this case from source 127.0.0.1 which is the 'local computer'. I selected Open with and the PDF file then displayed in the Foxit application, not in the Foxit Add-on. How do I know that? I could move the Foxit window around independent of the browser window.

That confused me until I realised that I had not enabled the Foxit add-on in Firefox. When I enabled that, and tried again, the PDF opened in the new tab.

You can see how complicated this is, and I haven't even touched on the download options or the applications tab yet.

Now, in the Applications tab, when you highlight PDF files, (I have two entries for those), you get a choice of options from "Always ask", to "Save file", to "Use other...". The "Other" seems to offer which application to open with.

I assume that if you select "Use other..." and then Foxit, then any PDF file will open in the browser window, unless the Foxit add-on has been disabled, in which case the Foxit application will be opened to display the PDF.

But just to confuse this, the download options in the General tab may have an effect. If you select "Always ask" for downloads, but also select "Always ask" in Applications, does Firefox then ask twice? I don't know.

I'm not sure Mozilla, the makers of Firefox have thought these combinations through properly, but that is not only confined to Firefox as I suspect all browsers have this problem.

I'm not sure what else I can say except, 'sorry for the long and confusing post', and "Try all combinations" until you get it right for yourself.

I hope that helps.

Mark

Collapse -
Answer
Same problem - different solution
by Lilica9 / January 4, 2012 8:53 PM PST

Click Firefox > Preferences > Applications > Content file: PDF file ; Action --> click on the onglet and switch to "always ask"

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech Tip

Know how to save a wet phone?

It's not with a dryer and it's not with rice. CNET shows you the secret to saving your phone.