go to NoScripts options (Options button and "Options" at top of menu) >
"Notifications" tab and uncheck the "Show message about blocked scripts"
_