Mac OS forum

General discussion

external drive will not mount

by ennui1ross / January 18, 2010 10:30 AM PST

Os 10.4.11; G4.

External drive recently stopped mounting on desktop. Does not matter which user account is tried.

Any suggestions as to what to check?


Post a reply
Discussion is locked
You are posting a reply to: external drive will not mount
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: external drive will not mount
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
No, it does not matter,
by mrmacfixit Forum moderator / January 18, 2010 9:02 PM PST

which account is used.

Unplug the drive from whatever port it is connected to and plug it back in.


Collapse -
try all of the ports,
by rnauth1418 / January 18, 2010 10:37 PM PST

Look under the system pro filer and ensure that your USB connections are recognized and operational. If not then the system will not be able to mount anything. You may also be dealing with a dead drive or external drive controller.

Another quick test of the ports is to use another drive in that port and see if it is recognized by the computer. Post what happens and I'm sure we can further diagnose the problem.

Collapse -
mounts on different computer
by ennui1ross / January 19, 2010 6:39 AM PST
In reply to: try all of the ports,

I should have added some initial info.

Os 10.4.11
G4 dual PPC
2g ram
using firewire connections

I tried what was suggested by using a different port but same result happened. Connected the external drive to a "back up computer" and it mounts with no problems. It is an older machine so maybe the firewire interface is bad(?).

Thanks for the replies!

Collapse -
Try this,,
by mrmacfixit Forum moderator / January 19, 2010 8:43 AM PST

Shut down the G4 and remove ALL the peripherals from it, including the keyboard and mouse.

Remove the power cord too.

Open the side and remove the battery.

Press the ON button on the front of the G4
Go get coffee for 30 minutes
Press the CUDA button, it's next to the battery holder and looks like a small metal square with a rubber tip in the middle. Press it ONCE
Reconnect the Power cord and keyboard/mouse
Power it up
When fully booted, connect the Firewire device and power it up.

Did it mount?


Collapse -
cuda switch
by ennui1ross / January 23, 2010 4:27 AM PST
In reply to: Try this,,

I had tried the cuda switch before but not with everything unattached. That must have done the trick as it now mounts.

Thanks for all the suggestions!

Collapse -
Here's what you did,
by mrmacfixit Forum moderator / January 23, 2010 6:02 AM PST
In reply to: cuda switch

by removing the battery, all peripherals and the power cord, you shut off all supply of power to the logic board.
By pressing the power button, you discharged the start capacitors.
Leaving for a while allowed all the remaining capacitors to drain.
Pressing the CUDA button in this state, zapped the the power manager.

With power resupplied, the system was forced to reload everything from Firmware and start afresh.

Pleased it worked for you


Collapse -
cuda switch and external HDs
by BrianRachocki / May 30, 2011 8:53 AM PDT
In reply to: Here's what you did,

would this also affect the mounting of an iPod Shuffle? it won't show up in iTunes or on desktop, mounts just fine on a Win7. I've had trouble getting an old iriver HD-based MP3 player to mount on it, to the point of giving up.

PowerMac G4 350, with processor aftermarket upgraded to 1GHz, 2GB memory, OS 10.4.unsure

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions


Having Wi-Fi troubles?

From the garage to the basement, we blanketed every square inch of the CNET Smart Home with fast, reliable Wi-Fi.