No, 10.6 will not work on ANY eMac. The eMac line never made the transition to Intel CPUs (thankfully) and 10.6 dropped all support for PPC CPUs. PPC systems, like your eMac reached the end of the line at 10.5.