Windows Legacy OS

General discussion

Dual Monitor, Programs Opening in Wrong one

by dangerlarson2 / July 17, 2008 10:31 PM PDT

I recently set up dual monitors which has been such a help in my work, but a somewhat annoying feature is that my firefox and a few other programs insist in opening in the wrong monitor.

I've tried closing them from the correct one, maximizing & closing, saving session (in FF), and other things but I'm out of ideas. You all have any?

Post a reply
Discussion is locked
You are posting a reply to: Dual Monitor, Programs Opening in Wrong one
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Dual Monitor, Programs Opening in Wrong one
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Not a native feature of XP.
by R. Proffitt Forum moderator / July 17, 2008 10:33 PM PDT
Collapse -
But how does windows decide?
by dangerlarson2 / July 17, 2008 10:43 PM PDT

Seen that utility & might give a try. My question is that if it were opening all windows in one monitor or the other, then I could understand. However, it arbitrarily opens some software in one and other programs in the 2nd monitor. How is XP deciding? Any way to control this?

Collapse -
The OS uses the "default" monitor.
by R. Proffitt Forum moderator / July 17, 2008 11:00 PM PDT

If a program decides it wants to be elsewhere it can ask to go there. Just to rephrase, not a feature of the OS, there are no controls exposed to control this and if a software title doesn't offer such then it is what it is.

I wonder if you were looking for some "hidden" feature?
Bob

Collapse -
But the monitor in question isn't my default
by dangerlarson2 / July 17, 2008 11:27 PM PDT

Looking at display properties and the monitor that it keeps trying to load FF and a couple other programs onto is Monitor 2 (vga usb). This one is not checked as primary.

Monitor 1 is my plug and play monitor, and primary monitor is checked.

Collapse -
Then swap them.
by R. Proffitt Forum moderator / July 17, 2008 11:43 PM PDT

There is nothing amiss here. You can try battling with it by changing which monitor is default in the BIOS and other things but after watching too many spend weeks on this I think tools like Ultramon are best.
Bob

Collapse -
Strange, because it works for me.
by MarkFlax Forum moderator / July 17, 2008 11:38 PM PDT

I also have a dual monitor setup, and what you want seems to work with me.

For example, if I have this FF window open on the primary, (default), monitor display, I then drag it across to the secondary, minimize it, re-display it from the taskbar, and close it down. The next time I open FF it opens in the secondary display, and it will do that the next time, even if I have rebooted the computer in between times.

I can't recall that I made any particular changes to settings, but checking my Display Properties I do see an unusual thing, shown in the image link below;
http://img176.imageshack.us/img176/5555/2monitorspq6.jpg

What I see is the Primary monitor on the left, (monitor 1 highlighted in the left image), and the secondary monitor on the right, (monitor 2 highlighted in the right image), and where it says "Display" with the drop down selection box, monitor 2 is listed as default.

That surprises me, as that 2nd monitor is not the default. If I deselect the 2 monitor display and return to a single monitor, it is Monitor 1 that I use, and that is what I would call the default monitor.

So, it seems what you want is possible, I just don't know how to achieve it.

Mark

Collapse -
by EnigmaV8 / July 23, 2008 4:43 AM PDT

The "Default" you are seeing on Monitor 2 is simply the driver name. There is no specific driver installed for that monitor and Windows is simply using the "Default" monitor driver which is a generic one. This has nothing to do with the monitor being primary or not.

Collapse -
(NT) Yep, that makes sense.
by MarkFlax Forum moderator / July 23, 2008 5:19 AM PDT
In reply to:
Collapse -
ALL you guys are looking at this wrong
by MTOakey / February 11, 2009 10:54 AM PST

This is an issue with XP (has been for years but M$ refuses to fix), permissions (Registry) are such that the app (FF) is allowed a change to be made to a secondary display (2) but not allowed to be changed back to primary (1). The ONLY thing that has and will work is to open 'Display Properties', 'Settings' tab, and click on (2) then DESELECT "Extend My Windows Desktop..."
Then you can open the app up and it will open on the (1) Primary (not Default), then you can go back into 'Display Properties', 'Settings' tab, and click on (2) then SELECT "Extend My Windows Desktop..." and all will be right in the world once again...

Collapse -
THIS WORKS!!!!!!!!!!!!!!!
by dynasty21021 / May 15, 2012 8:01 AM PDT

THIS IS THE SOLUTION TO YOUR PROBLEM! Thought I'd be a good guy and save everyone else from reading any further. I had the same problem and this solved it. LOOK NO FURTHER!!!

Collapse -
Works!
by RevStranger / August 20, 2013 8:56 AM PDT

This worked perfectly thank you!

Collapse -
pointless web sites
by Robert Branchflower / August 2, 2009 5:08 AM PDT

Not knowing if I'll EVER see an answer to this, why is it that every time I ask the net for help, all I ever see is other peoples questions and NEVER any answers.

Collapse -
I can tell you why.
by R. Proffitt Forum moderator / August 2, 2009 6:21 AM PDT
In reply to: pointless web sites

Because there is no feature in Windows to accomplish this. Look at the properties of the .exe and no where do you see "show this on the second display at this location."

It's not a pointless question. It's not a feature.
Bob

Collapse -
Try this
by cody55419 / September 16, 2009 12:47 AM PDT
In reply to: I can tell you why.
http://discussions.virtualdr.com/showthread.php?t=235877

Firefox is notorious for this. It sometimes works for other applications.

The only thing pointless are the responses from R.Proffitt. Look at the properties of the .exe? Are you kidding me? Instead of helping you just throw out these ridiculous responses.
Collapse -
I read your link.
by R. Proffitt Forum moderator / September 16, 2009 12:52 AM PDT
In reply to: Try this

And while that trick works it does not on all applications.

Thanks for fixing one app but why are you not supplying a fix for all applications?

Thanks but as a programmer and more I know why this is so.
Bob

Collapse -
Works for me too, sometimes.
by MarkFlax Forum moderator / September 16, 2009 3:00 AM PDT
In reply to: Try this

I use a dual monitor and that method works for me too, sometimes.

But then, I boot up my system, open FF, and 'bingo', it's back on the primary monitor.

So thanks, but your link is what I already knew, and it fails sometimes, works sometimes.

Since this is not a feature of Windows, something Bob has attempted to explain, then only the programmers can force this issue in their executables or DLLs.

Sorry you can't see that.

Mark

Collapse -
How I Fixed It
by jorlwebb / June 15, 2010 11:28 PM PDT

I had this exact problem too. I've fixed it twice now.
1. Go to Display Properties > Settings and uncheck the "Extend" box for monitor 2.
2. Shutdown the computer.
3. Disconnect the monitor from the back of the computer.
4. Startup the computer with just the one monitor.
5. Once in Windows, open the program you were having this problem with. For good measure, press the min-max buttons. Don't know if this is all necesary but it works.
6. Shutdown the computer again
7. Reconnect the 2nd monitor and startup the computer again.
8. Once in Windows, open your program again.
9. Go to Display Properties and re-extend your desktop to the 2nd monitor.
10. Close your program and re-open it. It should open in monitor 1, not 2. The crux is never maximize a program in monitor 2 or it will always open there by default.

Collapse -
How I Fixed It
by Spike_Mike / December 2, 2010 12:42 PM PST
In reply to: How I Fixed It

I found the Actual Multiple Monitors. It's helped me solve some problems with my dual monitors...
1. I set configuration for all programs manual (move to # monitor at startup, change position and etc).
2. Games and fullscreen videos don't minimizing if I using other monitor for any needs.
3. Mouse pointer don't moves over a game window borders.
4. I have the unique taskbar on both monitors (with start button, clock, system tray and etc.) And also all Windows 7 features works greatly on second monitor.

You may read following article:
http://www.actualtools.com/articles/detail.php?ID=1263

Collapse -
Just a couple of notes
by MarkFlax Forum moderator / December 2, 2010 7:15 PM PST
In reply to: How I Fixed It

I would have deleted this as spam, (to a discussion that is now over 2 years old), but I thought the app worth a look.

But then I saw that this is a "Try before you buy". Shame about that.

Mark

Collapse -
spam
by Spike_Mike / December 5, 2010 12:05 PM PST
In reply to: Just a couple of notes

I just find some information about multiple monitor. When I browse this topic I decided to tell "how I solved this problems".

Any work will payed, I think. And develop a software too. If I want use a good software, I must pay for this, I think.

Collapse -
This is a common form of spam.
by R. Proffitt Forum moderator / December 3, 2010 12:53 AM PST
In reply to: How I Fixed It

When you see an old discussion dug up and some APP FOR SALE talked up, BEWARE that the post may be ungeniune and just another SPAM.
Bob

Collapse -
IT WORKS
by tiger094 / September 11, 2012 2:30 PM PDT

The answer given works. I have Windows 7 on my computer. When I hooked up the hdmi cable to my tv to watch movies and opened FF, it would open on the tv screen, not the computer. I had the Computer set as display 1 and extended display selected. After reading the answer, I went to control panel, display, change display settings, and in the multiple displays field selected show desktop on display 1 only. I selected OK, and it made the temporary change. I opted to revert back to extend display. (I did not select apply changes). When I opened FF it opened on the computer display like I want it to. Success!!!!!.

Collapse -
For Nvidea cards you can use the nView hotkey to move window
by hayder78 / August 25, 2013 5:33 AM PDT
In reply to: IT WORKS

I solved it by making a hotkey in the nView (you can find it in the control pannel -> Hotkey) to move the current window to the next display.

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech Tip

Tired of your tricky Wi-Fi password?

Stop trying to memorize a complicated sequence of numbers and letters. Learn how to change the default password.