Windows Legacy OS forum

Resolved Question

Disable WMP CD autoplay when WMP is open?

by jack6128 / April 13, 2013 7:23 AM PDT

Hi, new here. Searched but could not find answer, so signed up here.

I just reinstalled XP Home and downloaded all MS updates, including WMP 11. I used Tweakui to disable autoplay for the CD drive and also instructed XP to "Take no action" for all options in the properties dialog box for this drive. This works fine as long as WMP is NOT open. I can insert a music CD in the drive and nothing happens, which is what I want. However, if WMP IS OPEN, it plays the CD when it inserted into the CD drive. I unselected all options making WMP the default player for all devices and files types, but could not prevent WMP from playing a newly inserted CD.

To summarize, is there a way to prevent autoplay WHEN WMP IS OPEN? Is there any hope, or am I stuck with this bahavior?


jack6128 has chosen the best answer to their question. View answer
Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Disable WMP CD autoplay when WMP is open?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Disable WMP CD autoplay when WMP is open?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Best Answer chosen by jack6128

Collapse -
Did you try?
by R. Proffitt Forum moderator / April 13, 2013 8:07 AM PDT

Did you try the following?

1. Hold the shift key to prevent the auto launch?
2. Disable AIN as well as AUTOPLAY?

Collapse -
Disable WMP CD autoplay when WMP is open? -- SOLVED
by jack6128 / April 13, 2013 12:04 PM PDT
In reply to: Did you try?

Your suggestion to disable AIN lead me to the solution. XP requires a registry edit to accomplish this. I googled <turn off auto insert notification xp> until I found the solution. I can't post the link, but if you google:

<disable auto insert notification or equivalent service in Windows XP PC Review>

... the first link will take you to it.

It is accomplished by changing the value of DWORD "autorun" at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom from 1 to 0.


Collapse -
Thanks for the report.
by R. Proffitt Forum moderator / April 13, 2013 12:33 PM PDT

And keep that note handy in case you need to turn it back on.

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions


CNET bought a house!

Take a look inside the house where we will be testing connected locks, thermostats and other smart home products so we can tell a complete story.