Windows Legacy OS forum

General discussion

Desktop not booting properly.

by Othniel327 / December 27, 2012 7:58 AM PST

I'm new here, but maybe you folks could be of some help. I'm at my wit's end and ready to reinstall windows (although I hate to do that).

My problems began last Friday. I had shut down my computer Thursday night without a problem, but upon turning it on Friday morning, I found that my desktop did not completely load. What I mean by this is that my background and regular program icons would show up properly, but the system tray (I think that's what you call the little area in the bottom-right where icons show next to the clock) was missing a couple icons, including the one for my internet connection. Furthermore, I could double-click on a program, but it would not open. After so clicking on any program, I could not click on anything else, the entire desktop area freezing up. The only thing I could get to work in any way was Task Manager (through hitting control + alt + delete), although this behaved sluggishly and would freeze up. I tried restarting and then shutting down my computer through Task Manager, but nothing happened after about 2-3 minutes, so I hit the power button to turn it off.

I thought that was odd and rebooted. Same result. I then rebooted in Safe Mode (in which my computer ran without problem!) and ran a scan with Microsoft Security Essentials and downloaded, updated, and ran Malwarebytes. Both programs came up clean. I also opened up the case and blew out the inside, just to make sure it wasn't dust. At this point I figured why not try a system restore, so I restored my computer to a restore point form a few days previous. After this, my computer rebooted and worked just fine for 30-45 minutes before completely freezing. I've tried rebooting many times, going into Safe Mode (in which my computer continues to work without issue), and using 4-5 different restore points, the earliest of which was all the way back to December 3. All to no success.

Eventually, I purchased, downloaded, and ran Uniblue Registry Booster because the program was recommended to me by a family member. It found many registry errors and fixed them. I then rebooted, with no result (I was still missing icons). After this, I have been able to use the "restart" and "shut down" commands in Task Manager, but it takes a good 10-15 minutes for the processes to finish and actually restart or shut down the computer. This evening, I just did another restore point back to Tuesday (Christmas day) during the evening of which my computer worked for about 30 minutes after the December 3 restore point. After this, it did not load properly as it had before after doing previous system restores. I'm not sure what else I can do from here aside from reinstalling windows. If I could, I would purchase a new computer, but I cannot afford to at the moment.

Please help if you can. Happy

Post a reply
Discussion is locked
You are posting a reply to: Desktop not booting properly.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Desktop not booting properly.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Try checking for corrupt files
by wpgwpg / December 27, 2012 8:09 AM PST

You can check for corrupted system files. Open an administrator command prompt and run SFC if the above doesn't help. Click START, then type CMD in the search box, right-click CMD.EXE and click Run as administrator. Then from the command prompt type sfc /scannow.
I have to caution you against running programs that fool with the registry. They don't help and can cause problems. They are snake oil.
If all else fails, you can check the rather cryptic system event log. To do that click Start -> Control Panel -> Administrative Tools -> Event Viewer. Once in Event Viewer click on the system log and scroll through the entries looking for those flagged "error" to see if you can find hints as to where the problem could be.
When you get your system back in good working order, I urge you to back your system up to an external hard drive and make regular periodic updates to it.
Good luck.

Collapse -
Re: Try checking for corrupt files
by Othniel327 / December 27, 2012 9:53 AM PST

Thanks for the reply.

I tried what you said. I clicked START and typed "CMD" in the search box, but found three different "cmd.exe" programs. One in my "C:\windows\$NtServicePackUninstall$" folder, one in my "C:\windows\system 32" folder, and one in my "C:\windows\ServicePackFiles\i386" folder. I selected "Run as" and picked administrator. All three gave me the same error message: "A device attached to the system is not functioning." I then went to START, and clicked "Run" where I typed in "cmd.exe" which brought up the program "C:\WINDOWS\system32\CMD.exe." There I typed "sfc /scannow" with the following result:

"The specific error code is 0x000006ba [The RPC server is unavailable.]."

I also looked through my event viewer log as well, and there are a ton of error messages and information messages, but I have no idea what they all mean.

Some of the error messages say "The following boot-start or system start driver(s) failed to load:

There's another that says "The Computer Browser service depends on the Workstation service which failed to start because of the following error: The service has returned a service-specific error code."

Another that says "The Workstation service terminated with service-specific error 2250 (0x8CA)."

Another that says "Could not load RDR device driver."

There are other similarly-phrased error messages as well going all the way back to 12/14.

Collapse -
You've got a lot of things not starting
by wpgwpg / December 27, 2012 10:07 AM PST

I think the first thing I'd do would be to save any data I didn't want to lose because it appears that some basic system functions are failing to start properly. Since you say things seemed to run OK in Safe Mode, I think the next thing to try would be a clean boot. To do this get into Safe Mode, then press and hold down the Windows key and press R. Type in MSCONFIG and hit enter. Click the Startup tab. You can uncheck everything except your antivirus program, then reboot. If this fixes your problem, you can go back and check your startup programs 2 or 3 at a time to see which one(s) is the culprit.
If that's no help, then I'd look to see if you can restore your computer to factory settings. That's preferable to reinstalling because it restores your drivers and any programs that came pre-installed on your computer. Of course if you don't have what you need to do that, you'll have to reinstall. If so, be sure to download all the drivers you'll need first.

Good luck.

Collapse -
Re: You've got a lot of things not starting
by Othniel327 / December 27, 2012 10:52 AM PST

Unfortunately, I'm having no success here still. The desktop boots up, but everything still freezes. It must be a program more important than the ones I unchecked (which was everything except Microsoft Security Essentials). If I understand what you've had me doing correctly, it sounds like it's some program that is integral to the start-up in normal mode that's malfunctioning?

I've already saved all of my documents and files that I don't want to lose onto an external hard drive. About two years ago, I had a different problem (what it was escapes me at the moment) where a restoration to factory settings did not solve the problem, and I had to reinstall windows at that point (and lost several programs). I'm guessing I'll have to reinstall windows from scratch this time as well because of that.

Collapse -
More things you COULD try
by wpgwpg / December 27, 2012 11:15 AM PST

Somewhere you'll reach the point of diminishing returns where it would be easier to just go ahead and reinstall, but here's a couple mores things you could try. First you could run CHKDSK and let it check for and attempt repair of any bad sectors. If you have bad sectors, reinstalling isn't going to fix the problem. The other thing you could do would be to try going into MSCONFIG again and this time click Services. Then check the box that says Hide all Microsoft services. There you can uncheck everything except things from your computer manufacturer and your antivirus. Just be sure you make a note of what you unchecked so you can turn them back on if need be.

Good luck.

Collapse -
Re: More things you COULD try
by Othniel327 / December 27, 2012 11:40 AM PST

I'll do that, while I'm doing that, I figured I'd mention something that just happened. After rebooting to normal mode to see if your last suggestions did anything, I hit "restart" from the Task Manager, and it did...10 minutes later. I'm not sure what this means, of course, but I thought it was interesting.

Collapse -
by Othniel327 / December 27, 2012 12:38 PM PST

All right, so I ran checkdisk and it didn't seem like anything popped up, but the program automatically exited really fast after the scan was complete.

After that, I went into MSCONFIG again, hid all microsoft services, and unchecked everything else. There was nothing left in the list from the manufacturer, and I didn't find my antivirus in the list (Microsoft Security Essentials), so maybe that was hid when I checked "Hide all microsoft services."

It seems to be working at the moment. I have been able to open and close a few programs.

Collapse -
Did you run chkdsk?
by R. Proffitt Forum moderator / December 28, 2012 12:20 AM PST
In reply to: After CHKDSK

Or did you open a command window and type in the command?

If you just ran chkdsk from the start button, it will just exit really fast.

Collapse -
:True, but often CHKDSK makes you reboot
by wpgwpg / December 28, 2012 12:42 AM PST
In reply to: Did you run chkdsk?

so you have no choice but to run it from a fresh boot.

Collapse -
Depends on the options.
by R. Proffitt Forum moderator / December 28, 2012 12:52 AM PST

CHDKSK with just C: will do the check but not repair. So this is one of those areas where details matter.

Collapse -
No big deal but I suggested the repair
by wpgwpg / December 28, 2012 1:20 AM PST

in my 12/27 post. I guess if you wanted to be certain of seeing the output from CHKDSK, you could direct the output to a file or boot to the command prompt. Details, details, details, ... Happy

Collapse -
by Othniel327 / December 28, 2012 2:31 AM PST

All right, so the computer is still working in normal mode with everything but microsoft services and startup programs unchecked (via msconfig). Also, this time I opened a command window and typed chkdsk to run it. At the end it didn't auto-exit, but I got this result:

Stages 1 and 2 went okay, but after stage 2:

"Deleting index entry 938B6d01 in index $I30 of file 65607.

Errors found. CHKDSK cannot continue in read-only mode."

Is there a way to run it NOT in read-only mode?

Collapse -
In response to your last post,
by wpgwpg / December 28, 2012 2:50 AM PST

...I had to respond here because it said "of the depth of this thread". Pickey, pickey! Mischief I believe it runs in read-only mode when you leave off the "/r /f" operands. Try entering the command as chkdsk /r /f and see if that doesn't work.
Good luck.

Collapse -
Ran CHKDSK again
by Othniel327 / December 29, 2012 4:28 AM PST

All right, so I ran CHKDSK again. Set it to run upon restart and rebooted my computer this morning. CHKDSK took about two hours to get through, I think. I found the results in the event viewer under "winlogon."

Here's what it said in the description:

Checking file system on C:
The type of the file system is NTFS.

A disk check has been scheduled.
Windows will now check the disk.
Cleaning up minor inconsistencies on the drive.
Cleaning up 2406 unused index entries from index $SII of file 0x9.
Cleaning up 2406 unused index entries from index $SDH of file 0x9.
Cleaning up 2406 unused security descriptors.
CHKDSK is verifying Usn Journal...
Usn Journal verification completed.
CHKDSK is verifying file data (stage 4 of 5)...
File data verification completed.
CHKDSK is verifying free space (stage 5 of 5)...
Free space verification is complete.
CHKDSK discovered free space marked as allocated in the
master file table (MFT) bitmap.
Windows has made corrections to the file system.

151332299 KB total disk space.
111541948 KB in 144874 files.
73304 KB in 17788 indexes.
0 KB in bad sectors.
515499 KB in use by the system.
65536 KB occupied by the log file.
39201548 KB available on disk.

4096 bytes in each allocation unit.
37833074 total allocation units on disk.
9800387 allocation units available on disk.

Internal Info:
e0 b5 05 00 6e 7b 02 00 20 c1 03 00 00 00 00 00 ....n{.. .......
71 06 00 00 06 00 00 00 c5 13 00 00 00 00 00 00 q...............
fc 8e 93 13 00 00 00 00 0c fd 50 73 00 00 00 00 ..........Ps....
22 8a 08 64 00 00 00 00 36 29 7c 1e 0b 00 00 00 "..d....6)|.....
b0 d0 cc 22 03 00 00 00 04 d4 4b 31 0f 00 00 00 ..."......K1....
99 9e 36 00 00 00 00 00 38 3e 07 00 ea 35 02 00 ..6.....8>...5..
00 00 00 00 00 f0 fa 97 1a 00 00 00 7c 45 00 00 ............|E..

Windows has finished checking your disk.
Please wait while your computer restarts.

For more information, see Help and Support Center at

So, no bad sectors. I take it that's a good thing?

Collapse -
No bad sectors is good but...
by wpgwpg / December 29, 2012 4:39 AM PST
In reply to: Ran CHKDSK again

The fact that your file system was so messed up is a concern. You've got something on that computer that's doing a job on your file system, so until you can find out what's doing that, I'd run chkdsk often. No need to check for bad sectors again, so it should run in a couple of minutes. If you run it from an elevated command prompt under Windows, you won't have to reboot either.

Good luck.

Collapse -
by Othniel327 / December 29, 2012 4:56 AM PST

Two more questions then:

What's the next step, start enabling programs on startup one-by-one to see which one is causing the problem?

Also, how do I run chkdsk from an elevated command prompt?

Collapse -
:Elevated command prompt
by wpgwpg / December 29, 2012 5:19 AM PST
In reply to: Re

To run the elevated command prompt, click Start and type CMD in the search box. Then right-click CMD.EXE in the Programs list and click Run as Administrator.
Re chkdsk I thought you were running with startup programs disabled when you ran that last one; no? You've also got corrupt files that SFC wasn't able to correct, right?
One other thing is your video. Since you have a discrete video card, did you go into the BIOS setup and disable any onboard video? If not, that can cause conflicts and should be done.

Collapse -
My advice is to stop now.
by R. Proffitt Forum moderator / December 29, 2012 11:03 AM PST

After a run in with the ZeroAccess rootkit your posts are setting off alarm bells.

1. Be sure you are ready for a total system meltdown. That is, if this drive vanished, are you ready?

2. With step one out of the way, the fastest test I know of for this one is RKILL noted by Grif at this link.;msg5099421

3. After we are sure there are no infections, and our files are safe, then back to chkdsk.

Collapse -
Re: My advice is to stop now
by Othniel327 / December 30, 2012 6:15 AM PST

Well, we might be at total system meltdown now, heh. Luckily I have saved all of my word documents, save files, etc. that I need to keep on a WD passport, so I'm good as far as that goes.

I was going to try the elevated command prompt stuff today, but after turning my computer off for a few hours this morning, it won't even load BIOS correctly now. It gets about 2/3 of the way through the white loading bar and freezes. I also have diagnostic lights 1 and 4 showing. It also did not beep at all while trying to load.

I tried Google and found this but it doesn't have the 1 and 4 combination.

I found one person here that said it means "Fatal system board failure detected" which doesn't sound good at all.

I'm not sure what to do next.

Collapse -
New update
by Othniel327 / December 30, 2012 6:55 AM PST

I let it sit for a while and tried again and it started up okay this time. Still not sure what to try next. Could it be a bad motherboard?

Collapse -
Or old.
by R. Proffitt Forum moderator / December 30, 2012 7:35 AM PST
In reply to: New update

As the parts pass about 5 years, strange things like this happen.

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions


Having Wi-Fi troubles?

From the garage to the basement, we blanketed every square inch of the CNET Smart Home with fast, reliable Wi-Fi.