Computer Help forum

General discussion

Desktop icons taking a long time to appear

by Jinxmchue / April 19, 2009 6:38 PM PDT

My computer is about 5 years old, runs XP and has current anti-virus software that is used regularly.

Less than a year ago, my computer started having a problem after restarts. The desktop background would come up normally (though possibly a bit slower than normal), but the icons would take between 1-2 hours to appear. Using the msconfig command, I shut off Services a few at a time in alphabetical order and restarted until I was able to narrow it down to one: the DHCP Client. When I disabled that, the icons came up without such a long delay. (I did not continue shutting down Services after that.) However, disabling it prevented me from accessing the internet. Additionally, my computer's performance seems to be down quite a bit even from when I first used the msconfig to track down the issue. Updates that require restarts don't seem to be intact after restarting, either, as I seem to just continue to get the same update notices over and over. Does anyone know what could be causing this and, if possible, how to fix it?

Discussion is locked
You are posting a reply to: Desktop icons taking a long time to appear
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Desktop icons taking a long time to appear
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Just A Thought Or Two...
by Grif Thomas Forum moderator / April 20, 2009 2:17 AM PDT

Based on your symptoms, it appears like you're using a HOSTS file.. If so, please try disabling a the service mentioned here.. Click on Start-Run, type: services.msc, then click on OK.. When the "Services" window loads, scroll to and double click on the "DNS Client" listing. Once that opens, then click on the "Stop" button in the "Service Status" and change the "Startup Type" to "Manual", then click on Apply, then OK. Restart the computer.

Next, try the steps below to toggle the DMA options for your hard drive. Follow the instructions in the link below and make sure to toggle DMA off, then back on again, even if already checked:

http://www.microsoft.com/whdc/device/storage/IDE-DMA.mspx

Once that's done, please follow ALL of the steps in the link below to cleanup your computer:

Cleanup Steps

Hope this helps.

Grif

Collapse -
Confused about the second step
by Jinxmchue / May 11, 2009 7:34 AM PDT
Collapse -
Do This...
by Grif Thomas Forum moderator / May 11, 2009 9:11 AM PDT

To enable DMA mode using the Device Manager

1. Open Device Manager.

2. Double-click IDE ATA/ATAPI Controllers to display the list of controllers and channels.

3. Right-click the icon for the channel to which the device is connected (Perform the steps on both Primary IDE Channel & Secondary IDE Channel), select Properties, and then click the Advanced Settings tab.

4. In the Current Transfer Mode drop-down box, select DMA if Available if the current setting is "PIO Only."

If the drop-down box already shows "DMA if Available" but the current transfer mode is PIO, then the user must toggle the settings. That is:
? Change the selection from "DMA if available" to PIO only, and click OK.

? Then repeat the steps above to change the selection to DMA if Available.


Hope this helps.

Grif

Collapse -
On Windows 2000 and XP
by Cursorcowboy / April 20, 2009 4:33 AM PDT

it's also important to check for unnecessary "Services" that run at start up. Shut them down and the computer should run smoother. Check these links for the "How To":

"This site " or

"This site" or

Note: This site offers a custom download which most users can use. I used it a long time ago after checking its consistency with how I had already configured my services and they were near 100%.

"This site"

Collapse -
Hopefully this helps..
by sri_k / April 21, 2009 8:36 AM PDT

Do you have zonealarm? Try uninstalling it. I had similar problem and after uninstalling zone alaram it worked.

Collapse -
Thanks, all.
by Jinxmchue / April 21, 2009 2:16 PM PDT
In reply to: Hopefully this helps..

I appreciate all the advice. I'm reading through everything, but haven't really had a chance to do it all. I did try out messing around with stopping and starting the DHCP Client after I had a restart today and the icons did come up faster after I did that. Still quite a bit of a delay, but not over an hour as usual. Hopefully that's a sign these things will work. I'll let you know.

Collapse -
You'll Note I Referred to 'DNS Client'..NOT...
by Grif Thomas Forum moderator / April 22, 2009 4:07 AM PDT
In reply to: Thanks, all.

Not "DHCP Client".. They're two different things and yes, disabling the DHCP Client will frequently cause issues with your internet connection.. Disabling "DNS Client" shouldn't cause such issues.

Hope this helps.

Grif

Collapse -
Oh.
by Jinxmchue / April 22, 2009 7:06 AM PDT

Well, nonetheless, it made something different happen!

Collapse -
If it hasn't worked yet..
by sri_k / April 22, 2009 5:44 AM PDT
In reply to: Thanks, all.

1. Bring up regedit in safe mode.
2. Navigate to
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction
3. Set "Enable" to "N".

Please try this out if your problem still exists.

Collapse -
Worked for me - no web.
by MacHesney / February 13, 2012 11:36 AM PST

Running Windows XP SP3 - same problem - an unacceptable 2 minute wait after desktop background appears.

I have a second hardware profile set up, that disables all services requiring a network connection.
No DNS, no TCP/IP, - many services off.

Desktop, icons, taskbar all loaded in TWO SECONDS INSTEAD OF TWO MINUTES.
Narrowed down to ax. 25 network dependent services.

Earlier tried:
Microsoft suggests using msconfig and selective startup - choose Services tab.
No Plug-n-Play and no WIA didn't help.

I also pared the startup list using CCleaner Startup tool.
I also uninstalled last few programs installed and then ran 3BSoft Windows Registry Repair Pro scan.

Network services confirmed to cause long delay.

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Tech explained

Do you know what an OLED TV is?

CNET explains how OLED technology differs from regular TVs, and what you need to know to make the right shopping decision.