Mac OS forum


Date won't show in menu bar

by ritamcbride / March 10, 2012 11:02 PM PST

Good morning Mac Masters,

Once again I need you to help make my macbook 10.5.8 run more efficiently for me.

The time and day appears where I would expect it in the upper right corner of my screen in the menu bar. It appears right before the Spotlight icon at far upper right, and right after my battery level indicator.

The problem is I cannot change the format no matter what I do. Right now, it says "Tue 6:25". I have gone to the International preference pane and tried any number of changes to the date and time formats, but nothing happens. (Originally I wanted to combine the day, short date and time.) No matter what I change, the time reads as above. I also set the preference to 'medium' for the menu bar and that did nothing.

Do you have any suggestions?

Thanks again for your help,


Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Date won't show in menu bar
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Date won't show in menu bar
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Did you
by Jimmy Greystone / March 11, 2012 12:25 AM PST

Did you check the "Show date" option in the Clock tab of the Date and Time settings in System Preferences?

Collapse -
Yes. All checked
by ritamcbride / March 13, 2012 12:02 AM PDT
In reply to: Did you

Hey Jimmy,

Collapse -
by ritamcbride / March 16, 2012 12:44 AM PDT
In reply to: Yes. All checked

Can any of you macmasters help me out on this?

Collapse -
You may have made a typo in your "Yes. All checked" post but
by mrmacfixit Forum moderator / March 16, 2012 8:45 AM PDT
In reply to: Help!

Let's see.
You said:
"Under date & time then under clock I have checked: show date/time in menu bar, view as digital and show day of the week. I get the day of the week and the time but no date."

If what you say is correct, then what you see on the menu bar is correct.
On my Date & Time Control Panel, under Clock, there is one more check box to fill in.
Show date.

Does yours have one of those and is it checked?

I don't have an International under Date & Time but there is something similar, Language and Text preferences. That is only used to format how the date and time is displayed when the date and time functions is turned on, it does not turn the date on or off.

OS X 10.7.3


Collapse -
RE: You may have made a typo in your "Yes. All checked" post


This is the problem you are having: You are trying to use the "Language & Text Preference Panel" to change the appearance of the Menu Bar Clock.
Do not use the "Language and Text" preference pane, since it will have no affect on the appearance of the Menu Bar Clock.

Use the "Date & Time" preference pane instead.
In that preference pane, there will be a second option right under "Show the day of the week" to
"Show the date". Put a checkmark beside that option to show the month and day. It will only display the Short Day and the Short Month, and not the year at all, no matter how you try to change it via the Language and Text preferences. Apple sure missed on this one. Perhaps it will be changed in the next release of OS X, but somehow, I do not expect this to happen any time soon.

If you want to see the Long or Full date, you must use a third-party menu-bar clock, such as "Day-O". It is free, and can be found in the Apple Store. Just click on the "Rocket" icon next to the Finder icon on the Dock. I heartily recommend it to anyone who likes to change the MenuBar clock appearance. Give it a try. I believe you will like it.

Donald Lee McDaniel

Collapse -
RE: You may have made a typo
by Revrag / March 16, 2012 10:32 PM PDT

I was having the same problem with trying to make the date appear and this worked!! No year, but I've got the day, date and time. Thank you.

Collapse -
I don't have that on my screen
by ritamcbride / March 16, 2012 11:45 PM PDT

Hey macmasters,

Thank you for your responses and suggestions. I am glad this answered the question for Old CelticHippy, but it did not work for me.

'On my Date & Time Control Panel, under Clock, there is one more check box to fill in.
Show date.' I don't have that option. I wish I knew how to capture the window image to show you but under the date & time tab I have only one option to click: 'set date and time automatically'. I can check this (I have it checked) or if I uncheck it I can set the date/time manually. This is my only option under that tab. Then I have a 'time zone' tab and a 'clock' tab.
Under 'clock' tab I have 'show date and time in menu bar' checked. Then under 'view as' I have 'digital' checked. Under digital I have 5 options to pick from: display time w/seconds, show AM/PM, show day of the week, flash time separators, use 24-hour clock. There is no option to show the date at all. I have the option of showing the day checked.

If I could get the short date to show I would be satisfied. I do not need the long date. However, if I download the menu clock from Day-0 would that allow me to see the short date? It looks like os x 10.5.8 won't let me show the date (very strange) but if Day-O would that is all I'm after and this will solve my problem:)

Collapse -
by jiesh / September 12, 2012 4:39 AM PDT
Collapse -
Customize Long Format
by NathanD117 / April 14, 2013 5:01 PM PDT

I know this thread is old, but it should have the correct solution posted in here anyway since it comes up pretty high in a google search. You don't need to install third party software since OSX will display the full date in the menu bar if you know what to select.

In the International pane of the system preferences, you need to select "Customize" in the Times section. In here in the Show: dropdown, select 'Long' format that you need to edit, since that format is what is displayed in the menu bar.

Collapse -
YEA!!!! You guys did it again!
by ritamcbride / March 17, 2012 12:06 AM PDT

Thank you, thank you, thank you. OldCelticHippy did it for me this time:) I disabled the os x date/time and just downloaded day-0. It is just amazing to me how simple it is to fix a problem if you know the right buttons to push Wink

I now have the date, day and time on my menu.

I love this site.


Collapse -
RE: Date won't show in menu-bar
by OldCelticHippy / March 16, 2012 1:08 PM PDT
In reply to: Yes. All checked

Rita, I made a mistake in my post. Do NOT click on the Rocket icon, this opens the Launchpad.

Instead, click on the Blue "A" icon to access the Apple Store. Other than that, everything else I posted is correct.

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

CNET Holiday Gift Guide

Looking for great gifts under $100?

Trendy tech gifts don't require a hefty price tag. Choose from these CNET-recommended useful and high-quality gadgets.