Windows Legacy OS forum

General discussion

Computer on network can't access shared files or printer

by lfchanin / July 21, 2005 11:49 PM PDT

Hi,

I have a two computer wireless home network with both computers running Windows XP. One is in the Den and the other is in the Home Theater. The Home Theater computer is directly wired to the wireless router at 100 Mbps. The Den computer communicates with the wireless router via a wireless UBS adapter at 11 Mbps, and it has a printer connected to it via a printer cable. Both computers have no trouble accessing my broad band Internet connection from the network.

I have setup both computers to share files on the network and to share the Den printer. On either computer it shows both computers networked to the workgroup. That is it shows both the Den and Home Theater icons connected to the MsHome network. On the Den computer it can access the files on the Home Theater computer, and successfully transfers, adds, edits or deletes files.

My problem is that on the Home Theater computer it gets an error message when I click on the Den computer icon. The message says:

''Dencomputer is not accessable. You might not have permission to access this network resource. Contact the administrator of this server to find out if you have access permisions.

The Server service is not started.''

As a consequence I can not access the files on the Den computer or the network printer. To the best of my knowledge my user ID (Larry) automatically logs on with Administrator permissions on both computers. I have also used the network wizard to turn on file and printer sharing on both computers.

Any help would be greatly appreciated.

Thanks.

Larry

Post a reply
Discussion is locked
You are posting a reply to: Computer on network can't access shared files or printer
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Computer on network can't access shared files or printer
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Can't access computer on network
by El Alquimista / July 22, 2005 6:38 AM PDT

Larry -- Have you tried the Windows network troubleshooter?

Go to Help and Support > Networking and the Web > Fixing Network or Web Problems > File and Printer Troubleshooter. Now select I can?t connect to a specific computer on the network and go from there.

If this doesn?t solve your problem, check some of the other options in the troubleshooter.

Hope this helps

Frank

Collapse -
Almost there!
by lfchanin / July 22, 2005 12:42 PM PDT

Frank - Thanks. The troubleshooter helped quite a bit. I was able to finally access the network printer!!

The troubleshooter also suggested accessing the other computers files by typing \\computer\share\ in the run box. (where computer is the other computer and share is the file) This worked giving me access to the other computer.

However, when I went back and selected the dencomputer icon from the MShome workgroup, I continued to receive the same error message and couldn't access the other computer.

Thanks again for your help.

Larry

Collapse -
Can't Access Computer on Network
by guest77 / July 22, 2005 7:25 AM PDT

This is a fairly common problem which involves the ip addresses assigned to each computer by your router. On each computer, you can find the ip address assigned by your router by going to Run on the Start Menu and typing in cmd. In the Command Prompt window that opens type ipconfig and hit enter. Then the ip address of each computer will come up which should be the same except for the last number. For instance, one computer may have an address of 190.170.1.10 and the other will have an ip address of 190.170.1.11.

Now, in Windows Explorer, go the following folder: C:\Windows\System32\drivers\etc. Click on the file in this folder named hosts, and open the file with a text editor such as Notepad. Upon opening the file, you should see on the last line an ip address followed by the word localhost. Start a new line, and type in the ip address of the computer you are using followed by the computer's assigned name on the network. Then start a 3rd line and type in the ip address of your other computer followed by its assigned name on the network. So, for example, if your computers had the ip addresses used in the example used above, and their network names were DEN COMPUTER and HOME THEATER COMPUTER, the text would be as follows:

127.0.0.1 localhost
190.170.1.10 DEN COMPUTER
190.170.1.11 HOME THEATER COMPUTER

After typing in the data, click on Save in the File menu and close the window. Open the same file in your second computer and type in the same data and save. Both computers on your network should now be able to recognize and share files with one another.

Collapse -
Had a little problem.
by lfchanin / July 22, 2005 12:54 PM PDT

guest77-Thanks for the help.

I tried following your instructions and I was able to update the Hosts file on the Home Theater computer, but when I tried to save the Hosts file on the Den computer I received the following error message:

''Can not create c:\Windows\System32\Drivers\etc\hosts file.''

Also I wasn't sure which designation for the computer should be used in the hosts file, the descriptive names or the system assigned names?
For example:
Descriptive names: Den computer & Home Theater
Assigned names: dencomputer & hometheater

Thanks.

Larry

Collapse -
Had a little problem.
by guest77 / July 23, 2005 4:40 AM PDT
In reply to: Had a little problem.

Use should use the names that you assigned to each computer on your network. (Not the descriptive names.) They should be the same names that appear when you open My Network Places and click on Entire Network\Microsoft Windows Network\x, where x is the name that you assigned to your local network.

I'm not sure why you cannot edit and save the text in the hosts file on the one computer. Right click on the file and select properties to make sure that Read-only is not checked.

Another method you may try to have the computers find one another is to right click on My Network Places and select the Search for computers... option. In the box labelled Computer Name, type in the assigned name (not the descripive name) that you gave the other computer when you set up your network. Does that work?

Collapse -
I tried searching network places, but have a problem
by lfchanin / July 24, 2005 7:29 AM PDT
In reply to: Had a little problem.

Thanks.

I tried right-clicking network places and entered dencomputer. I received a response listing two entries.

An icon with Den Computer (Dencomputer) and a second icon with dencomputer

Clicking on both icon yielded the same error message,
"decomputer is not accessable..."

Larry

Collapse -
I've got it working! ...I think.
by lfchanin / July 24, 2005 4:35 PM PDT
In reply to: Had a little problem.

Hi,

I tried renaming the hosts file on the den computer to overcome the problem I was having saving the modified file.

Now I have a dencomputerc on EntireNetwork icon on my Local Network which I can click on to view the C: drive on my den computer from my home theater computer.

The only minor wrinkle is that when I select ''View workgroup computers'' I get the MsHome network showing the den and home theater computers, but when I click on the den computer I continue to get the same error message. Weird.

Thanks for your help.

Larry

Collapse -
I'm making progress, but I still have a problem
by lfchanin / July 25, 2005 4:06 AM PDT
In reply to: Had a little problem.

I've got two hard drives on the den computer, C: and F:. I've set both up as shared drives on the network, and on the den computer they show as shared drives on the network places list.

However, only the den computer's C: drive shows up as a shared drive on the home theater computer's network places list.

Is there a way to force the den computer's F: drive to show up as a shared drive by mapping a drive on the home theater computer?

Thanks.

Larry

Collapse -
check this out
by gopinath_sastra / July 25, 2005 4:13 AM PDT

Hi
The Icons showing Up in Network Places and in View Work Group computers are a shortcut and may be this shortcut is expired and that's the Reason you can Access the shared files using \\computername\

So check this out
Open MyComputer and then Click Tools and then goto Floder Options and then Click on View and Uncheck the Option "Automatically Search For Network Folders and Printers" and then click ok
then once again recheck the Option and see if this works
we are just Refreshing the "NetCrwal" feature in WIndows XP

Collapse -
Thanks, but no luck.
by lfchanin / July 25, 2005 7:21 AM PDT
In reply to: check this out

Thanks for the idea. I tried it several times, but no luck.

When viewing My Network Places on my den computer I noticed two similar icons and I wondered if perhaps that might be the source of the problem. One icon is labeled Public (f) on dencomputer, the other is f on dencomputer.

When I click on these icons in both cases it takes me to the f: drive on den computer.

However, the Public designation is usually automatically assigned to my removable USB drive when it is inserted in a USB port. In this case the USB drive was not installed. As an experiment I installed the USB drive and it automatically added the Public (H) drive to the My Computer list.

Is there a safe means of removing the Public (F) icon from the My Network Places list? I'm concerned if I simply delete it the contents of the f: drive will be deleted. Do these icons represent a shortcut to the folder or do they represent the actual contents of the folder?

Any chance that this similar labeling is causing the problem?

Thanks.

Larry

Collapse -
Workgroup
by Indianasasin / July 25, 2005 3:46 AM PDT

Make sure the workgroup of both computers is the same.

You can find out the name of the workgroup each computer is assigned to by

right clicking on mycomputer

selecting properties

then click on the computer name tab.

Collapse -
Both computers are on MSHOME workgroup
by lfchanin / July 25, 2005 3:59 AM PDT
In reply to: Workgroup

Thanks.

I followed your instructions and both of my computers are listed as being on the MSHOME workgroup.

On the den computer I can access the home theater computer via the workgroup list, but I can't access the den computer via the home theater workgroup list.

I can access the den computer's C: drive via the network places list.

Larry

Collapse -
help
by ase_alem / November 9, 2009 12:41 PM PST

I join this forum not to post a reply but to ask question
the same to Larry because I faced the same problem to him

Collapse -
PC on network can't access shared files or printer (solved)
by ragtoy / August 8, 2010 7:55 AM PDT

Try this...Hope it works for you. all these techs taking you nowhere. you haven't changed any settings to get this problem so why start plugging away at settings now. So very simple your not going to believe it. goto my network places via my computor or how ever you do it. depending on how you pc is set up. Now I'm taking about the laptop with the printer connectivity issue on the network, not the pc with the printers physically conected to it, as I'm almost sure those printers are working fine.
Go to your laptop and click on my network places
Click on view work group computors. Now sign-on or click on the icon showing home pc with the printers physically attached. you should be prompted to sign-on and password just as you would like if you were in front of it, but now your signing on via your network. Once you're in you should be able to see all your network shares via your laptop through the network including all printers. select one of these printers and right click it for a test page you should know how to do this. your going to get a permission notice "your about to connect to a printer "printer name" which will automatically install aprint driver on your machine.... may contain viruses or scripts harmful blah, blah, it is important to be certain that the computor sharing this printer is trustworthy, would you like to contine? Select yes Voila! do this for all net work printers.......... very easy you just needed to sign-on to that pc by way of the network.

Collapse -
2005
by MarkFlax Forum moderator / August 8, 2010 8:16 AM PDT

Since this discussion was in 2005 I am not sure whether your advice will be needed now. They have either solved the problem or moved on.

Mark

Collapse -
there wil be others
by ragtoy / August 11, 2010 1:31 AM PDT
In reply to: 2005

even though there will be more people who come into these forums for insight into their own pc anamolies. hope to help anyone else that may be looking for help. online forums have helped me plenty of times, so lets just pay it forward.

Collapse -
Unlikely
by MarkFlax Forum moderator / August 11, 2010 2:53 AM PDT
In reply to: there wil be others

People tend to 'pass on by' older threads like these.

Mark

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Smartphone tip

Hoarding photos on your phone?

Those picture are hogging memory and could be slowing down your phone.