Windows 7 forum

General discussion

COM interface was not available?

by klanzaro / March 12, 2010 2:51 AM PST

Hallo there..

a) Recently in using Acid Pro 7e (latest version)

b) In creating varying edits

c) I get the following msg, but the program closes down.

" An error occured while processing the undo buffer. You should save your work immediately using a new project filename and restart ACID Pro. A necessary COM interface was not available. You many need to reboot your computer."

d) I renamed & rebooted. Though the problem still exists.

e) The problem is not just isolated to 1 single project in Acid. It's happening in various Acid projects.

Thanks!

Post a reply
Discussion is locked
You are posting a reply to: COM interface was not available?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: COM interface was not available?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Stumper.
by R. Proffitt Forum moderator / March 12, 2010 3:39 AM PST
Collapse -
thanks... Security Suite?
by klanzaro / March 12, 2010 6:03 AM PST
In reply to: Stumper.

Hi Stumper...

Thank-you for the interesting reply..

Pardon my ignorance.... What is a security suite? And how does one change it? Are you meaning a program like Avast or McAfee? I'm not using any Anti-virus or Windows Defender or any Win Security updates on the computer at hand with the issue. It's offline & I use it specifically for music work.

Please suggest further if possible...

All the best....
k

Collapse -
That may be a clue.
by R. Proffitt Forum moderator / March 12, 2010 6:05 AM PST

Since it is off I wonder if there are updates that are missing.

Since there is no security suite, there is nothing to discusse there.
Bob

Collapse -
ahh...
by klanzaro / March 12, 2010 7:06 AM PST
In reply to: That may be a clue.

Wouldn't the updates that may potentially be missing, be updates to further Microsoft security updates though? I cancel all security updates for this computer isn't online and have no worry of invasion... security updates seem to clutter up my PC. I only update pertinent system updates for the OS & drivers.

thanks again!

Collapse -
And that's another clue.
by R. Proffitt Forum moderator / March 12, 2010 10:09 AM PST
In reply to: ahh...

If the machine was working, offline why would anyone update the OS or drivers?

My thought is to go back to when it worked with System Restore.

Collapse -
thanks... but it's a software issue.
by klanzaro / March 12, 2010 8:21 PM PST

Hi there...

again, thanks for the suggests.

the issue, is related to ACID PRO 7 (latest version) - a software issue that is related to a: COM interface & an "undo buffer"... as the error msg states.

It arises only when trying to implement specific edits like pasting a group of files or inserting "time, a.k.a. bars of blank music space".

My naive guess is that this is a C++ or .NET Framwork issue related to perhaps in the program design itself? For C++ relates to COM interface issues. Also, the error/crash, doesn't happen in earlier versions of the program. And the new version is implementing C++ 2008 now.

Tech support at SONY Acid, are clueless and don't provide knowledgeable support either... they give always, a generic fix "please, re-install the program" - which doesn't work.

Guess I will have to revert to using the old version of the program unless I figure out a fix of some sort. My hope was to figure out what exactly was giving me the specific "error msg" stated above.

Thanks again so much for taking interest - kind of you.

Collapse -
What I can't tell.
by R. Proffitt Forum moderator / March 12, 2010 10:04 PM PST

Re-reading this discussion it sounds like it always failed like this. If so you have found a software bug.

I was under the impression it was working then not.
Bob

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Smartphone tip

Hoarding photos on your phone?

Those picture are hogging memory and could be slowing down your phone.